It is currently 01 Oct 2014 20:16


Make Exaile default for MP3

Questions about software.
  • Author
  • Message
Offline

chrispop

  • Posts: 12
  • Joined: 23 Dec 2013 11:53

Make Exaile default for MP3

Post23 Dec 2013 11:59

Hi,

I want to make Exaile the default for MP3's. In Thunar, I can right-click an MP3 file, select properties, then use the 'Open with' dropdown to try to change from VLC to Exaile, but VLC remains selected.
Googling hasn't produced anything helpful. Trying to change it as root doesn't help.
If I temporarily uninstall VLC, MP3's open in Exaile fine, but when VLC is re-installed it takes over again.
Any thoughts for me please?

Chris
Offline
User avatar

smackthepony

  • Posts: 147
  • Joined: 28 Oct 2013 13:49
  • Location: the low countries

Re: Make Exaile default for MP3

Post23 Dec 2013 12:51

have you tried changing the mimeapps.list?
It can be found in your local folder.
Code: Select all
sudo nano .local/share/applications/mimeapps.list

mimelist.jpeg
Image
Offline

chrispop

  • Posts: 12
  • Joined: 23 Dec 2013 11:53

Re: Make Exaile default for MP3

Post23 Dec 2013 14:36

smackthepony wrote:have you tried changing the mimeapps.list?
It can be found in your local folder.


Thanks for the reply, but the problem is still the same.

(I rebooted after the change you suggested, and re-checked in mimeapps.list that it was still set to Exaile, but I still can't set VLC as the default.)

Chris
Offline
User avatar

smackthepony

  • Posts: 147
  • Joined: 28 Oct 2013 13:49
  • Location: the low countries

Re: Make Exaile default for MP3

Post23 Dec 2013 15:00

chrispop wrote:but I still can't set VLC as the default.)

Chris

I'm confused here, in your first post you wanted to make Exaile default. :?
Image
Offline

chrispop

  • Posts: 12
  • Joined: 23 Dec 2013 11:53

Re: Make Exaile default for MP3

Post23 Dec 2013 15:25

smackthepony wrote:
chrispop wrote:but I still can't set VLC as the default.)

Chris

I'm confused here, in your first post you wanted to make Exaile default. :?


So sorry; trying to do too many things at once!

Yes, I want to make Exaile the default.

Chris
Offline
User avatar

smackthepony

  • Posts: 147
  • Joined: 28 Oct 2013 13:49
  • Location: the low countries

Re: Make Exaile default for MP3

Post23 Dec 2013 16:12

NP :D

Ok taken from the XFCE site (http://www.xfce.org/about/tour) do you have a MIME Type Editor in you system settings?
If you have you can change the preferred application for lots of different filetypes.
Image
Offline

chrispop

  • Posts: 12
  • Joined: 23 Dec 2013 11:53

Re: Make Exaile default for MP3

Post23 Dec 2013 16:36

Yes, Mime Type Editor exists in Settings, but there is no entry in it for MP3 files and no way of creating a new entry as far as I can see.

Chris
Offline
User avatar

smackthepony

  • Posts: 147
  • Joined: 28 Oct 2013 13:49
  • Location: the low countries

Re: Make Exaile default for MP3

Post23 Dec 2013 17:06

in filter--> type mpeg and you will see several filetypes including audio/mpeg. Try changing that one to Exaile.
Hope this 1 works :)
Image
Offline

chrispop

  • Posts: 12
  • Joined: 23 Dec 2013 11:53

Re: Make Exaile default for MP3

Post23 Dec 2013 18:18

smackthepony wrote:in filter--> type mpeg and you will see several filetypes including audio/mpeg. Try changing that one to Exaile.
Hope this 1 works :)


Sadly not; it was already set to Exaile.

Chris
Offline
User avatar

smackthepony

  • Posts: 147
  • Joined: 28 Oct 2013 13:49
  • Location: the low countries

Re: Make Exaile default for MP3

Post23 Dec 2013 20:13

This is the last solution i found
In Thunar right click on the file you want to open with Exaile --> Properties and then change the open with program to Exaile
If it shouldn.t work try it by opening thunar as root.
Fingers crossed :roll:
Image
Offline

Renderer

  • Posts: 27
  • Joined: 08 Aug 2013 18:29

Re: Make Exaile default for MP3

Post23 Dec 2013 20:15

The other spot to edit is: gksudo nano /usr/share/applications/defaults.list.
Offline

chrispop

  • Posts: 12
  • Joined: 23 Dec 2013 11:53

Re: Make Exaile default for MP3

Post23 Dec 2013 21:18

smackthepony wrote:This is the last solution i found
In Thunar right click on the file you want to open with Exaile --> Properties and then change the open with program to Exaile
If it shouldn.t work try it by opening thunar as root.
Fingers crossed :roll:


Thanks; that's where I started from. The dropdown to change the default program is set to VLC. If I select it, Exaile is there, but as soon as the dropdown closes, it is back to VLC.

I have tried doing it both by opening Thunar as root, and as logging on as root, but the same thing happens.

Just for further information, I am having this problem with a 64-bit install on a laptop. I have a spare desktop machine, so I temporarily installed the 32-bit version, and exactly the same problem happens.

Chris
Offline

chrispop

  • Posts: 12
  • Joined: 23 Dec 2013 11:53

Re: Make Exaile default for MP3

Post23 Dec 2013 21:24

Renderer wrote:The other spot to edit is: gksudo nano /usr/share/applications/defaults.list.


The file 'defaults.list' does not exist in that location either on this machine, or on one with a SolydX 32-bit install. There are only .desktop files, and one text file called mimeinfo.cache. If I examine that file, there is a line in it thus:

Code: Select all
audio/mp3=exaile.desktop


which would seem to be correct.

It's proving to be a tricky thing to track down!

Chris
Offline
User avatar

smackthepony

  • Posts: 147
  • Joined: 28 Oct 2013 13:49
  • Location: the low countries

Re: Make Exaile default for MP3

Post23 Dec 2013 21:41

purging and reinstalling Exaile is the last thing i can think of.
Or perhaps try another musicplayer like Clementine

I'm all out of thoughs on this 1 :(
Image
Offline

Renderer

  • Posts: 27
  • Joined: 08 Aug 2013 18:29

Re: Make Exaile default for MP3

Post23 Dec 2013 21:43

OK, let's try this: make a backup of .local/share/applications/mimeapps.list, then global replace all instances of vlc.desktop with exaile.desktop, then see if you haven't fixed the problem. There are so many different audio and video formats that you may not be changing all the appropriate ones.

Best of luck.
Offline

chrispop

  • Posts: 12
  • Joined: 23 Dec 2013 11:53

Re: Make Exaile default for MP3

Post23 Dec 2013 21:58

Renderer wrote:OK, let's try this: make a backup of .local/share/applications/mimeapps.list, then global replace all instances of vlc.desktop with exaile.desktop, then see if you haven't fixed the problem. There are so many different audio and video formats that you may not be changing all the appropriate ones.

Best of luck.


What would be the effect on files that I want to open in VLC if I do this?

I've just tried changing the default for jpg from Ristretto to Image Magik using the same context menu method. The change worked successfully, but when I tried to change back to Ristretto I had the same problem. The dropdown is 'stuck' on Image Magik now.

I'm beginning to think this problem is related to the lack of a defaults.list file in /usr/share/applications. Checking another recent XFCE distro shows that file exists.

Is anyone else able to replicate what I am seeing please? That is, right-clicking on an mp3 in Thunar, selecting Properties, then using the Open With dropdown doesn't let you change from VLC.

Chris
Offline

Renderer

  • Posts: 27
  • Joined: 08 Aug 2013 18:29

Re: Make Exaile default for MP3

Post24 Dec 2013 00:28

Yeah, that's a valid concern. That's why I suggested making a backup, because then you can individually restoring what used to be vlc.desktop, to see which ones effect your mp3 files.

Hope this helps.
Offline

chrispop

  • Posts: 12
  • Joined: 23 Dec 2013 11:53

Re: Make Exaile default for MP3

Post27 Dec 2013 09:46

Further testing has revealed that the inability to change preferred program for a given file type affects more than multimedia files. It is also impossible to change preferred program for things like text files and JPG's after the first change. (IOW, I can change the default for an image from Ristretto to GIMP and it works. If I then try to change back from GIMP to Ristretto or any other program, the dropdown won't change from GIMP.)

This happens on both the 32- and 64-bit versions of the latest releases, on three different pieces of hardware.

I have tried everything suggested here (thanks all), anything I could think of myself, and anything I found that seemed relevant online. I'm sure this is going to be a simple fix like a config file missing or in the wrong place, but I don't have the skills to fix it.

This is such a great distro in every other respect, but this problem is a show-stopper for me. I will move on simply because I have no other ideas. I will leave one machine with SolydX on until I need it; in the meantime, if anyone else has any thoughts, I would love to hear them!

Chris
Offline
User avatar

smackthepony

  • Posts: 147
  • Joined: 28 Oct 2013 13:49
  • Location: the low countries

Re: Make Exaile default for MP3

Post27 Dec 2013 10:47

I usually just start my music player to play music from my symlinked other drive, but Chrispop got me thinking.
Being a K user myself i wondered how hard can it be to change file associations in system settings. Unlike Chrispop using MP3 i use Lossless (FLAC) for my music files but the problem remains the same. After setting (in my case) Clementine as preferred application and applying the settings i get a updating system configuration message but nothing gets updated because when double clicking a FLAC file i get VLC by default (rechecking system settings shows VLC as preferred application again) so somewhere along the line this setting is not saved or overruled somehow.
Image
Offline
User avatar

Uzi

  • Posts: 44
  • Joined: 27 Dec 2013 08:05

Re: Make Exaile default for MP3

Post27 Dec 2013 11:39

Hi

New member. I installed SolydX a few days ago & so far I am impressed. Joined the forum to ask about this very subject.

I use SMPlayer & VLC for movies & TV. I prefer SMPlayer as my default. Using the drop down 'open with' option, I have successfully changed avi & mkv files from VLC default but like the OP, mpeg 4 files refuse to change even though SMPlayer is selected. Mpeg 4 play on SMPlayer with no issue but cannot set as the default.

Uzi
Next

Return to Software

Who is online

Users browsing this forum: No registered users and 3 guests