Upgrade problem with solydk-system-adjustments-9

Questions about SolydX and SolydK installation.
silopolis
Posts: 15
Joined: 13 Aug 2013 08:13
Location: Avignon, France
Contact:

Upgrade problem with solydk-system-adjustments-9

Postby silopolis » 19 Jun 2017 16:19

Hi,

I've upgraded my system today and except for a couple of packages, everything went smouth :) Still have to reboot the machine though...

The only errors I got was for gpsd:

Code: Select all

Setting up gpsd (3.16-4) ...
Creating/updating gpsd user account...
A dependency job for gpsd.service failed. See 'journalctl -xe' for details.
invoke-rc.d: initscript gpsd, action "start" failed.
● gpsd.service - GPS (Global Positioning System) Daemon
   Loaded: loaded (/lib/systemd/system/gpsd.service; indirect; vendor preset: enabled)
   Active: inactive (dead)

Jun 19 12:37:22 lapje01 systemd[1]: Dependency failed for GPS (Global Positioning System) Daemon.
Jun 19 12:45:55 lapje01 systemd[1]: Dependency failed for GPS (Global Positioning System) Daemon.
Jun 19 12:45:55 lapje01 systemd[1]: gpsd.service: Job gpsd.service/start failed with result 'dependency'.
Jun 19 12:46:25 lapje01 systemd[1]: Dependency failed for GPS (Global Positioning System) Daemon.
Jun 19 12:46:25 lapje01 systemd[1]: gpsd.service: Job gpsd.service/start failed with result 'dependency'.
Jun 19 16:42:24 lapje01 systemd[1]: Dependency failed for GPS (Global Positioning System) Daemon.
Jun 19 16:42:24 lapje01 systemd[1]: gpsd.service: Job gpsd.service/start failed with result 'dependency'.
Jun 19 16:42:37 lapje01 systemd[1]: Dependency failed for GPS (Global Positioning System) Daemon.
Jun 19 16:42:37 lapje01 systemd[1]: gpsd.service: Job gpsd.service/start failed with result 'dependency'.
dpkg: error processing package gpsd (--configure):
 subprocess installed post-installation script returned error exit status 1


Which I don't really care about... But I'm a lot more concerned about solydk-system-adjustments-9 which fails with:

Code: Select all

Setting up solydk-system-adjustments-9 (2.8.0) ...
/usr/bin/python3: can't open file '/usr/lib/solydxk/system/adjust.py': [Errno 2] No such file or directory
dpkg: error processing package solydk-system-adjustments-9 (--configure):
 subprocess installed post-installation script returned error exit status 2


May I safely ignore this error until a fixed package is released and restart my computer to complete the upgrade ? Or should I put the machine on hold ?

Thanks in advance for your answers
Bests

PS: I should mention that, may be in a misunderstanding of other forum messages (?!), I have manually purged solydk-system-adjustments-8 and installed solydk-system-adjustments-9 before running the upgrade dist-upgrade combo

User avatar
ilu
Posts: 1410
Joined: 09 Oct 2013 12:45

Re: Debian Stretch released

Postby ilu » 19 Jun 2017 17:53

silopolis wrote:PS: I should mention that, may be in a misunderstanding of other forum messages (?!), I have manually purged solydk-system-adjustments-8 and installed solydk-system-adjustments-9 before running the upgrade dist-upgrade combo

Those instructions were for people who already ran stretch/testing.

Please post the output of

Code: Select all

dpkg -l solyd* |grep ii
. You could also try

Code: Select all

sudo apt-get install --reinstall solydk-system-adjustments-9

User avatar
Schoelje
Site Admin
Posts: 8264
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Debian Stretch released

Postby Schoelje » 19 Jun 2017 18:42

/usr/lib/solydxk/system/adjust.py is part of the solydxk-system package. Check if you have that installed.


SolydXK needs you!
Development | Testing | Translations

User avatar
ilu
Posts: 1410
Joined: 09 Oct 2013 12:45

Re: Upgrade problem with solydk-system-adjustments-9

Postby ilu » 20 Jun 2017 00:03

Regading gpsd: Maybe this bugreport helps? https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=818332

silopolis
Posts: 15
Joined: 13 Aug 2013 08:13
Location: Avignon, France
Contact:

Re: Upgrade problem with solydk-system-adjustments-9

Postby silopolis » 23 Jun 2017 07:57

Indeed solydxk-system was not present and installing it allowed solydk-system-adjustments-9 to configure without problem !

Still, don't know if I should worry about this missing package as it seems quite essential, at least from its name...

Here is the list of solyd* packages installed on my system after fixing:

Code: Select all

dpkg -l solyd* |grep ii                                                                                                                                                   
ii  solydk-system-adjustments-9         2.8.0           all          Adjustments specific to SolydK (version 9, stretch).                                                       
ii  solydkee-info                       1.0.5           all          Info package for SolydK EE.                                                                               
ii  solydxk-flashplugin-11              11.2.202.644xk1 amd64        Adobe Flash plugin 11                                                                                     
ii  solydxk-keyring                     2016.03.29      all          GnuPG key of the SolydXK repository                                                                       
ii  solydxk-mozilla-evolvere-icon-theme 0.1.1           all          Evolvere desktop icon theme                                                                               
ii  solydxk-softwaremanager             7.6.9           all          Software Manager                                                                                           
ii  solydxk-system                      2.6.1           all          SolidXK System Base Package                                                                               


Hope nothing else missing

Thank you very much for your fast support !
Now going for a reboot to enjoy your great work...

Have a very good night
Jeremie


Return to “Installation”

Who is online

Users browsing this forum: No registered users and 0 guests