UP 2013.11.06 09:00 UTC [PRODUCTION] [DONE]

Important informations about SolydXK including releases notes, forum rules and other anouncements
User avatar
Snap
Posts: 1244
Joined: 25 Aug 2013 20:01
Location: Spain

Re: UP 2013.11.06 09:00 UTC [PRODUCTION]

Postby Snap » 12 Nov 2013 08:00

zerozero wrote:in the end of the day you did very well.
sorry for all the troubles :oops:
cya tomorrow
No worries. These things happen. Computers and OSs are bitches! :mrgreen:

The good part is I've learnt a lot within the proccess. The hard way, but it's usually the way to go with these devices.

I need to edit a song for a customer now. I'll go over the Nvidia thing later. I'll report back.

PS, By the way. Thanks a lot for your constant help, zerozero and Schoelje.
This likely means that your installation is broken. -Mr Pixbuf.

Image

User avatar
ChipButty
Posts: 21
Joined: 19 Jun 2013 23:52

Re: UP 2013.11.06 09:00 UTC [PRODUCTION]

Postby ChipButty » 12 Nov 2013 08:52

After reading along some of these posts I thought I'd open up the DDM and change the video driver from Nvidia (319.xx) and see what happens. The first change was awful with a 640x480 looking resolution. So I changed again, forget which and am now unable to get to a desktop and am left with just a command line. On the plus side my fonts are lovely! What do I need to do to get my KDE desktop back?

User avatar
Snap
Posts: 1244
Joined: 25 Aug 2013 20:01
Location: Spain

Re: UP 2013.11.06 09:00 UTC [PRODUCTION]

Postby Snap » 12 Nov 2013 09:18

Huh... I was in that situation a few times yesterday. Login as root in the tty1. Then:

Code: Select all

sudo rm /etc/X11/xorg.conf

sudo rm /etc/modprobe.d/nvidia*

sudo rm /etc/modprobe.d/blacklist-nouveau.conf

sudo apt-get purge nvidia*
Then check for any persistent Nvidia package still there. The output should be nothing.

Code: Select all

apt search nvidia | grep ^i
Reboot

It should start kdm again on the Nouveau driver. Now you can try to install the 304 if that was what you had before.

BTW, The fonts were always right here.
This likely means that your installation is broken. -Mr Pixbuf.

Image

eidnch
Posts: 21
Joined: 12 Nov 2013 09:38

Re: UP 2013.11.06 09:00 UTC [PRODUCTION]

Postby eidnch » 12 Nov 2013 10:04

The upgrade with my nvidia driver also don't worked. I had to make the upgrade with the terminal, because the updatemanger didn't work this time because a dependency problem also mentioned in this posts. I followed the pre- and post-upgrade-instructions, but the displaymanager could not load. I also need the 304 driver. The workaround in this posts helped:

sudo rm /etc/X11/xorg.conf

in /etc/modprobe.d/ was no nvidia entry

sudo apt-get purge nvidia*

After that i reinstalled the nvidia driver with the device driver manager and now all is ok.

But i would wish for the next time, that there would be a script to handel a upgrade with the nvidia driver. For debian exists the sgfxi script. It works also for SolydXK? Perhaps it would be a option to implement it in the updatemanager ... ? I hope that i don't have to deinstall and reinstall the nvidia driver every upgrade process.

User avatar
twa
Posts: 24
Joined: 22 Jul 2013 20:10
Location: flown west

Re: UP 2013.11.06 09:00 UTC [PRODUCTION]

Postby twa » 12 Nov 2013 12:56

Hi,
make life easy....use smxi / sgfxi.
http://smxi.org/
On all Debian based distro I have tried / used, I always have let the script take care of updates and Nvidia drivers
installation, I'm actually on Liquorix kernel 3.11.2 and nVidia driver 304.108 .
Once you have read and understood how it works everything is very easy.
:mrgreen:

Nomen Nescio
Posts: 63
Joined: 02 Oct 2013 09:01

Re: UP 2013.11.06 09:00 UTC [PRODUCTION]

Postby Nomen Nescio » 12 Nov 2013 19:21

After wasting time fighting (nvidia)drivers on different distro's I also prefer smxi, even on ubuntu based distro's if jockey wasn't able to activate the driver, sgfxi did the job, takes care of updating grub and initramfs as well.

User avatar
Snap
Posts: 1244
Joined: 25 Aug 2013 20:01
Location: Spain

Re: UP 2013.11.06 09:00 UTC [PRODUCTION]

Postby Snap » 13 Nov 2013 07:00

This sounds very interesting.
Installing with the smxi stub installer
A few lucky users (for example, antiX 8.0 and later) are running distros that are using the smxi stub installer (svn source page). This lets you install any of the supported scripts by simply typing in the following commands, as root:
smxi

# or for sgfxi
sgfxi

# or for svmi
svmi
The stub installer downloads and starts the scripts if they are missing, otherwise it just runs the script directly. This is by far the most pleasant, and the easiest, way to install and start the scripts, but it requires a preinstalled smxi stub installer to work.
What about including this in SolydXK as default, Devs?
This likely means that your installation is broken. -Mr Pixbuf.

Image

User avatar
Arjen Balfoort
Site Admin
Posts: 9518
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP 2013.11.06 09:00 UTC [PRODUCTION]

Postby Arjen Balfoort » 13 Nov 2013 07:23

The discussion about sgfxi isn't new. So, it makes my anwer easier
If I remember well, correct me if I'm wrong, it's been a while, sgfxi downloads the proprietary drivers from Nvidia's site, and installs them.
Not that I have problems with proprietary software, but it's not something we can support.
It's complicated enough to support all that's related with our repositories.

sgfxi is not meant for people with little or no Linux experience, and that's why I created DDM.

DDM only uses what's in the repositories, and that's where we have to trust Debian's packagers and maintainers.
The issues we have now is that a new legacy package has been released, and some drivers were moved from Nvidia's main driver package to the new legacy package.
Unfortunately, not all packages were adapted to reflect that change, leaving both the main, and the legacy drivers installed, breaking the system.
Hence, the workaround I wrote in the UP info page. We know now that the workaround did not work in all situations, and that's something we cannot prevent from happening, unfortunately.

In short: we're not going to support sgfxi in SolydXK.


SolydXK needs you!
Development | Testing | Translations

User avatar
Snap
Posts: 1244
Joined: 25 Aug 2013 20:01
Location: Spain

Re: UP 2013.11.06 09:00 UTC [PRODUCTION]

Postby Snap » 13 Nov 2013 07:36

Understood. 8-)
This likely means that your installation is broken. -Mr Pixbuf.

Image

iain1940
Posts: 23
Joined: 09 Mar 2013 08:22
Location: UK

Re: UP 2013.11.06 09:00 UTC [PRODUCTION]

Postby iain1940 » 16 Nov 2013 16:03

I attempted UP 1013.11.06 on 9th Nov after backing up system with Clonezilla.

I downloaded the update and ran the (updated) Update manager, when I came back to the screen there was a error comment relating to

'lib6c:i386
libgcc1:i386'

(sorry - I didn't get more details)

I rebooted and the restart hung after displaying the Nvidia logo on both screens.

I was quite busy at the time so I restored the system and stayed with the previous version.

I am now hoping to re-attempt the update.

I am running XFCE - Solydx-64 on a i5

machine details :

Code: Select all

$15:31:22 ~ >inxi
CPU~Quad core Intel Core i5 CPU 750 (-MCP-) clocked at 1200.000 Mhz Kernel~3.10-3-amd64 x86_64 Up~5:55 Mem~1133.5/12044.8MB HDD~5281.1GB(15.5% used) Procs~188 Client~Shell inxi~1.9.14  
$
$15:29:32 ~ >inxi -Gxx
Graphics:  Card: NVIDIA G94 [GeForce 9600 GT] bus-ID: 01:00.0 chip-ID: 10de:0622 
           X.Org: 1.12.4 driver: nvidia Resolution: 1680x1050@60.0hz, 1280x1024@60.0hz 
           GLX Renderer: GeForce 9600 GT/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 304.108 Direct Rendering: Yes

$15:29:32 ~ >nvidia-detect
Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G94 [GeForce 9600 GT] [10de:0622] (rev a1)
Your card is supported by the default drivers and version 173.
It is recommended to install the
    nvidia-glx
package.
$15:38:47 ~ >uname -a
Linux dylan 3.10-3-amd64 #1 SMP Debian 3.10.11-1 (2013-09-10) x86_64 GNU/Linux

The previous update worked only after I had disabled Plymouth.

As you can see I am running Nvidia drivers with dual monitors.
I also installed
qt4-tools
qt4-desktop
which may be relevent.

What should I do (apart from another Clonezilla!) before retrying the update ?

Sorry if this is going over old ground.
Thanks

User avatar
Arjen Balfoort
Site Admin
Posts: 9518
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP 2013.11.06 09:00 UTC [PRODUCTION]

Postby Arjen Balfoort » 16 Nov 2013 21:05

Try to upgrade through terminal as described in the info page included in the Opening Post of this topic.
This should have been done by the UM, but as you can see in this topic, there were some problems with the Nvidia drivers.

If you end up in a black screen again, follow these steps to purge Nvidia from your system: http://forums.solydxk.nl/viewtopic.php?p=19395#p19395

When done, you can install the Nvidia drivers with DDM again.


SolydXK needs you!
Development | Testing | Translations

DLWood
Posts: 22
Joined: 02 May 2013 18:32

Re: UP 2013.11.06 09:00 UTC [PRODUCTION]

Postby DLWood » 16 Nov 2013 21:30

I haven't attempted the update yet because of the Nvidia driver issues. Has anyone tried to revert back to the Nouveau driver and then perform the update? If so, did it work?

iain1940
Posts: 23
Joined: 09 Mar 2013 08:22
Location: UK

Re: UP 2013.11.06 09:00 UTC [PRODUCTION]

Postby iain1940 » 16 Nov 2013 23:52

Try to upgrade through terminal as described in the info page included in the Opening Post of this topic.
This should have been done by the UM, but as you can see in this topic, there were some problems with the Nvidia drivers.
Thanks !

90 minutes later - lots of crossed fingers - everything (all the bits I've looked at) working.
I followed the Opening Post - no problems

Thanks again Schoelje - great on-line support

Iain

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP 2013.11.06 09:00 UTC [PRODUCTION]

Postby zerozero » 16 Nov 2013 23:59

DLWood
follow Schoelje's last post (and the link there included if anything goes wrong in the process); this should give you a safe upgrade.
bliss of ignorance

User avatar
Gonzalo_VC
Posts: 321
Joined: 07 May 2013 13:25
Location: SouthAmerica

Re: UP 2013.11.06 09:00 UTC [PRODUCTION]

Postby Gonzalo_VC » 18 Nov 2013 15:37

Schoelje wrote:@Gonzalo_VC
In terminal, before upgrading:

Code: Select all

sudo apt-get purge libxvmcnvidia1 libxvmcnvidia1:i386
apt-get install libegl1-mesa-drivers
sudo apt-get install libc6 libc6:i386
sudo apt-get dist-upgrade
The purge line is only needed when you have the files installed.
Let's see if this works.
Sorry, but nope.
I got:

Code: Select all

O pacote 'libxvmcnvidia1' não está instalado, por isso não será removido
O pacote 'libxvmcnvidia1:i386' não está instalado, por isso não será removido
Você deve querer executar 'apt-get -f install' para corrigí-los:
Os pacotes a seguir têm dependências desencontradas:
 cpp-4.8 : Depende: gcc-4.8-base (= 4.8.1-10) mas 4.8.2-1 está para ser instalado
 g++-4.8 : Depende: gcc-4.8-base (= 4.8.1-10) mas 4.8.2-1 está para ser instalado
 gcc-4.8 : Depende: gcc-4.8-base (= 4.8.1-10) mas 4.8.2-1 está para ser instalado
 libasan0 : Depende: gcc-4.8-base (= 4.8.1-10) mas 4.8.2-1 está para ser instalado
 libatomic1 : Depende: gcc-4.8-base (= 4.8.1-10) mas 4.8.2-1 está para ser instalado
 libgcc-4.8-dev : Depende: gcc-4.8-base (= 4.8.1-10) mas 4.8.2-1 está para ser instalado
 libgfortran3 : Depende: gcc-4.8-base (= 4.8.1-10) mas 4.8.2-1 está para ser instalado
 libgomp1 : Depende: gcc-4.8-base (= 4.8.1-10) mas 4.8.2-1 está para ser instalado
 libitm1 : Depende: gcc-4.8-base (= 4.8.1-10) mas 4.8.2-1 está para ser instalado
 libquadmath0 : Depende: gcc-4.8-base (= 4.8.1-10) mas 4.8.2-1 está para ser instalado
 libstdc++-4.8-dev : Depende: gcc-4.8-base (= 4.8.1-10) mas 4.8.2-1 está para ser instalado
 libstdc++6 : Depende: gcc-4.8-base (= 4.8.1-10) mas 4.8.2-1 está para ser instalado
 libstdc++6:i386 : Depende: gcc-4.8-base:i386 (= 4.8.1-10) mas 4.8.2-1 está para ser instalado
 libtsan0 : Depende: gcc-4.8-base (= 4.8.1-10) mas 4.8.2-1 está para ser instalado
E: Dependências desencontradas. Tente 'apt-get -f install' sem nenhum pacote (ou especifique uma solução).
That in English means: the package 'libxvmcnvidia1:i386 9and the other) is not installed, so it won't get removed.
It suggest apt-get -f install that doesn't work either.

Code: Select all

# apt-get -f install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
Os pacotes extra a seguir serão instalados: {this extra packages will be installed}
  binutils cpp-4.8 g++-4.8 gcc-4.8 libasan0 libatomic1 libgcc-4.8-dev libgfortran3 libgomp1 libitm1
  libquadmath0 libstdc++-4.8-dev libstdc++6 libstdc++6:i386 libtsan0
Pacotes sugeridos: {suggested packages}
  binutils-doc gcc-4.8-locales g++-4.8-multilib gcc-4.8-doc libstdc++6-4.8-dbg gcc-4.8-multilib
  libmudflap0-4.8-dev libgcc1-dbg libgomp1-dbg libitm1-dbg libatomic1-dbg libasan0-dbg libtsan0-dbg
  libbacktrace1-dbg libquadmath0-dbg libmudflap0-dbg libstdc++-4.8-doc
Os pacotes a seguir serão atualizados: {the following packages will be updated}
  binutils cpp-4.8 g++-4.8 gcc-4.8 libasan0 libatomic1 libgcc-4.8-dev libgfortran3 libgomp1 libitm1
  libquadmath0 libstdc++-4.8-dev libstdc++6 libstdc++6:i386 libtsan0
15 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 627 não atualizados.
4 pacotes não totalmente instalados ou removidos.
É preciso baixar 0 B/26,4 MB de arquivos.
Depois desta operação, 10,2 kB adicionais de espaço em disco serão usados.
Você quer continuar [S/n]? s
[color=#800000]dpkg: erro ao processar libc6:amd64 (--configure):[/color]
 o pacote libc6:amd64 não pode ser configurado porque libc6:i386 não está pronto (estado actual 'half-installed')
dpkg: problemas com dependências impedem a configuração de libgcc1:amd64:   {dependency problem!}
 libgcc1:amd64 depende de libc6 (>= 2.14); porém:
  Pacote libc6:amd64 não está configurado ainda.  {says this one and others are not configured}

dpkg: erro ao processar libgcc1:amd64 (--configure):
 problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
 libc6:amd64
 libgcc1:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1) 
I'll appreciate some more help :roll:

Don't be a pirate, nor a slave. Use GNU/Linux!
GNU/Linux user 451206
SolydXK, GALPon MiniNo, PCLinuxOS, Xubuntu




Return to “News & Anouncements”

Who is online

Users browsing this forum: No registered users and 3 guests