UP and BE/BO 2014.04.15 [CLOSED]

Important informations about SolydXK including releases notes, forum rules and other anouncements
User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP and BE/BO 2014.04.15

Postby zerozero » 15 Apr 2014 13:55

Reyfer
in a terminal

Code: Select all

sudo /etc/init.d/cups stop
bliss of ignorance

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP and BE/BO 2014.04.15

Postby zerozero » 15 Apr 2014 13:58

fkef
can you please attach in your next post the updatemanager.log (in /var/log/) and history.log (in /var/log/apt/)
[you might have to compress them, they should be huge]
bliss of ignorance

fkef
Posts: 83
Joined: 26 Aug 2013 11:45

Re: UP and BE/BO 2014.04.15

Postby fkef » 15 Apr 2014 14:02

See attached files
Attachments
updatemanager.log.tar.gz
(120.9 KiB) Downloaded 49 times
history.log.tar.gz
(15.89 KiB) Downloaded 49 times

User avatar
wyrdoak
Posts: 113
Joined: 07 Jan 2014 21:25

Re: UP and BE/BO 2014.04.15

Postby wyrdoak » 15 Apr 2014 14:14

Kwin crashed and will not restart tried rebooting and changing the rendering mode, still nothing.

Code: Select all

Graphics:  Card: Intel Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller bus-ID: 00:02.0 chip-ID: 8086:a011 
           X.Org: 1.15.0 drivers: intel (unloaded: fbdev,vesa) Resolution: 1680x1050@60.0hz 
           GLX Renderer: Mesa DRI Intel IGD x86/MMX/SSE2 GLX Version: 2.1 Mesa 9.2.2 Direct Rendering: Yes
Attachments
updatemanager.log.zip
(133.15 KiB) Downloaded 45 times

Acer Aspire One AO532h; CPU Atom n450 1.66Gh: 2GB RAM, duel boot with Win7: SolydK32

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP and BE/BO 2014.04.15

Postby zerozero » 15 Apr 2014 14:24

Code: Select all

15-04-2014 14:30:21 UM.on_line_added              INFO      Lined added: E: Kunde inte hitta paketet firefox-l10n-sv

Code: Select all

15-04-2014 14:30:22 UM.on_line_added              INFO      Lined added: E: Kunde inte hitta paketet thunderbird-l10n-sv
does this mean that APT can't find the locales for FF/TB? if so it aborts the installation because of that.
bliss of ignorance

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP and BE/BO 2014.04.15

Postby zerozero » 15 Apr 2014 14:26

@wyrdoak
what windeco and window style are you using?
try to change both to oxygen
bliss of ignorance

User avatar
Arjen Balfoort
Site Admin
Posts: 9258
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP and BE/BO 2014.04.15

Postby Arjen Balfoort » 15 Apr 2014 14:29

It should be firefox-l10n-sv-se
The script isn't that intelligent...


SolydXK needs you!
Development | Testing | Translations

User avatar
wyrdoak
Posts: 113
Joined: 07 Jan 2014 21:25

Re: UP and BE/BO 2014.04.15

Postby wyrdoak » 15 Apr 2014 14:34

zerozero wrote:@wyrdoak
what windeco and window style are you using?
try to change both to oxygen

Was using diamond switch everything to oxygen, still nothing.

Acer Aspire One AO532h; CPU Atom n450 1.66Gh: 2GB RAM, duel boot with Win7: SolydK32

User avatar
Arjen Balfoort
Site Admin
Posts: 9258
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP and BE/BO 2014.04.15

Postby Arjen Balfoort » 15 Apr 2014 15:00

I've adapted the pre-scripts (for home, and be) to adapt language names:

Code: Select all

if [ "$FFL10N" == "firefox-l10n-es" ]; then
    FFL10N="firefox-l10n-es-es"
  elif [ "$FFL10N" == "firefox-l10n-fy" ]; then
    FFL10N="firefox-l10n-fy-nl"
  elif [ "$FFL10N" == "firefox-l10n-ga" ]; then
    FFL10N="firefox-l10n-ga-ie"
  elif [ "$FFL10N" == "firefox-l10n-gu" ]; then
    FFL10N="firefox-l10n-gu-in"
  elif [ "$FFL10N" == "firefox-l10n-hi" ]; then
    FFL10N="firefox-l10n-hi-in"
  elif [ "$FFL10N" == "firefox-l10n-nb" ]; then
    FFL10N="firefox-l10n-nb-no"
  elif [ "$FFL10N" == "firefox-l10n-nn" ]; then
    FFL10N="firefox-l10n-nn-no"
  elif [ "$FFL10N" == "firefox-l10n-pa" ]; then
    FFL10N="firefox-l10n-pa-in"
  elif [ "$FFL10N" == "firefox-l10n-pt" ]; then
    FFL10N="firefox-l10n-pt-pt"
  elif [ "$FFL10N" == "firefox-l10n-sv" ]; then
    FFL10N="firefox-l10n-sv-se"
  elif [ "$FFL10N" == "firefox-l10n-zh" ]; then
    FFL10N="firefox-l10n-zh-cn"
  fi
Did the same for the ESR version, and Thunderbird.

Can anybody check this out (I'll have to install a VM with one of these languages. I'll post back asap).


SolydXK needs you!
Development | Testing | Translations

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP and BE/BO 2014.04.15

Postby zerozero » 15 Apr 2014 15:35

i have a problem updating SolydX-64

Code: Select all

INFO      Lined added: Unpacking thunderbird (24.4.0) ... (col=0, row=740)
INFO      Lined added: dpkg: error processing archive /var/cache/apt/archives/thunderbird_24.4.0_amd64.deb (--unpack): (col=0, row=743)
INFO      Lined added:  corrupted filesystem tarfile - corrupted package archive (col=0, row=743)
INFO      Lined added: dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) (col=0, row=744)
INFO      Lined added: Selecting previously unselected package thunderbird-l10n-en-gb. (col=0, row=747)
INFO      Lined added: Preparing to unpack .../thunderbird-l10n-en-gb_24.4.0_amd64.deb ... (col=0, row=747)
INFO      Lined added: Unpacking thunderbird-l10n-en-gb (24.4.0) ... (col=0, row=747)
INFO      Lined added: Selecting previously unselected package thunderbird-solydxk-adjustments. (col=0, row=750)
INFO      Lined added: Preparing to unpack .../thunderbird-solydxk-adjustments_24.4.0_all.deb ... (col=0, row=750)
INFO      Lined added: Unpacking thunderbird-solydxk-adjustments (24.4.0) ... (col=0, row=750)
INFO      Lined added: Errors were encountered while processing: (col=0, row=753)
INFO      Lined added:  /var/cache/apt/archives/thunderbird_24.4.0_amd64.deb (col=0, row=753)
INFO      Lined added: E: Sub-process /usr/bin/dpkg returned an error code (1) (col=0, row=753)
INFO      Lined added: > TB: Copy /opt/firefox/browser/extensions/{25A1388B-6B18-46c3-BEBA-A81915D0DE8F}.xpi to /home/zerozero/.thunderbird/pjzwmea6.default/extensions/{25A1388B-6B18-46c3-BEBA-A81915D0DE8F}.xpi (col=0, row=756)
INFO      Lined added: Reading package lists... Done (col=0, row=757)
INFO      Lined added: B (col=0, row=757)
INFO      Lined added: Building dependency tree (col=0, row=759)
INFO      Lined added: Reading state information... Done (col=0, row=759)
INFO      Lined added: You might want to run 'apt-get -f install' to correct these. (col=0, row=767)
INFO      Lined added: The following packages have unmet dependencies: (col=0, row=767)
INFO      Lined added:  thunderbird-l10n-en-gb : Depends: thunderbird but it is not installed (col=0, row=767)
INFO      Lined added:  thunderbird-solydxk-adjustments : Depends: thunderbird but it is not installed (col=0, row=767)
INFO      Lined added: E: Unmet dependencies. Try using -f. (col=0, row=767)
my download of TB is corrupt breaking the update;
i had to clear the cache

Code: Select all

apt clean
redownload the packages

Code: Select all

apt update && apt dist-upgrade
install the broken dep

Code: Select all

sudo apt-get -f install
and resume the D-U

Code: Select all

apt dist-upgrade
bliss of ignorance

fkef
Posts: 83
Joined: 26 Aug 2013 11:45

Re: UP and BE/BO 2014.04.15

Postby fkef » 15 Apr 2014 15:46

Since I reinstalled FF and TB manually using the command:

Code: Select all

sudo apt-get install firefox firefox-solydxk-adjustments thunderbird thunderbird-solydxk-adjustments
The update manager does not start anymore.

Output when trying to run updatemanager

Code: Select all

fredrik@fredrik-pc ~ $ sudo updatemanager
[sudo] password for fredrik: 
Traceback (most recent call last):
  File "/usr/bin/updatemanager", line 98, in <module>
    showMsg(title, msg)
  File "/usr/bin/updatemanager", line 77, in showMsg
    dialog.set_icon_from_file("/usr/share/solydxk/updatemanager/icons/base.svg")
gi._glib.GError: Misslyckades med att öppna filen "/usr/share/solydxk/updatemanager/icons/base.svg": Filen eller katalogen finns inte
Also anyone else having issue with libjack0 being hold back, because upgrading it will delete skype?

User avatar
Arjen Balfoort
Site Admin
Posts: 9258
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP and BE/BO 2014.04.15

Postby Arjen Balfoort » 15 Apr 2014 15:49

These are unrelated issues.

I haven't seen this one before. So, please try to reinstall updatemanager:

Code: Select all

sudo apt-get install --reinstall updatemanager


SolydXK needs you!
Development | Testing | Translations

User avatar
Arjen Balfoort
Site Admin
Posts: 9258
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP and BE/BO 2014.04.15

Postby Arjen Balfoort » 15 Apr 2014 15:54

@zz
Perhaps something went wrong during the package download?


SolydXK needs you!
Development | Testing | Translations

fkef
Posts: 83
Joined: 26 Aug 2013 11:45

Re: UP and BE/BO 2014.04.15

Postby fkef » 15 Apr 2014 15:55

Schoelje wrote:These are unrelated issues.

I haven't seen this one before. So, please try to reinstall updatemanager:

Code: Select all

sudo apt-get install --reinstall updatemanager
Reinstalled updatemanager. Same error

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP and BE/BO 2014.04.15

Postby zerozero » 15 Apr 2014 15:55

fkef
you don't need sudo to start the updatemanager.
what happens if you start it just with

Code: Select all

updatemanager
bliss of ignorance

fkef
Posts: 83
Joined: 26 Aug 2013 11:45

Re: UP and BE/BO 2014.04.15

Postby fkef » 15 Apr 2014 15:57

zerozero wrote:fkef
you don't need sudo to start the updatemanager.
what happens if you start it just with

Code: Select all

updatemanager
same error message

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP and BE/BO 2014.04.15

Postby zerozero » 15 Apr 2014 15:58

Schoelje wrote:@zz
Perhaps something went wrong during the package download?
yep, surely. i'm pushing a bit the available bandwidth updating 2 systems at the same time;
clearing the cache and redownloading solves the issue
bliss of ignorance

abqnm
Posts: 12
Joined: 15 Jan 2014 18:15

Re: UP and BE/BO 2014.04.15

Postby abqnm » 15 Apr 2014 16:08

So far so good with SolydK 32-bit (still updating, but the new updater method is nice - the old one didn't work for me so I always had to use the terminal).

I did have one minor usability issue with the GRUB update screen. It does show up as indicated in the guide, but after selecting OK on the description, the box pops up to choose the device where grub is installed (as shown in your screenshot). The issue is that this screen only displays for 1-2 seconds before it automatically advances (which skips the grub configuration). I was able to hit ESC and get the grub screen again, but I still only had about a second to choose the proper drive. I think the grub update needs to not automatically advance without user input, otherwise it could wind up skipping the grub setup for someone who isn't paying strict attention.

User avatar
Night Wing
Posts: 445
Joined: 26 Dec 2013 02:46
Location: Texas, USA

Re: Thank you - most trouble free update so far!

Postby Night Wing » 15 Apr 2014 16:11

It didn't go well for me. After the update disappeared and went back to the Desktop, I lost the Update Manager Shield on the Panel taskbar. It's not there anymore and now I have to figure out what went wrong.

I'm first going to re-start the system and see if it brings it back.

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP and BE/BO 2014.04.15

Postby zerozero » 15 Apr 2014 16:16

Night Wing
moved your post to a support topic

Please read the OP: either logout/login or start the UM from the terminal with

Code: Select all

updatemanager
bliss of ignorance


Return to “News & Anouncements”

Who is online

Users browsing this forum: No registered users and 4 guests