UP and BE/BO 2014.04.15 [CLOSED]

Important informations about SolydXK including releases notes, forum rules and other anouncements
bodam
Posts: 28
Joined: 10 Oct 2013 02:22

Upgrade process stopped

Postby bodam » 15 Apr 2014 16:23

I have started up quarterly update process but it has stopped at removing libnotify0.4-cli from Mono for about 30 minutes. Any ideas? Here is part of the output up to where it has stopped:

Preparing to unpack .../libmono-web4.0-cil_3.0.6+dfsg2-11_all.deb ...
Unpacking libmono-web4.0-cil (3.0.6+dfsg2-11) over (3.0.6+dfsg2-10) ...
Preparing to unpack .../libmono-system-web4.0-cil_3.0.6+dfsg2-11_all.deb ...
Unpacking libmono-system-web4.0-cil (3.0.6+dfsg2-11) over (3.0.6+dfsg2-10) ...
Preparing to unpack .../libmono-system-xml-linq4.0-cil_3.0.6+dfsg2-11_all.deb ...
Unpacking libmono-system-xml-linq4.0-cil (3.0.6+dfsg2-11) over (3.0.6+dfsg2-10) ...
Preparing to unpack .../libnotify0.4-cil_0.4.0~r3032-7_all.deb ...
Removing libnotify0.4-cil from Mono :?
David Inglehart

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP and BE/BO 2014.04.15

Postby zerozero » 15 Apr 2014 16:30

bodam
[topics merged]
dropping to a terminal and

Code: Select all

sudo apt-get -f install
or

Code: Select all

sudo dpkg --configure -a
unblocks that?
bliss of ignorance

User avatar
Arjen Balfoort
Site Admin
Posts: 9220
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP and BE/BO 2014.04.15

Postby Arjen Balfoort » 15 Apr 2014 16:44

abqnm wrote:I think the grub update needs to not automatically advance without user input, otherwise it could wind up skipping the grub setup for someone who isn't paying strict attention.
I haven't seen that in all our testing.
What language were you using?


SolydXK needs you!
Development | Testing | Translations

abqnm
Posts: 12
Joined: 15 Jan 2014 18:15

Re: UP and BE/BO 2014.04.15

Postby abqnm » 15 Apr 2014 16:51

Schoelje wrote:
abqnm wrote:I think the grub update needs to not automatically advance without user input, otherwise it could wind up skipping the grub setup for someone who isn't paying strict attention.
I haven't seen that in all our testing.
What language were you using?
English-US. The GRUB (man?) page showed up saying that there was no device selected... Tab over to OK, press enter and I got the screen to select the device as pictured in your screenshot. As I was reading it, it automatically advanced, leaving it with nothing selected. I got another full page warning text from GRUB saying that no device was selected and the only option I had was <OK>. I pressed ESC, and got back to the first screen (man page?) and tabbed to <OK> and hit enter, but immediately hit space on the device and within a second it advanced on its own again.

Aside from that, everything seemed to work great. About to reboot, so let's see if it works.

Edit: Back from (2) reboot(s). Everything went great, although it installed the 486 kernel as default again so I had to start up the Driver Manager and install the new 686-pae kernel again. Now I am back up and all seems well. Much better upgrade process than the old apt method (that usually didn't work anyway).

Edit2: So it seems my older hardware doesn't play nicely with the new 3.13 kernel. I have my laptop set to just turn off the screen (not sleep or anything) when closing the lid. On 3.13, if I close the lid, that is it. The screen goes black and never comes back up. Booted with the 3.11-2 kernel and all is well. I will look into this further another day, but for now, the older kernel is fine.

bodam
Posts: 28
Joined: 10 Oct 2013 02:22

Re: UP and BE/BO 2014.04.15

Postby bodam » 15 Apr 2014 16:53

zerozero wrote:bodam
[topics merged]
dropping to a terminal and

Code: Select all

sudo apt-get -f install
or

Code: Select all

sudo dpkg --configure -a
unblocks that?
Both commands complain: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
David Inglehart

fkef
Posts: 83
Joined: 26 Aug 2013 11:45

Re: Thank you - most trouble free update so far!

Postby fkef » 15 Apr 2014 16:56

Night Wing wrote:It didn't go well for me. After the update disappeared and went back to the Desktop, I lost the Update Manager Shield on the Panel taskbar. It's not there anymore and now I have to figure out what went wrong.

I'm first going to re-start the system and see if it brings it back.
This problem seems similar to my problem with updatemanager

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP and BE/BO 2014.04.15

Postby zerozero » 15 Apr 2014 17:01

bodam wrote:Both commands complain: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
meaning that there is another application (synaptic, updatemanager or other) using APT.
close all instances that can access APT and try again
bliss of ignorance

bodam
Posts: 28
Joined: 10 Oct 2013 02:22

Re: Thank you - most trouble free update so far!

Postby bodam » 15 Apr 2014 17:02

fkef wrote:
Night Wing wrote:It didn't go well for me. After the update disappeared and went back to the Desktop, I lost the Update Manager Shield on the Panel taskbar. It's not there anymore and now I have to figure out what went wrong.

I'm first going to re-start the system and see if it brings it back.
This problem seems similar to my problem with updatemanager
The package notes had this: After the Update Manager has updated itself, you need to manually start the Update Manager (or logout/login), and re-enter your blacklisted packages in the preferences window if needed.

is this what you are seeing? If so, I think it's expected.
David Inglehart

abqnm
Posts: 12
Joined: 15 Jan 2014 18:15

Re: Thank you - most trouble free update so far!

Postby abqnm » 15 Apr 2014 17:05

fkef wrote:
Night Wing wrote:It didn't go well for me. After the update disappeared and went back to the Desktop, I lost the Update Manager Shield on the Panel taskbar. It's not there anymore and now I have to figure out what went wrong.

I'm first going to re-start the system and see if it brings it back.
This problem seems similar to my problem with updatemanager
I got this too, but it was due to a dialog box for the old update manager saying the update was complete hiding in the background that was keeping apt locked. I closed that, launched the update manager manually and proceeded to install the UP.

outlaw
Posts: 17
Joined: 01 Feb 2014 19:12

update / upgrde hangs

Postby outlaw » 15 Apr 2014 17:48

I've tried to apply the update pack today April 15 and the process hangs.

Setting up libc6:amd64 (2.18-4) ...
Checking for services that may need to be restarted...
Checking init scripts...

Restarting services possibly affected by the upgrade:
smbd: restarting...done.
exim4: restarting...done.
cups: restarting...

Any ideas on how I might work around (bypass) this step.

Thanks in advance for any advice / suggestions offered.


Tom

ZeRaler
Posts: 4
Joined: 15 Apr 2014 17:29

Re: UP and BE/BO 2014.04.15

Postby ZeRaler » 15 Apr 2014 17:50

Hi,

I cant login to my desktop anymore, terminal login works.

Update process seems to be good(no error nor message), I have rebooted my computer and since I cant login to any of my users(even a fresh new one).

At login screen, when I enter password, session seems to load but a window like a terminal appears and then I go back to login screen.

I can see some message from /var/log/kdm.log

Code: Select all

kdeinit4: Communication error with launcher. Exiting!
And from user/.xsession-errors

Code: Select all

x-terminal-emulator: Fatal IO error : client killed
Any suggestions?

Ps: I am from my tablet to write and it is not a fun thing to do, cant transmit files or else.

User avatar
Arjen Balfoort
Site Admin
Posts: 9220
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP and BE/BO 2014.04.15

Postby Arjen Balfoort » 15 Apr 2014 17:59

Lacalizing seems to be good now:
Before:

Code: Select all

solydxk@solydxk ~ $ apt search firefox thunderbird | grep ^i
i   firefox                         - The Firefox web browser                   
iB  firefox-l10n-es                 - Spanish language packs for Firefox        
i   thunderbird                     - The Thunderbird email client              
iB  thunderbird-l10n-es             - Spanish language packs for Thunderbird    

solydxk@solydxk ~ $ apt policy firefox firefox-l10n-es thunderbird thunderbird-l10n-es
firefox:
  Instalados: 27.0
  Candidato:  27.0
  Tabla de versión:
 *** 27.0 0
        500 http://packages.solydxk.com/production.old/ solydxk/main amd64 Packages
        100 /var/lib/dpkg/status
firefox-l10n-es:
  Instalados: 27.0
  Candidato:  27.0
  Tabla de versión:
 *** 27.0 0
        500 http://packages.solydxk.com/production.old/ solydxk/main amd64 Packages
        100 /var/lib/dpkg/status
thunderbird:
  Instalados: 24.3.0
  Candidato:  24.3.0
  Tabla de versión:
 *** 24.3.0 0
        500 http://packages.solydxk.com/production.old/ solydxk/main amd64 Packages
        100 /var/lib/dpkg/status
thunderbird-l10n-es:
  Instalados: 24.3.0
  Candidato:  24.3.0
  Tabla de versión:
 *** 24.3.0 0
        500 http://packages.solydxk.com/production.old/ solydxk/main amd64 Packages
        100 /var/lib/dpkg/status
After:

Code: Select all

solydxk@solydxk /usr/lib/solydxk/updatemanager $ apt search firefox thunderbird | grep ^i
i   firefox                         - The Firefox web browser                   
i   firefox-l10n-es-es              - Spanish language pack for Firefox         
i   firefox-solydxk-adjustments     - Firefox adjustments for SolydXK           
i   thunderbird                     - The Thunderbird web browser               
i   thunderbird-l10n-es-es          - Spanish language pack for Thunderbird     
i   thunderbird-solydxk-adjustments - Thunderbird adjustments for SolydXK       

solydxk@solydxk /usr/lib/solydxk/updatemanager $ apt policy firefox firefox-l10n-es-es firefox-solydxk-adjustments thunderbird thunderbird-l10n-es-es thunderbird-solydxk-adjustments
firefox:
  Instalados: 28.0
  Candidato:  28.0
  Tabla de versión:
 *** 28.0 0
        500 http://packages.solydxk.com/production/ solydxk/main amd64 Packages
        100 /var/lib/dpkg/status
firefox-l10n-es-es:
  Instalados: 28.0
  Candidato:  28.0
  Tabla de versión:
 *** 28.0 0
        500 http://packages.solydxk.com/production/ solydxk/main amd64 Packages
        100 /var/lib/dpkg/status
firefox-solydxk-adjustments:
  Instalados: 28.0
  Candidato:  28.0
  Tabla de versión:
 *** 28.0 0
        500 http://packages.solydxk.com/production/ solydxk/main amd64 Packages
        100 /var/lib/dpkg/status
thunderbird:
  Instalados: 24.4.0
  Candidato:  24.4.0
  Tabla de versión:
 *** 24.4.0 0
        500 http://packages.solydxk.com/production/ solydxk/main amd64 Packages
        100 /var/lib/dpkg/status
thunderbird-l10n-es-es:
  Instalados: 24.4.0
  Candidato:  24.4.0
  Tabla de versión:
 *** 24.4.0 0
        500 http://packages.solydxk.com/production/ solydxk/main amd64 Packages
        100 /var/lib/dpkg/status
thunderbird-solydxk-adjustments:
  Instalados: 24.4.0
  Candidato:  24.4.0
  Tabla de versión:
 *** 24.4.0 0
        500 http://packages.solydxk.com/production/ solydxk/main amd64 Packages
        100 /var/lib/dpkg/status


SolydXK needs you!
Development | Testing | Translations

User avatar
Night Wing
Posts: 445
Joined: 26 Dec 2013 02:46
Location: Texas, USA

Re: UP and BE/BO 2014.04.15

Postby Night Wing » 15 Apr 2014 17:59

I finally got the UP installed. I got the "my system is up to date" prompt. I thought all was well. Not so.

I wanted to see if Firefox 24.4.0 ESR was in the Synaptic Package Manager because I wanted to replace Firefox 28.0 with it. As soon as I get into Synaptic, a box pops up and tells me I have a broken package. (I start getting frustrated) The package isn't named either. (More frustration). The box tells me I have to use the "broken filter" to find it. (Now I'm getting aggravated).

The problem is I'm basically a computer illiterate user in linux. I don't know where the broken filter is or how to get to it and even if I did, I don't know how to use the broken filter to find, fix or delete a broken package since the package isn't named. (Now I'm mad).

The first UP in January gave me a problem and this UP in April has given me a problem. I think a debian based distro with a rolling release is not for me. As much as I like SolydX over Mint, I think I'm going to have to give up on SolydX and go back to Mint 16 XFCE on this computer because I've never had a problem with updates in Mint. Shame too since I really prefer SolydX. (Now I'm feeling depressed).

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP and BE/BO 2014.04.15

Postby zerozero » 15 Apr 2014 18:00

@outlaw
try this >> http://forums.solydxk.nl/viewtopic.php? ... 493#p32638
also are you updating with the UM or the terminal?
bliss of ignorance

User avatar
Arjen Balfoort
Site Admin
Posts: 9220
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP and BE/BO 2014.04.15

Postby Arjen Balfoort » 15 Apr 2014 18:01



SolydXK needs you!
Development | Testing | Translations

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP and BE/BO 2014.04.15

Postby zerozero » 15 Apr 2014 18:04

Night Wing wrote:The first UP in January gave me a problem and this UP in April has given me a problem. I think a debian based distro with a rolling release is not for me. As much as I like SolydX over Mint, I think I'm going to have to give up on SolydX and go back to Mint 16 XFCE on this computer because I've never had a problem with updates in Mint. Shame too since I really prefer SolydX. (Now I'm feeling depressed).
the option is yours of course (and posts like this will only help release the frustration) but if you want to know what's broken try

Code: Select all

sudo apt-get -f install
[share the output for review]
bliss of ignorance

User avatar
Arjen Balfoort
Site Admin
Posts: 9220
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP and BE/BO 2014.04.15

Postby Arjen Balfoort » 15 Apr 2014 18:05

@ZeRaler
I've never seen that one, but after some googling, I found this on a Gentoo forum with some suggestions: http://www.gossamer-threads.com/lists/g ... ser/270796


SolydXK needs you!
Development | Testing | Translations

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP and BE/BO 2014.04.15

Postby zerozero » 15 Apr 2014 18:16

@ZeRaler
what method you used to update?
the terminal or updatemanager?
if the terminal, what commands exactly?
dropping to a tty (Ctrl Alt F1) and logging in with your userid and password, if you do

Code: Select all

apt update && apt dist-upgrade
is there any updates available?

===
also:
what graphic card you have?
bliss of ignorance

User avatar
Night Wing
Posts: 445
Joined: 26 Dec 2013 02:46
Location: Texas, USA

Re: UP and BE/BO 2014.04.15

Postby Night Wing » 15 Apr 2014 18:17

zerozero wrote:the option is yours of course (and posts like this will only help release the frustration) but if you want to know what's broken try

Code: Select all

sudo apt-get -f install
[share the output for review]
Here's the output.

Code: Select all

joe@hp:~$ sudo apt-get -f install
[sudo] password for joe: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  liblivemedia17 libspice-server1
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  mate-polkit-common
The following NEW packages will be installed:
  mate-polkit-common
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
723 not fully installed or removed.
Need to get 0 B/47.3 kB of archives.
After this operation, 829 kB of additional disk space will be used.
Do you want to continue? [Y/n] 
I haven't clicked on the [Y/n} since I don't know what to do.

Reyfer
Posts: 29
Joined: 01 Aug 2013 13:15

Re: UP and BE/BO 2014.04.15

Postby Reyfer » 15 Apr 2014 18:18

I had to stop the UM, restart the pc and put in terminal

Code: Select all

sudo dpkg --configure -a; sudo apt-get -y --force-yes -f install
after that, update manger worked the update great


Return to “News & Anouncements”

Who is online

Users browsing this forum: No registered users and 1 guest