UP and BE/BO 2014.04.15 [CLOSED]

Important informations about SolydXK including releases notes, forum rules and other anouncements
Rocky
Posts: 127
Joined: 15 Apr 2014 11:04
Location: Ireland

Re: UP and BE/BO 2014.04.15 Firefox and Thunderbird

Postby Rocky » 16 Apr 2014 09:23

Thanks for all your hard work on the testing/upgrade and these forums :D

I too lost Firefox and Thunderbird during the upgrade process. However have now successfully installed them ( from NL mirror) using apt-get as per your post here http://forums.solydxk.nl/viewtopic.php? ... 493#p32633

Code: Select all

sudo apt-get install firefox firefox-solydxk-adjustments thunderbird thunderbird-solydxk-adjustments
All seems OK but I received an error message :

Code: Select all

Errors were encountered while processing:
 /var/cache/apt/archives/firefox-solydxk-adjustments_28.0_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Rocky
"All that glisters is not gold" - Shakespeare "The Merchant of Venice"

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP and BE/BO 2014.04.15

Postby zerozero » 16 Apr 2014 09:31

Rocky
what is the output of

Code: Select all

sudo apt-get -f install
bliss of ignorance

User avatar
Arjen Balfoort
Site Admin
Posts: 9394
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP and BE/BO 2014.04.15

Postby Arjen Balfoort » 16 Apr 2014 09:33

Probably a bad download of that package (the server seems a bit busy).
You should have run:

Code: Select all

sudo apt clean
before installing the packages.
You could run the same install command, but with "--reinstall" added.


SolydXK needs you!
Development | Testing | Translations

ZeRaler
Posts: 4
Joined: 15 Apr 2014 17:29

Re: UP and BE/BO 2014.04.15

Postby ZeRaler » 16 Apr 2014 09:40

zerozero wrote:
ZeRaler wrote:With apt dist-upgrade I have some packages that are kept : kamera, kinfocenter, krdc, and some libs.
humm, this doesn't "smell" good.
we never had any report of kde-related lib held back.
are you sure that your sources.list are set correctly?
...
do you have any preferences file in /etc/apt/ ? [unless you made one, you shouldn't]

do you have app installed from outside the repo? PPA's?
Ok, few steps forward for my problem.

First, I was on a mirror that was not fully synced when I've try yesterday ...
-> I returned back to USA and I am fully updated.
Second, I dont understand why, kde-workspace package was not installed (and many of these friends)?!
-> I installed them, now a fresh new user is able to login from KDM. My user cant yet but I can login from terminal and do a startx. I have to understand difference between these users and between start from kdm and from startx.


To respond to question :
no I dont have any preferences in /etc/apt,
yes I have external deb(freecad) installed and few 'original' packages from debian testing.
(Yes I know it is ugly ...)

Thanks to pointing me some of my problems, I progress.

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP and BE/BO 2014.04.15

Postby zerozero » 16 Apr 2014 10:06

ZeRaler wrote:Second, I dont understand why, kde-workspace package was not installed (and many of these friends)?!
well, it should be installed (of course) something, somewhere uninstalled it; maybe because of unmet dependencies earlier when trying to dist-upgrade with a non updated mirror, maybe ...
you can dig that out looking at /var/log/apt/history.log [or history.log.1.gz]
bliss of ignorance

yoast
Posts: 138
Joined: 20 Jan 2014 09:54

Re: UP and BE/BO 2014.04.15

Postby yoast » 16 Apr 2014 10:18

Thanks for this wonderful OS and the additional "rolling" services/updates.

I reside in the UK and use this server GBR: http://solydxk.ogun.org I am on SolydXK 64Bit home edition.

This morning my update manager started indicating I had hundreds of files ready for update. Since I knew the update-manager should be updated first I waited. Indeed after a couple of hours the message changed to just 1 update which was the update manager itself. On trying to update this I get "this upgrade will trigger additional upgrades" and it lists 3 "girl1.2" ones and one pynotify. However these 4 cannot be installed. "failed to fetch http://solydxk.ogun.org/debian/producti ... /girl*.deb for the girl ones and http://solydxk.ogun.org/debian/producti ... /u/update/* for the last one.
Indeed: those fodlers do not exits on ogun yet. Were they forgotten?
Is it best to wait until the last folders exist on the mirror, or can I just start and accept that 4 libs are missing?

thanks,
Yoast

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP and BE/BO 2014.04.15

Postby zerozero » 16 Apr 2014 10:23

Yoast
ogun is not yet synced http://solydxk.nl/mirror-update-up-201404/
bliss of ignorance

User avatar
rajkapur
Posts: 26
Joined: 09 Feb 2014 09:57
Location: Romania, Roman
Contact:

Problem after updating

Postby rajkapur » 16 Apr 2014 10:30

I've just updated my system. I selected continue without installing grub (because after selecting the entire hard disk i could not continue by pressing NO). After rebooting I selected SolydK from the grub menu and I got this error:

error:file not found
error:file not found
error:file not found
something about ramdisk

The kde updated to version 4.12.4 but the kernel is still the old one.
How can I fix these problems?

yoast
Posts: 138
Joined: 20 Jan 2014 09:54

Re: UP and BE/BO 2014.04.15

Postby yoast » 16 Apr 2014 10:32

Thanks zerozero.
I just responed to the update manager indicating there were updates.
It is almost synced because the update manager now only reports 2 files missing (instead of 4). :-)

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: Problem after updating

Postby zerozero » 16 Apr 2014 10:48

@rajkapur
for the most urgent issue (grub) you can follow one of these 2 topics
http://forums.solydxk.nl/viewtopic.php?f=9&t=236
http://forums.solydxk.nl/viewtopic.php?f=9&t=3509
bliss of ignorance

User avatar
jsvenancio
Posts: 223
Joined: 16 Dec 2013 17:59
Location: Portugal
Contact:

Re: UP and BE/BO 2014.04.15

Postby jsvenancio » 16 Apr 2014 10:55

zerozero wrote:jsvenancio
in recovery mode try first

Code: Select all

sudo apt-get -f install
and then

Code: Select all

sudo apt-get dist-upgrade
In recovery mode i use the command;

Code: Select all

sudo apt-get -f install
I received the following message;

E: dpkg was interrupted, you must manually run "sudo dpkg --configure -a" to correct the problem.

Then I used the command;

Code: Select all

sudo dpkg --configure -a
After making some choices with "y" could use the command;

Code: Select all

sudo apt-get -f install
Apparently all went well.
But when I start the PC I noticed that I still have to do this update, as I show in the image below;

Image

My question is, will be better to upgrade the terminal?
SolydX - 64bts - Debian

Sorry for my bad English, I speak Portuguese and use the Google translator.

User avatar
helmsdeeper
Posts: 105
Joined: 10 Jul 2013 09:49
Location: Southeast Tennessee, USA

Re: UP and BE/BO 2014.04.15

Postby helmsdeeper » 16 Apr 2014 10:59

Success to report here on my SolydK32 Toshiba Satellite A205-S4707 laptop. I used the new Update Manager, rebooted with the newest kernel and my rig is good to go. Tommorow I will upgrade my Acer netbook running SolydX32 and report back.
Thanks to everyone involved!

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP and BE/BO 2014.04.15

Postby zerozero » 16 Apr 2014 11:03

@jsvenancio
if you feel more comfortable with the terminal, no problem but you can do it with the updatemanager.
bliss of ignorance

User avatar
rajkapur
Posts: 26
Joined: 09 Feb 2014 09:57
Location: Romania, Roman
Contact:

Re: UP and BE/BO 2014.04.15

Postby rajkapur » 16 Apr 2014 11:04

Grub is working. I am able to boot using the old kernel(3.11-2-686-pae). I think the missing file error that I get after I select SolydK from the grub menu is caused by the missing kernel file(the kernel I should have after updating).

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP and BE/BO 2014.04.15

Postby zerozero » 16 Apr 2014 11:09

@rajkapur
share, please, the output of

Code: Select all

dpkg -l | egrep '(linux-image|linux-headers)'
bliss of ignorance

User avatar
Arjen Balfoort
Site Admin
Posts: 9394
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: UP and BE/BO 2014.04.15

Postby Arjen Balfoort » 16 Apr 2014 11:09

rajkapur wrote:Grub is working. I am able to boot using the old kernel(3.11-2-686-pae). I think the missing file error that I get after I select SolydK from the grub menu is caused by the missing kernel file(the kernel I should have after updating).
If you run:

Code: Select all

sudo apt-get dist-upgrade
it should list the kernel to upgrade.
If you feel confident, you could try that.

Or better, do what zz said above ^


SolydXK needs you!
Development | Testing | Translations

User avatar
rajkapur
Posts: 26
Joined: 09 Feb 2014 09:57
Location: Romania, Roman
Contact:

Re: UP and BE/BO 2014.04.15

Postby rajkapur » 16 Apr 2014 11:10

@zerozero

Code: Select all

stefanlnt@stefanlnt ~ $ dpkg -l | egrep '(linux-image|linux-headers)'
ii  linux-headers-3.11-2-686-pae                                3.11.10-1                           i386         Header files for Linux 3.11-2-686-pae
ii  linux-headers-3.11-2-common                                 3.11.10-1                           i386         Common header files for Linux 3.11-2
rc  linux-image-3.11-2-486                                      3.11.10-1                           i386         Linux 3.11 for older PCs
ii  linux-image-3.11-2-686-pae                                  3.11.10-1                           i386         Linux 3.11 for modern PCs
@Schoelje

Code: Select all

stefanlnt@stefanlnt ~ $ sudo apt-get dist-upgrade
[sudo] password for stefanlnt: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Thank you for the quick reply.

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: UP and BE/BO 2014.04.15

Postby zerozero » 16 Apr 2014 11:21

@rajkapur
you need to install the headers and image meta-package for the 686-pae (otherwise you won't get kernel updates)
you see that my output is different

Code: Select all

zerozero@xfce-32:~$ dpkg -l | egrep '(linux-image|linux-headers)'
ii  linux-headers-3.13-1-686-pae           3.13.5-1                       i386         Header files for Linux 3.13-1-686-pae
ii  linux-headers-3.13-1-common            3.13.5-1                       i386         Common header files for Linux 3.13-1
ii  linux-headers-686-pae                  3.13+56                        i386         Header files for Linux 686-pae configuration (meta-package)
ii  linux-image-3.13-1-686-pae             3.13.5-1                       i386         Linux 3.13 for modern PCs
ii  linux-image-686-pae                    3.13+56                        i386         Linux for modern PCs (meta-package)
i also removed the 486 kernel but you don't need to do that

the packages you need are

Code: Select all

apt install linux-headers-686-pae linux-image-686-pae
it should update grub automagically but anyway just to be sure

Code: Select all

sudo update-grub
reboot
bliss of ignorance

User avatar
rajkapur
Posts: 26
Joined: 09 Feb 2014 09:57
Location: Romania, Roman
Contact:

Re: UP and BE/BO 2014.04.15

Postby rajkapur » 16 Apr 2014 11:42

Thanks. The kernel was updated.
I still get this error when I boot :
https://www.dropbox.com/s/q7zlhebymjrb3pq/_IGP3729.JPG

User avatar
Jeerva
Posts: 2
Joined: 09 Apr 2014 12:58

Re: UP and BE/BO 2014.04.15

Postby Jeerva » 16 Apr 2014 11:47

Hello, thanks to all for SolydXK.

I'm trying to update SolydK (amd64) via the update manager (version 2.0.9) but I'm stuck on

Code: Select all

Configurazione di locales (2.18-4)...
Installazione della nuova versione del file di configurazione /etc/locale.alias...
Generating locales (this might take a while)...
  en_US.UTF-8... done
  it_IT.UTF-8... done
Generation complete.
Processing triggers for libc-bin (2.17-97) ...
Configurazione di libc6:i386 (2.18-4)...
Checking for services that may need to be restarted...
Checking init scripts...

Restarting services possibly affected by the upgrade:
  smbd: restarting...done.
  cups: restarting...
Simply nothing happens after that. I tried to close the update manager and reboot but nothing is changed.
It seems that the system works well, but I can't complete the update.

Any kind of help is appreciated. Thanks a lot once again.

System:
CPU Intel Core i4670k
GPU nVidia GeForce GTX 670
MoBo Asrock z87 Pro4
Graphic drivers nVidia 319.76


Return to “News & Anouncements”

Who is online

Users browsing this forum: No registered users and 3 guests