Updated broke my xserver

Important informations about SolydXK including releases notes, forum rules and other anouncements
t0psy
Posts: 39
Joined: 21 Mar 2014 16:01

Updated broke my xserver

Postby t0psy » 21 Jul 2014 10:18

I updated today 21 \july via UM and after a reboot xserver does not start.

Half way through the update process I had to press "q" to make the process carry on.

I logged in at the prompt ans tried "startx"
and got:-
xinit: unable to connect to X server: connection refused
and a few other lines.

I tried re-configuring xorg which did nothing

I then tried re-installing xorg which met with unmet dependancies. (sudo dpkg-reconfigure xserver.org)

I then tried as prompted (sudo apt-get -f install)
this installed some packages, reconfigured and restarted lots of services.

From here "startx" was good.
Sorry I don't know the package names it complained about with unmet dependancies.

User avatar
Arjen Balfoort
Site Admin
Posts: 9395
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Updated broke my xserver

Postby Arjen Balfoort » 28 Jul 2014 14:49

I just came back from holidays. Do you still need help with this?
If so, did you check the UP 2014.07.15 opening post?
http://forums.solydxk.nl/viewtopic.php?f=32&t=4303
and this survival kit?
http://forums.solydxk.nl/viewtopic.php?f=4&t=4345


SolydXK needs you!
Development | Testing | Translations


Return to “News & Anouncements”

Who is online

Users browsing this forum: No registered users and 3 guests