Hangs on shutdown after upgrade

Important informations about SolydXK including releases notes, forum rules and other anouncements
User avatar
ath_pg
Posts: 21
Joined: 01 Sep 2013 09:34

Hangs on shutdown after upgrade

Postby ath_pg » 03 Aug 2014 11:56

Hi guys,
After I upgraded to 7.15 UP, I found an issue mentioned here viewtopic.php?f=44&t=3990&start=20
The error info is like
cifs vfs server *** has not responded in 120 seconds. reconnecting.

and I need to wait a couple minutes for the time out confirmation.

I tried to use systemd but it is not working properly, so I turned back to sysvinit.
I also tried a solution online that

Code: Select all

ln -s /etc/init.d/umountnfs.sh /etc/rc0.d/K15umountnfs.sh
ln -s /etc/init.d/umountnfs.sh /etc/rc6.d/K15umountnfs.sh
it didn't work either.

How to solve the cifs umount time out problem if I have to use sysvinit?
Many thanks.

User avatar
Arjen Balfoort
Site Admin
Posts: 8986
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Hangs on shutdown after upgrade

Postby Arjen Balfoort » 03 Aug 2014 15:24

You could try moving the mount to /etc/rc.local (comment the mount in /etc/fstab).

It would look something like:

Code: Select all

mkdir -p /media/mycifs
mount -t cifs -o auto,username=cifs_user_name,password=cifs_user_name_pwd,_netdev,uid=myuser,gid=mygroup //cifs_ip/share /media/mycifs
exit 0
Make sure "exit 0" is on the last line, and adapt the names in the commands to your situation.

Note: don't do this when you have systemd installed. Follow this tutorial instead: http://forums.solydxk.nl/viewtopic.php?f=9&t=4358


SolydXK needs you!
Development | Testing | Translations

User avatar
ath_pg
Posts: 21
Joined: 01 Sep 2013 09:34

Re: Hangs on shutdown after upgrade

Postby ath_pg » 05 Aug 2014 03:36

Thanks Schoelje.
To be honest, I'm not quite comfortable with mounting using rc.local, since fstab is designed for this job essentially. In addition, I am still trying to figure out why it was working before and not working after the upgrade. I will post the progress here.

User avatar
Arjen Balfoort
Site Admin
Posts: 8986
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Hangs on shutdown after upgrade

Postby Arjen Balfoort » 05 Aug 2014 06:13

I'm using a wireless connection, and I never was able to cifs mount correctly in fstab, whatever I tried. I remember vaguely that I didn't have that problem with a wired connection, though.


SolydXK needs you!
Development | Testing | Translations

User avatar
ath_pg
Posts: 21
Joined: 01 Sep 2013 09:34

Re: Hangs on shutdown after upgrade

Postby ath_pg » 05 Aug 2014 06:18

I always use wired connection to mount fstab. It used to work without any problem until I upgrade to UP 7.15.

User avatar
tuxic
Posts: 39
Joined: 24 Sep 2013 10:31

Re: Hangs on shutdown after upgrade

Postby tuxic » 05 Aug 2014 10:18

I'm having the same problem when the screen message is "Stoping Netbios name server" and also something related to nmbd or something like dad. I looked for the words in Synaptic but found anything related installed...

User avatar
Arjen Balfoort
Site Admin
Posts: 8986
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Hangs on shutdown after upgrade

Postby Arjen Balfoort » 06 Aug 2014 14:20

If you have your cifs mounted in fstab, you can try to create this file:

Code: Select all

su
echo "#!/bin/sh

# mount/unmount cifs shares on network-manager up/down events.
# Copy this file to: /etc/NetworkManager/dispatcher.d/

case "$2" in
   up)
      #mount -a -t cifs
      ;;
   down)
      umount -a -t cifs
      ;;
esac 
" > /etc/NetworkManager/dispatcher.d/00cifs
chmod +x /etc/NetworkManager/dispatcher.d/00cifs


SolydXK needs you!
Development | Testing | Translations

User avatar
ath_pg
Posts: 21
Joined: 01 Sep 2013 09:34

Re: Hangs on shutdown after upgrade

Postby ath_pg » 07 Aug 2014 11:17

Thanks Schoelje.
Unfortunately, this patch doesn't work either.
I test the single command

Code: Select all

umount -a -t cifs
, it works fine. But if I put it under NetworkManager/dispatcher.d/ as you indicates, the shutdown info says failed to terminate process, as shown in the attached picture.
DSC_0504-s.jpg
I also tried to create a script and add it as K01** to rc0.d and rc6.d, no luck. It seems the umount command doesn't work properly under init, just as the same as your patch.

Now, as a temporary solution, I create a script of

Code: Select all

umount -a -t cifs
, execute it manually before I shutdown or reboot. At least I know it is because umount is not working properly when called by init.

User avatar
Arjen Balfoort
Site Admin
Posts: 8986
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Hangs on shutdown after upgrade

Postby Arjen Balfoort » 07 Aug 2014 12:37

I'm having the same issue with systemd on a laptop.
I'm going to try if wicd handles it better, and if that doesn't work I can only think of defining your network in /ect/network/interfaces


SolydXK needs you!
Development | Testing | Translations

User avatar
Arjen Balfoort
Site Admin
Posts: 8986
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Hangs on shutdown after upgrade

Postby Arjen Balfoort » 08 Aug 2014 14:39

After a lot of experimenting, I found that you can either do two things:
  1. Define your wireless connection in /etc/networks/interfaces
  2. Use autofs (which I've done now for my laptop): http://forums.solydxk.nl/viewtopic.php?f=9&t=4512


SolydXK needs you!
Development | Testing | Translations


Return to “News & Anouncements”

Who is online

Users browsing this forum: No registered users and 5 guests