SolydXK: Plymouth on Intel, ATI, NVIDIA

SolydXK is too quiet for you? SolydXK Enthusiast Editions, based on Debian Testing is for you! Here you can find news about Debian Testing and Unstable too, and also tests on SolydXK programs.
The support for SolydXK EE is provided by the community.
User avatar
just
Posts: 297
Joined: 07 Nov 2013 08:06
Location: Rovaniemi, Finland

SolydXK: Plymouth on Intel, ATI, NVIDIA

Postby just » 04 Nov 2014 15:09

many times in this forum plymouth-on-nvidia was accused to not being stable enough, to prevent boot and/or installation of the system, to hang it, to work bad or not to work at all.

i disagree.

default SolydXK Plymouth works well on all cards i have: Intel, ATI, NVIDIA.

even a freshly prepared live media (LiveUSB, LiveDVD) can be happily booted with Plymouth into live session on NVIDIA. there's no need to "Start SolydK wihout Plymouth". the default "Start SolydK" works just fine.

the currently available dev-testing solydk64_201410.iso of 30-Oct-2014 08:54 1.8G was used in these tests. which is a very boring ISO - everything simply works without a hitch :) .

to get plymouth work on nvidia or any other card all that is needed is to add one parameter to the kernel's boot line:

Code: Select all

vga=nnn
where nnn is one of the available graphic card's vbe modes. unfortunately, there's no standard for them. you may try:

Code: Select all

800×600    =  789
1024×768   =  792
1280×1024  =  795
1600×1200  =  799
1600×900   = 1008
1920×1080  =  895
read more about vesa bios extensions modes here.

alternatively, you may use vga=ask boot parameter. in this case the boot will stop and propose you some basic framebuffer modes you may choose from. select any one you want, it doesn't important.

don't use vga=normal parameter. in this case SolydXK will boot, but without plymouth.

two of my computers boot with vga=895, while another one with vga=1008. all are equipped with nvidia. plymouth works flawlessly.

ideally, the vga= mode should correspond to your graphical desktop resolution. that's why i'm using vga=895 and vga=1008.

but on SolydXK it is possible to use any explicit vga=nnn parameter. when it is present, SolydXK is smart enough to switch the framebuffer to the max available resolution, and use it for Plymouth.

example: on nvidia with 1920×1080 max resolution i can happily boot with plymouth specyfying vga=789 - the 800×600 resolution. SolydXK will boot with Plymouth in 1920×1080 nevertheless.

SolydXK only hangs with Plymouth on NVIDIA when vga=nnn parameter is not specified.

to boot from LiveUSB/DVD with Plymouth:
  1. select the 1st option from the boot menu (the default one) "Start SolydK"
  2. hit TAB once to edit the kernel's boot line
  3. add vga=789 anywhere you want in that line
  4. don't alter other boot parameters
  5. hit Enter, to boot with plymouth
to boot installed SolydXK with Plymouth:
  • add vga=nnn parameter to the boot line
it's that simple.

User avatar
palimmo
Posts: 809
Joined: 19 Nov 2013 19:44
Contact:

Re: SolydXK: Plymouth on NVIDIA

Postby palimmo » 04 Nov 2014 20:16

do you mean here

Code: Select all

sudo kate /etc/default/grub
should I add it at the end of the file?

Code: Select all

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT="0"
#GRUB_HIDDEN_TIMEOUT="0"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_TIMEOUT="3"
GRUB_DISTRIBUTOR="`cat /etc/solydxk/info | grep GRUB_TITLE | cut -d= -f2 2> /dev/null || echo SolydXK`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL="console"

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1024x768
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID="true"

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

#export GRUB_MENU_PICTURE="/usr/share/images/desktop-base/desktop-grub.png"
in my case should be this
1024×768 = 792
thanks!
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: SolydXK: Plymouth on NVIDIA

Postby zerozero » 04 Nov 2014 20:26

the reported (and real for some time) problem was not only with proprietary nvidia but also with fglrx.
last test i did with with the 2014.10 dev isos [ http://forums.solydxk.nl/viewtopic.php? ... 623#p45623 ] fglrx and plymouth could coexist together (and without tweaks)
bliss of ignorance

User avatar
just
Posts: 297
Joined: 07 Nov 2013 08:06
Location: Rovaniemi, Finland

Re: SolydXK: Plymouth on NVIDIA

Postby just » 04 Nov 2014 20:53

before editing grub config, making the changes permanent, try vga= parameter "on-the-fly" for already existing kernel boot line. while in boot menu, press Esc to exit from graphic mode and enter the text menu mode, then press "e" (if i recall well; sorry, i'm not using much hated grub2) to edit the kernel parameters line.

add vga=nnn to it. then press "b" to boot with that line.

if it works well for you, then you may edit /etc/default/grub, to make the changes permanent.

yes, if you're using grub2, you should edit /etc/default/grub as root, but do not simply add this parameter somewhere in that file. you should edit the line:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
which will become:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vga=895"
or any other numeric value suitable for your card. repeat, before making this changes in /etc/default/grub, try it out on-the-fly.

BTW, to quickly find basic vbe modes available for a video card, the users of grub2 may use vbeinfo command in the grub2 command-line interface. all users, indipendently from their boot loader, may find the same basic vbe modes in terminal with:

Code: Select all

# hwinfo --framebuffer
unfortunately, neither of two commands returns the highest available modes. don't remember right now, how i managed to find 895 and 1008 for my boxes :shock: ...

EDIT: if you have modified the /etc/default/grub file, remember to run update-grub or update-grub2 command after that! (still don't know the difference between them.)

User avatar
palimmo
Posts: 809
Joined: 19 Nov 2013 19:44
Contact:

Re: SolydXK: Plymouth on NVIDIA

Postby palimmo » 04 Nov 2014 21:15

thanks. I'll try asap. My plymouth splash screen during the shut-down has been terrible for so much long time...
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/

User avatar
just
Posts: 297
Joined: 07 Nov 2013 08:06
Location: Rovaniemi, Finland

Re: SolydXK: Plymouth on NVIDIA

Postby just » 04 Nov 2014 21:34

zerozero wrote:
the reported (and real for some time) problem was not only with proprietary nvidia but also with fglrx...
sorry zz, but this is the first time when [DELETE: i'm not 100% agree with] [INSERT: i can't follow] you :shock: . neither proprietary nor freeware, neither nvidia nor ati video drivers have nothing to do with plymouth problems.

video drivers are totally unrelated with plymouth.

on boot plymouth is typically started from initramfs, and is stopped before X-org or any display manager start working. on shutdown plymouth starts working after X-org has been exited. in both cases any video drivers are still/already light years away from plymouth.

plymouth problems are related only to specific for every video card hardware specs, and how the framebuffer is controlled by the kernel.

if you agree, could we close the discussion here? the intention was only to give a quick advice to use vga=nnn to get plymouth back, nothing more.


Return to “Testing Zone”

Who is online

Users browsing this forum: No registered users and 2 guests