Synaptic problem reloading package info

New to SolydXK? This is the place to start.
Please check the other subforums to see if there's a more suitable place for your question.
sxphild
Posts: 12
Joined: 07 Aug 2019 10:53

Synaptic problem reloading package info

Postby sxphild » 18 May 2020 11:33

I have been trying to update firefox ro latest version (76) from my current(75).

Synaptic doesn't show the new version. So I asked it to
check repository ( which I have done in the past ).
I have been doing this for almost a week now...

I get these error messages

Code: Select all


There is no public key available for the following key IDs:
AA8E81B4331F7F50GPG error: http://dl.google.com stable InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 78BD65473CB3BD13Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/main/binary-amd64/Packages  404  Not Found [IP: 130.89.148.12 80]
Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/contrib/binary-amd64/Packages  404  Not Found [IP: 130.89.148.12 80]
Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/non-free/binary-amd64/Packages  404  Not Found [IP: 130.89.148.12 80]
Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/main/binary-i386/Packages  404  Not Found [IP: 130.89.148.12 80]
Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/contrib/binary-i386/Packages  404  Not Found [IP: 130.89.148.12 80]
Failed to fetch http://ftp.debian.org/debian/dists/jessie-backports/non-free/binary-i386/Packages  404  Not Found [IP: 130.89.148.12 80]
Some index files failed to download. They have been ignored, or old ones used instead.

I am running solydX 201701 version.

Any ideas?

Thanks,

Phil

User avatar
Arjen Balfoort
Site Admin
Posts: 9425
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Synaptic problem reloading package info

Postby Arjen Balfoort » 18 May 2020 12:59

Yes, jessie-backports has been discontinued.

You can remove that line from /etc/apt/sources.list and run:

Code: Select all

apt update
apt upgrade


SolydXK needs you!
Development | Testing | Translations

sxphild
Posts: 12
Joined: 07 Aug 2019 10:53

Re: Synaptic problem reloading package info

Postby sxphild » 21 May 2020 16:22

Thank you, Arjen...

I did what you suggested, deleted the line from sources.list
and ran the apt commands. apt upgrade shows a lot of "E: Failed to fetch..".
messages...apt upgrade complains there is no PUBLIC KEY for 3
repos ( I think ).

Then I went back to synaptic and looked. latest version of firefox is
still listed as 75.0-1 ( which is what is installed ).

I have another machine, running solydX 201909 with firefox 76 installed and
running...did the SolydXK repos stop updating firefox for and older version?
I am running 201701 on most of my machines, since they choke during the
installation on versions with Debian 10 as the kernel...

I know I could download the whole firefox installation direct from firefox, and
run it from a separate folder, but this is messy...and I don't know where to place
the various parts of the installation ( i.e. in /etc or /opt )

What do you suggest I try?

User avatar
Arjen Balfoort
Site Admin
Posts: 9425
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Synaptic problem reloading package info

Postby Arjen Balfoort » 22 May 2020 06:22

The 201701 ISO was based on Debian 7 Wheezy which you upgraded to Debian 8 Jessie, right? SolydXK maintains packages for the previous version (based on Debian 9 and Firefox only is updated), the current (Debian 10) and testing (Debian 11). The Debian 8 repository received updates for Firefox but was discontinued a few weeks ago.

I recommend that you either upgrade SolydXK to the current version or replace Firefox with Mozilla's version.

Your key error just needed a simple search:
https://askubuntu.com/questions/1205540 ... nformation


SolydXK needs you!
Development | Testing | Translations

sxphild
Posts: 12
Joined: 07 Aug 2019 10:53

Re: Synaptic problem reloading package info

Postby sxphild » 22 May 2020 11:00

OK, thanks. You can see I am still a "newbie", eh?

I appreciate your help! I love your O/S...put it on
many people's machines who are migrating from Windows.
Very friendly to a newcomer to Linux..

Phil

User avatar
ilu
Posts: 2657
Joined: 09 Oct 2013 12:45

Re: Synaptic problem reloading package info

Postby ilu » 22 May 2020 20:37

And if you decide to update Firefox from Mozilla, put everything into /opt. Nothing goes into /etc.

Arjen: 201701 iso doesn't sound right for wheezy. Probably 201201? I'm just mentioning this so nobody is mistaken aubout the support period.

sxphild
Posts: 12
Joined: 07 Aug 2019 10:53

Re: Synaptic problem reloading package info

Postby sxphild » 22 May 2020 20:45

Hi ilu,
FYI
Here is the result of uname -a

Code: Select all


Linux solydxk-dx-2400 3.16.0-4-amd64 #1 SMP Debian 3.16.39-1 (2016-12-30) x86_64 GNU/Linux

Phil


Return to “Newbie Questions”

Who is online

Users browsing this forum: No registered users and 1 guest