Page 1 of 1

(Solved) Installing Clementine 1.2 in SolydK

Posted: 16 Oct 2013 02:23
by not found
So I have never really understood everything surrounding packaging and versions and libraries etc. so perhaps someone can help me understand a bit more.

I just saw that Clementine 1.2 dropped a few days ago. Now it isn't in any of the Debian repo's as yet but there are several deb's available.

I decided to grab the 64-bit one for wheezy (I imagine this is the closest I can get to Testing out of the choices available). I tried installing it, first with dpkg and then also with gdebi and there were unmet dependencies.

Now the one I looked at and tried to solve was called liblastfm0. Now what I find interesting about this library is the fact that a search for it in the packages for Debian shows it is available for all versions of Debian, except Testing. liblastfm1 is available in Testing and in Sid (Sid has liblastfm0 as well) and is installed.

So I guess I am wondering how do I go about solving this?


404

Re: Installing Clementine 1.2 in SolydK

Posted: 16 Oct 2013 16:14
by not found
Well being an idiot and never really understanding how things work I tried several other debs from https://code.google.com/p/clementine-pl ... loads/list and got all manner of random unmet dependencies... until I changed my tactics and found the deb of liblastfm0 for wheezy and installed that first, then the deb for clementine1.2 and...

Great success \m/


404

Re: (Solved) Installing Clementine 1.2 in SolydK

Posted: 16 Oct 2013 19:28
by Orbmiser
Strange as my setup is showing liblastfm1 which is version 1.0.8-2 already installed.
And haven't installed Clementine on my setup as still using the default Amarok.
So wouldn't liblastfm0 be going backwards? To an older lib?
Just trying to learn something here and wonder about it.
.

Re: (Solved) Installing Clementine 1.2 in SolydK

Posted: 16 Oct 2013 20:03
by zerozero
in older setups (like mine :roll: using the first isos) you have both lib. installed

Code: Select all

zerozero@home ~ $ apt policy liblastfm0 liblastfm1
liblastfm0:
  Installed: 0.4.0~git20090710-2
  Candidate: 0.4.0~git20090710-2
  Version table:
 *** 0.4.0~git20090710-2 0
        100 /var/lib/dpkg/status
liblastfm1:
  Installed: 1.0.8-2
  Candidate: 1.0.8-2
  Version table:
 *** 1.0.8-2 0
        500 http://debian.solydxk.com/testing/ testing/main amd64 Packages
        100 /var/lib/dpkg/status
though liblastfm0 is local and not present in any active repo

0 was replaced by 1 (and that should be the way it rocks for jessie) but the clementine builds in the official homepage are targeted to wheezy (and need to compile with the lib in wheezy)
very soon we'll see clementine1.2 in testing without this liblastfm issue :lol:

Re: (Solved) Installing Clementine 1.2 in SolydK

Posted: 16 Oct 2013 20:49
by not found
zerozero wrote:very soon we'll see clementine1.2 in testing without this liblastfm issue :lol:
True true :D


404

Re: (Solved) Installing Clementine 1.2 in SolydK

Posted: 16 Oct 2013 21:19
by Orbmiser
zerozero wrote: very soon we'll see clementine1.2 in testing without this liblastfm issue :lol:
That was my thinking and will just wait and expect to see it in next month's or month after updates.
.