Page 1 of 1

grub problems after update

Posted: 04 May 2014 14:11
by toothandnail
I've now had this happen twice on my desktop machine (HP dc7900). After running the main UP, the next time I tried to reboot, the system attempted to start Plymouth and promptly locked up. In order to get it to boot, I had to edit the grub command line and remove the video settings and remove splash. The odd thing is, I disabled Plymouth during the initial install, so I've no idea why it keeps coming back. I would like to be rid of the silly thing once and for all....

After getting the system to restart, I went and edited /boot/grub/grub.cfg to remove the splash nomdeset stuff (I know it says not to edit it, but I've yet to see another way to fix it). So it was booting properly.

There were a few more updates that I let run this morning, and, yet again, the system is trying to start Plymouth and locking up. Looking through /boot/grub/grub.cfg, I find this:

Code: Select all

linux   /boot/vmlinuz-3.13-1-amd64 root=UUID=b456f5d9-71d6-4dcb-afcd-0127862ced5b ro  quiet splash nomodeset video=uvesafb:mode_option=800x600-16,mtrr=3,scroll=ywrap
In order to get a clean boot, I have to remove everything after "quiet". How can I make this change permanent?

I've not had the same problem on my laptop, but I use EasyBCD's neo-grub, which is based on legacy grub and works in a much more predictable fashion....

While I'm on the subject of booting the system, since grub is calling the real kernel image in /boot, why is there still a symlink to it in /? Seems more than a little redundant.

Paul.

Re: grub problems after update

Posted: 04 May 2014 15:35
by fleabus
toothandnail wrote:I would like to be rid of the silly thing once and for all....
I always run around after install with my can of bugspray killing off these things...

Code: Select all

apt-get purge plymouth*
I turn off the DE's splash as well, Don't know which you're running, in KDE it's System Settings -> Workspace Appearance -> Splash Screen [set to "None"]

Just my personal prefs... :)