default localhost

New to SolydXK? This is the place to start.
Please check the other subforums to see if there's a more suitable place for your question.
tux-world
Posts: 31
Joined: 22 Jan 2014 19:34

default localhost

Postby tux-world » 19 May 2014 07:25

hi all. i get 404 in default localhost. why?

tux-world@alachiq ~ $ ls /var/www/ -l
total 4
-rwxrwxrwx 1 tux-world tux-world 42 May 7 12:42 scandir.php


FireFox :

Not Found

The requested URL / was not found on this server.

User avatar
ScottQuier
Posts: 1781
Joined: 18 Jul 2013 15:55
Location: Newport News, VA

Re: default localhost

Postby ScottQuier » 19 May 2014 10:09

A little more detail is needed because, right now, this looks like some sort of coding issue. Need more info of what you are trying to do and what you've already tried to do to get there.
Scott
Quoting zerozero, "The usage of PPA's in debian-based
systems is risky at best and entails serious compatibility
problems; usually it's the best way to destroy an install"

Deleted User 2764

Re: default localhost

Postby Deleted User 2764 » 19 May 2014 15:54

My guess is that maybe you don't have the entire path correct in your address bar. Also be sure you have apache set up correctly so that it looks for files in the directory your files are in. You can find the apache configuration in /etc/apache2/apache2.conf. You need to look for:

Code: Select all

<Directory /var/www/>
	Options Indexes FollowSymLinks
	AllowOverride None
	Require all granted
</Directory>
And be sure that the /var/www/ is where your files actually are. I actually added a directory /var/www/sites and then I put this at the bottom of the apache2.conf file:

Code: Select all

# CGI Script Configuration
ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory /var/www/*/>
AddHandler cgi-script .cgi .pl
Options +ExecCGI +Includes +FollowSymLinks
</Directory>
Then I would put a symlink in /var/www pointing to web site directories in /var/www/sites (like test.com for example I would symlink in /var/www/test.com pointing to /var/www/sites/test.com). After that, you just go into your browser and do like http://localhost/test.com/your_file.php and it should work.

Other things you need to consider is that you have read/write/alter permissions set for those directories. You want to set them as group www-data. Also be sure to reboot apache whenever you make changes:

Code: Select all

$ sudo /etc/init.d/apache2 restart
I hope this helps. As ScottQuier said, it's hard to know exactly the problem unless you're more specific. What were you typing into your browser's address bar?


Return to “Newbie Questions”

Who is online

Users browsing this forum: No registered users and 4 guests