Shut down very slow: "A stop job is running..."

New to SolydXK? This is the place to start.
Please check the other subforums to see if there's a more suitable place for your question.
User avatar
palimmo
Posts: 788
Joined: 19 Nov 2013 19:44
Contact:

Shut down very slow: "A stop job is running..."

Postby palimmo » 13 Aug 2014 09:36

Hi.
When I shut down my laptop, recently it takes a lot.
Pressing F1 (or ESC, I do not remember) I have realised it is stuck at this message:

Code: Select all

A stop job is running for LSB: ... miniDLNA.
Before start searching for a solution, I wonder: do I really need this package? Can I remove it?

The MiniDNLA daemon serves media files (music, pictures, and video) to clients on a network

I do not share any media file on a network....therefore...

Thanks!
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: Shut down very slow: "A start job is running for LSB"

Postby zerozero » 13 Aug 2014 11:29

if you don't need it (and don't use it) you can safely uninstall it.

there a couple topics dealing with issues related with this new version of miniDLNA
http://forums.solydxk.nl/viewtopic.php? ... t=miniDLNA
http://forums.solydxk.nl/viewtopic.php? ... t=miniDLNA
bliss of ignorance

User avatar
palimmo
Posts: 788
Joined: 19 Nov 2013 19:44
Contact:

Re: Shut down very slow: "A start job is running for LSB"

Postby palimmo » 13 Aug 2014 18:10

zerozero wrote:if you don't need it (and don't use it) you can safely uninstall it.
Yes! Now the shutdown is really really fast (4-5 seconds, even less).
I wonder if we could avoid to have that package by default. Does it worth it?

thanks!
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/

User avatar
palimmo
Posts: 788
Joined: 19 Nov 2013 19:44
Contact:

Re: Shut down very slow: "A start job is running..."

Postby palimmo » 07 Sep 2014 13:04

:( Well.. lately I have the same issue with

Code: Select all

A stop job is running for Light Display Manager
and before finalizing it the system takes 10-15 seconds more.
This happens often, but not always. I'm not able to reproduce it.

What should I do now?
Is this related with Systemd? Have you ever experienced it?
Thanks!
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/

User avatar
palimmo
Posts: 788
Joined: 19 Nov 2013 19:44
Contact:

Re: Shut down very slow: "A stop job is running..."

Postby palimmo » 08 Sep 2014 18:19

Noboby has bumped into this issue?
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/

User avatar
ScottQuier
Posts: 1781
Joined: 18 Jul 2013 15:55
Location: Newport News, VA

Re: Shut down very slow: "A stop job is running..."

Postby ScottQuier » 08 Sep 2014 19:06

I may have, but I need to take a look at my machine when I get home to see if this is the reason my shutdowns sometimes take 30 seconds. The longer shutdowns seem to be an intermittent issue. I'll post back later this evening if I find not of this issue in my logs.
Scott
Quoting zerozero, "The usage of PPA's in debian-based
systems is risky at best and entails serious compatibility
problems; usually it's the best way to destroy an install"

User avatar
palimmo
Posts: 788
Joined: 19 Nov 2013 19:44
Contact:

Re: Shut down very slow: "A stop job is running..."

Postby palimmo » 08 Sep 2014 19:24

ScottQuier wrote:I may have, but I need to take a look at my machine when I get home to see if this is the reason my shutdowns sometimes take 30 seconds. The longer shutdowns seem to be an intermittent issue. I'll post back later this evening if I find not of this issue in my logs.
Thanks ScottQuier. Same situation here.
Just press esc (or F1, I don not remember) when you notice the slowdown.
Let me know! ;)
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/

User avatar
palimmo
Posts: 788
Joined: 19 Nov 2013 19:44
Contact:

Re: Shut down very slow: "A stop job is running..."

Postby palimmo » 10 Sep 2014 18:49

any idea? :cry:
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/

User avatar
ScottQuier
Posts: 1781
Joined: 18 Jul 2013 15:55
Location: Newport News, VA

Re: Shut down very slow: "A stop job is running..."

Postby ScottQuier » 10 Sep 2014 20:00

F1 didn't do anything.

Still preliminary but it SEEMS to be related to whether I have a USB device plugged in. If I have an external USB HDD plugged in (like I did last night but usually don't), it takes 30+ seconds to shut down. More testing required because I'm not certain there's a cause and effect relationship here.
Scott
Quoting zerozero, "The usage of PPA's in debian-based
systems is risky at best and entails serious compatibility
problems; usually it's the best way to destroy an install"

User avatar
palimmo
Posts: 788
Joined: 19 Nov 2013 19:44
Contact:

Re: Shut down very slow: "A stop job is running..."

Postby palimmo » 10 Sep 2014 20:41

In my case it happens without any usb device plugged in.
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/

User avatar
palimmo
Posts: 788
Joined: 19 Nov 2013 19:44
Contact:

Re: Shut down very slow: "A stop job is running..."

Postby palimmo » 14 Sep 2014 09:04

nobody has experienced this? :(
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Shut down very slow: "A stop job is running..."

Postby MAYBL8 » 14 Sep 2014 11:48

I had this with entries from fstab where I was adding other external drives to connect to.


User avatar
palimmo
Posts: 788
Joined: 19 Nov 2013 19:44
Contact:

Re: Shut down very slow: "A stop job is running..."

Postby palimmo » 14 Sep 2014 12:30

This is my fstab

Code: Select all

# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc	/proc	proc	defaults	0	0
# /dev/sda5
UUID=f420b490-1d24-43f0-a56a-763453136af5	/	ext4	rw,errors=remount-ro	0	1
# /dev/sda7
UUID=70ca2e98-0985-40cd-a9c4-beed0615fb9d	swap	swap	sw	0	0
# /dev/sda6
UUID=4F00-0987 /media/Data vfat defaults,user,exec,uid=1000,gid=100,umask=000 0 0
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Shut down very slow: "A stop job is running..."

Postby MAYBL8 » 14 Sep 2014 13:10

I think it might have to do with that last line for sda6.
To do some troubleshooting we can do this:

edit /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

take the word 'quiet' out. That will display your items that are happening in the background as your system shuts down.
after you have edited it run
sudo update-grub

Then shut down.
If it is hanging on sda6 which looks like some kind of external drive you could comment it out and see if it shuts down faster.

This is all a guess by me. Not really sure if this is the problem.


User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: Shut down very slow: "A stop job is running..."

Postby zerozero » 14 Sep 2014 18:21

you could try this
snapshot306.png
systemsettings > startup and shutdown > session management > on login
and choose start with an empty session
logout & login
[last couple days my system was also hanging on shutdown <it wasn't doing it before> and this, apparently, fixed it]
bliss of ignorance

User avatar
palimmo
Posts: 788
Joined: 19 Nov 2013 19:44
Contact:

Re: Shut down very slow: "A stop job is running..."

Postby palimmo » 18 Sep 2014 21:46

Unfortunately this has not solved the problem.. :cry: :cry:
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/


Return to “Newbie Questions”

Who is online

Users browsing this forum: No registered users and 1 guest