Page 1 of 1

PIA VPN not working anymore

Posted: 16 Nov 2016 02:50
by vortex
Hello,

After the last update from 13 November, my Solydx distro's do not want to connect over the VPN i use to connect to my work.

We tested different ports, reinstalling, firewall off, no avail. This on all 4 machines running the latest version of Solydx here.

After several hours i tried on another Debian Jessie based distro, there it works...

What is so special about the last update ? on my ISP side nothing has changed, like blocking different or more ports.

Did someone else experienced this ?

Thanks

Re: PIA VPN not working anymore

Posted: 16 Nov 2016 19:04
by ilu
The last updates were all debian security updates. So there can't be a difference to the debian system you tested - if that one was fully updated. Was the debian system you tested on your network? Which internet provider?

Re: PIA VPN not working anymore

Posted: 18 Nov 2016 10:42
by vortex
Hello,

Yes the other Debian i installed here was Robolinux 8.7 Mate 64 bit, fully updated also the Solydx was fully updated Sunday evening, a few hours before all worked fine.
Like i told the Solydx was running on 4 different machines even one with 32 bit , from Monday on the PIA can not connect to any of their server, after about 30 seconds it says " you are disconnected".

My ISP is Telenet be , i checked their blocked ports, and played around with that also , nothing works, even just now o tried no go.

On the other Debian, the RoboLinux, it works fine, both tested on the same cable connection, also via wifi , no go.

I also find it very strange, i did not installed or changed anything on the Solydx , because it was always running fine..

Also the 32 bit i tried had no extra apps or progs installed , just a fresh install... not working.

But i just think of it , the Robolinux is based on Debian stable.. Solydx on testing..maybe.

I will try to install a Solydx without internet connection and see what happens.


to be continued


kind regards

Re: PIA VPN not working anymore

Posted: 18 Nov 2016 10:57
by kurotsugi
instead of looking into what was added perhaps you should start with what was missing. there was several missing packages so that it doesn't work well with vpn. the issue have been fixed in the newest iso but older system might still suffer with this issue.

though, from your description it sounds like the problem was on server side or a configuration issue. solydxk is also based on debian stable. if robolinux works then solydxk should work too.

lastly, if you're experienced, you can solyxk-ing a robolinux. you can turn any debian stable based distro into solydxk with several tweaks (with some exception, almost all debian based distro are interchangeable. kinda like magic :3). though, using vanilla debian will lot easier.

Re: PIA VPN not working anymore

Posted: 18 Nov 2016 16:19
by vortex
Hello,

@Kurotsugi, it might be that kind of problem, i installed this afternoon the last iso 2016-06 from Solydx without internet connection during install, and also later the older version 2015-12 both the same thing no go.

About using the repo from Solydx, i would like to try , if anyone has a link to such an undertaking i would be thankful .

I am not "that" experienced in copying the sources etc :-)


grtz

Re: PIA VPN not working anymore

Posted: 18 Nov 2016 21:37
by kurotsugi
solydxk-ing a vanilla debian would be as easy as add solydxk repo then install solydxk packages. there will be more job to make a debian looks like a solydxk but since I usually have a custom desktop I usually not bothered making a debian looks like a solydxk.

Re: PIA VPN not working anymore

Posted: 19 Nov 2016 06:50
by vortex
Hello again,

Well i gave it a try, copying the apt folder from Robolinux to Solydx, and after reloading synaptic, he wanted a few updates... strangely everything works now as it should, i noticed that both repositories from Solydx and the one from Robolinux are there in the sources list, i thought the ones from Solydx would be deleted, but even better.
Now all is fine, i got the best of both of them :clap:


thanks for the tips guys

hopefully there will be a Mate version of Solyd soon ...... ;)

Re: PIA VPN not working anymore

Posted: 19 Nov 2016 07:28
by kurotsugi
I think there won't be solydM because there's already lmde mate version. but, again, solydxk-ing is easy.