solyxk-pepperflashplugin package question

New to SolydXK? This is the place to start.
Please check the other subforums to see if there's a more suitable place for your question.
bobeng
Posts: 5
Joined: 23 May 2017 11:42

solyxk-pepperflashplugin package question

Postby bobeng » 02 Aug 2017 15:36

SolydX noob here. Recently did “in-place” upgrade from SolydX Jessie to SolydX Stretch. Installed Chromium 59.0.3071.86-1 using Synaptic. Installed solydxk-pepperflashplugin 26.0.0.137 using Synaptic to provide flash support in Chromium. After installing solydxk-pepperflashplugin, I looked at Synaptic “installed files” tab for the solydxk-pepperflashplugin package and I see that /usr/lib/PepperFlash/libpepflashplayer.so is installed. When I hex view the file, I see that the level of the libpepflashplayer.so module is 25.0.0.127. Question – shouldn’t the level of libpepflashplayer.so in the “solydxk-pepperflashplugin 26.0.0.137” package be 26.0.0.137 ? Thank you.

User avatar
grizzler
Posts: 1886
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: solyxk-pepperflashplugin package question

Postby grizzler » 03 Aug 2017 11:34

Yes, you are correct. The so file in that package appears to be the previous version. The manifest file hasn't been updated either, so I think something must have gone wrong when the package was last updated.

Unfortunately, I don't have access to the server, so we'll have to wait until Arjen comes back from his holiday.
Frank

SolydX EE 64 - tracking Debian Testing

bobeng
Posts: 5
Joined: 23 May 2017 11:42

Re: solyxk-pepperflashplugin package question

Postby bobeng » 03 Aug 2017 16:12

Thank you for confirming my suspicion. I knew that something was wrong when I tried to use flash in Chromium after installing the "solyxk-pepperflashplugin 26.0.0.137" package. I kept getting getting an informational message from Chromium that the level of flash was out of date whenever I brought up a page requiring flash. Putting "chrome://flash" in the address bar of the Chromium browser, it showed the level of flash being used by Chromium as 25.0.0.127. This motivated me to check out what level of flash was really installed by the "solyxd-pepperflashplugin 26.0.0.137" package.

Regards,
Bob

User avatar
Schoelje
Site Admin
Posts: 8460
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: solyxk-pepperflashplugin package question

Postby Schoelje » 09 Aug 2017 10:58

I've just updated the pepperflash plugin.
Can anyone confirm it is the right version?


SolydXK needs you!
Development | Testing | Translations

bobeng
Posts: 5
Joined: 23 May 2017 11:42

Re: solyxk-pepperflashplugin package question

Postby bobeng » 09 Aug 2017 12:10

I just installed the "solydxk-pepperflashplugin 26.0.0.151" package. I can confirm that "chrome://flash" now reports that it is using flash version 26.0.0.151 -- which is the latest level of Adobe flash available. I no longer get the message from the Chromium browser that the level of flash that I am using is outdated when I bring up a webpage requiring flash. So, yes, the issue is fixed. Thank you!

User avatar
grizzler
Posts: 1886
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: solyxk-pepperflashplugin package question

Postby grizzler » 09 Aug 2017 12:13

26.0.0.151. That's the most recent, so looks good.

The older packages are still in the repository, though. You may want to remove them (same for the solydxk-flashplugin package).
Frank

SolydX EE 64 - tracking Debian Testing

User avatar
Schoelje
Site Admin
Posts: 8460
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: solyxk-pepperflashplugin package question

Postby Schoelje » 09 Aug 2017 13:29

grizzler wrote:26.0.0.151. That's the most recent, so looks good.

The older packages are still in the repository, though. You may want to remove them (same for the solydxk-flashplugin package).

Done.


SolydXK needs you!
Development | Testing | Translations


Return to “Newbie Questions”

Who is online

Users browsing this forum: No registered users and 5 guests