Google Calendar will not auto start

New to SolydXK? This is the place to start.
Please check the other subforums to see if there's a more suitable place for your question.
yaloo1935
Posts: 9
Joined: 26 Aug 2013 03:43

Google Calendar will not auto start

Postby yaloo1935 » 16 Aug 2017 11:14

I have install Solydx 9 and installed Google Calendar Indicator, Dropbox, and CopyQ setting the option to auto start. There are entries in the "Startup Application", for all 3. Dropbox and CopyQ will start on login but not Google Calendar Indicator. It is contained in the main menu under "Other" and will start when selected. I have deleted the original entry in the applications list and created a new one, added some time delay to no avail. My work around is simply starting the entry in "Other" upon the completion of the login process which Copyq, Dropbox, and Update Manager does start and displays the icons in the system tray.

User avatar
belze
Posts: 221
Joined: 29 Sep 2014 16:31
Location: Torino, Italy

Re: Google Calendar will not auto start

Postby belze » 17 Aug 2017 22:32

clearly this software is not in debian nor solyd official repositories. can you ask support to developers of this software?
I'm not an xfce user myself anyway.
-------
Image

yaloo1935
Posts: 9
Joined: 26 Aug 2013 03:43

Re: Google Calendar will not auto start

Postby yaloo1935 » 17 Aug 2017 23:38

You are correct about the type of software it is not; however, I have it installed on LMDE 2 Debian based as you probably know, on Linux Mint 18.2 (XFCE, Cinnamon, and Mate), Ubuntu 16.04.3 (Cinnamon) Xubuntu (XFCE) and Google Calendar Indicator starts on Login just fine. I have compared the entries in all of the Startup Session application lists and they appear as expected. As stated in the post it will start the menu entry in Solydx as well as all the others. Just some little hook not set but I have not found it. Thanks for the reply!

kurotsugi
Posts: 1952
Joined: 09 Jan 2014 00:17

Re: Google Calendar will not auto start

Postby kurotsugi » 18 Aug 2017 00:10

what happened when you tried to run it from terminal?

User avatar
ilu
Posts: 1671
Joined: 09 Oct 2013 12:45

Re: Google Calendar will not auto start

Postby ilu » 18 Aug 2017 00:16

There have been autostart issues for Google Calendar Indicator in the past. Did you install the same version that works on the other systems? Start in terminal and post the output.

yaloo1935
Posts: 9
Joined: 26 Aug 2013 03:43

Re: Google Calendar will not auto start

Postby yaloo1935 » 18 Aug 2017 02:12

The first screen print of the entry in Startup. and the command is ( /opt/extras.ubuntu.com/calendar-indicator/bin/calendar-indicator) Note that the ICON for Calendar-Indicator is not in the system tray which has the DropBox, CopyQ, and Wi-Fi icons.
I double click the calendar-indictor of /opt/extras.ubuntu.com/calendar-indicator/bin/calendar-indicator, which allows a choice to Run or run from terminal. See the second screenshot.
Third screenshot (terrible format but I could not decide how to display the terminal output) but noticed the icon is now displayed. The same results when Run was selected. Or as I previously stated Item Other Calendar-Indicator will place the icon in the system tray.

This may not give you enough detail and if you will give me some instructions I will try to send what you need.

If you time is critical and you need to cease I understand and know how to work a round until later.

Howard (yaloo1935)
Attachments
Screenshot_2017-08-17_20-21-32.png
Screenshot_2017-08-17_20-17-54.png
Screenshot_2017-08-17_19-48-02.png

User avatar
ilu
Posts: 1671
Joined: 09 Oct 2013 12:45

Re: Google Calendar will not auto start

Postby ilu » 18 Aug 2017 16:52

The screenshot with the terminal output shows several error messages but the screenshot shows only half of it. Please open a terminal, enter "calendar-indicator" (or whatever the correct start command would be) and copy the output. Mark with the mouse and right-click and copy and paste the whole terminal output into your posting and format it with code tags, you'll find them among the icons above your post.

Code: Select all

[code][/code]

Where did you get your calendar-indicator install from? The directory name suggests it was a Ubuntu package and not made for debian so the icon and tray applet might have landed in the wrong place.

yaloo1935
Posts: 9
Joined: 26 Aug 2013 03:43

Re: Google Calendar will not auto start

Postby yaloo1935 » 18 Aug 2017 22:24

Spent a bunch of time almost learning some terminal cmds to satisfy your request. Running GCI (Google Calendar Indicator) creates a very large data file. Could not accomplish the task. But I would like to suggest an alternative. I will include the steps I followed to install GCI and if you have a nice test machine, perhaps it would be less time-consuming if you would install it. I know you indicated that you were not a user of XFCE which might be a problem. But if you were to install it on SolydK would it not provide the same information? I have only dabbled with KDE and don't have it installed on any my PCs and don't recall if I ever installed GCI on a KDE version..

So here are the steps if you agree to the suggestion.

As we all know, Debian doesn’t have built-in support for Launchpad PPA. However, we can manually add the PPA and then install the indicator.
Edit software source configuration file with root privilege.
sudo gedit /etc/apt/sources.list
Paste the following two lines at the end of this file.
deb http://ppa.launchpad.net/atareao/atareao/ubuntu trusty main
deb-src http://ppa.launchpad.net/atareao/atareao/ubuntu trusty main
Press Ctrl+O to save the file. Ctrl+X to close the file. Then run the below command to import the GPG signing key of this PPA which can be found on Launchpad if you like to confirm the key.
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 36FD5529

sudo apt update && sudo apt-get install calendar-indicator


The results will be a menu item called OTHER containing calender-indicator

Oops! It works with gmail account and if you don't have one--back to the drawing board.

I will keep poking around and just start GCI when I need t check my activities.
I really do appreciate your assistance and it has caused me to brush up on some things I haven't used in a while or in some cases ever!

User avatar
ilu
Posts: 1671
Joined: 09 Oct 2013 12:45

Re: Google Calendar will not auto start

Postby ilu » 19 Aug 2017 10:40

Debian doesn't support ppa. SolydXK doesn't support ppa. It might work or it might not. In this case it obviously doesn't. And it might screw up your system. At least remove the ppa entries in your sources.list after installation.

And yes, I use SolydX, not KDE, and no, I do not agree to the suggestion :-)

Ask the developers of calendar-indicator to provide a debian package. Or follow Xiao Guoan's comment on the site you used and compile from source. And I'm sorry, but I can't help with compiling.

kurotsugi
Posts: 1952
Joined: 09 Jan 2014 00:17

Re: Google Calendar will not auto start

Postby kurotsugi » 21 Aug 2017 00:15

there are some warning but the calendar indicator seems works. so the problem is on the startup mechanism. adding sleep 60 in front of the command string sometimes help.

yaloo1935
Posts: 9
Joined: 26 Aug 2013 03:43

Re: Google Calendar will not auto start

Postby yaloo1935 » 21 Aug 2017 02:42

I added the sleep parameter as follows plus I increased the Notification size (just fishing here because the icon does display when manually started).

sleep 60; /opt/extras.ubuntu.com/calendar-indicator/bin/calendar-indicator

Is this the correct format? Because it still does not show up at fresh boot up.

kurotsugi
Posts: 1952
Joined: 09 Jan 2014 00:17

Re: Google Calendar will not auto start

Postby kurotsugi » 21 Aug 2017 03:45

I think it should be

Code: Select all

sleep 60 && /path/to/file
sleep 60 means that it will gives 60 seconds delay so that your desktop is fully ready before executing the program. regarding this line,

Code: Select all

/opt/extras.ubuntu.com/calendar-indicator/bin/calendar-indicator
I'm not quite sure about it. I rarely use something outside the official repo but IIRC the syntax is different. perhaps it like this

Code: Select all

sleep 60 && ./opt/extras.ubuntu.com/calendar-indicator/bin/calendar-indicator
if the program is a shell script using "bash /path/to/file" sometimes works too. though, your program is a python so it won't work on it. either way, you'll need to find the correct form using terminal.

meanwhile, please also check the file permission and attribute. IIRC you'll need 655 to make it executeable.


Return to “Newbie Questions”

Who is online

Users browsing this forum: No registered users and 4 guests