[Solved] Change from UTC to local time

New to SolydXK? This is the place to start.
Please check the other subforums to see if there's a more suitable place for your question.
toothandnail
Posts: 94
Joined: 02 Jun 2013 18:45
Location: Oxfordshire, UK

[Solved] Change from UTC to local time

Postby toothandnail » 02 Jun 2013 18:54

I've installed SolydX to have a look. Overall it looks very good. I have hit one problem though - it appears to have defaulted to using UTC, and if there was a prompt as to whether localtime or UTC should be used, I must have missed it. Haven't looked at a Debian derived distro for quite a while, so I have no idea how to go about changing the default - unfortunately, I still have Windows on this laptop, and need local time rather than UTC.

Paul.

User avatar
Arjen Balfoort
Site Admin
Posts: 9457
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Change from UTC to local time

Postby Arjen Balfoort » 02 Jun 2013 20:17

Hi Paul, and welcome to our forum.

To change your time, follow these simple steps:
From the start menu > System > Time and Date
Hit "Click to make changes"
Change the Time zone
Hit "Click to prevent changes"


SolydXK needs you!
Development | Testing | Translations

toothandnail
Posts: 94
Joined: 02 Jun 2013 18:45
Location: Oxfordshire, UK

Re: Change from UTC to local time

Postby toothandnail » 02 Jun 2013 20:30

Schoelje wrote:Hi Paul, and welcome to our forum.

To change your time, follow these simple steps:
From the start menu > System > Time and Date
Hit "Click to make changes"
Change the Time zone
Hit "Click to prevent changes"
Thanks for the suggestion. Not quite what I need, I'm afraid - the time zone is correct (London), but the system is responding as though the hardware clock is set to UTC, not to the current BST. Its a pain - I normally run Arch Linux, and it has problems when time is set to local rather than UTC, but I've been unable to get Windows to work in UTC, even though it is supposed to work with a registry hack, which I have installed...

I did something similar for SalineOS, but I've not touched it for a while, and can't remember what was needed to change system time from UTC to localtime :oops:

Thanks for the welcome - I like the look of SolydX, and it seems like a very good community as well.

Paul.

User avatar
drc
Posts: 137
Joined: 30 Apr 2013 22:47
Location: Nebraska USA

Re: Change from UTC to local time

Postby drc » 02 Jun 2013 20:34

toothandnail wrote:Thanks for the suggestion. Not quite what I need, I'm afraid
If I read you correctly, you need to re-set the hardware clock. It's been quite a while since I've done this, but I'd "man hwclock" and see what it says there,

toothandnail
Posts: 94
Joined: 02 Jun 2013 18:45
Location: Oxfordshire, UK

Re: Change from UTC to local time

Postby toothandnail » 03 Jun 2013 01:40

drc wrote:
toothandnail wrote:Thanks for the suggestion. Not quite what I need, I'm afraid
If I read you correctly, you need to re-set the hardware clock. It's been quite a while since I've done this, but I'd "man hwclock" and see what it says there,
Thanks. That was the clue:

Code: Select all

hwclock --localtime --hctosys


Seems to have done the trick, though I did think that /etc/ajtime would be re-written to reflect that - when I checked, it was still specifying UTC.

:) Would be nice if I could give Windows up completely, or convince the silly thing to use UTC the way it is supposed to be set...

Paul.

User avatar
greywolf
Posts: 103
Joined: 27 Feb 2013 22:34
Location: Sydney, Australia

Re: Change from UTC to local time

Postby greywolf » 04 Jun 2013 01:48

toothandnail wrote:
drc wrote:
toothandnail wrote:
:) Would be nice if I could give Windows up completely, or convince the silly thing to use UTC the way it is supposed to be set...

Paul.
Are there particular applications holding you back? Why not open a new thread setting out what holds you there; someone might have ideas or experience to help you with Linux alternatives to help make your transition complete!

cheers,
Greywolf.
It was about the dragons. It was always about the dragons!

toothandnail
Posts: 94
Joined: 02 Jun 2013 18:45
Location: Oxfordshire, UK

Re: Change from UTC to local time

Postby toothandnail » 05 Jun 2013 18:45

greywolf wrote:
Are there particular applications holding you back? Why not open a new thread setting out what holds you there; someone might have ideas or experience to help you with Linux alternatives to help make your transition complete!

cheers,
Greywolf.
:) Don't I wish. Trouble is, I sometimes need Windows for client support. So I leave it there. Most of the time it only gets used to update virus signature files and Windows security patches, but I do still sometimes need it.

I guess the easy answer would be to ignore the time that Windows shows. I long ago disabled Windows correction for daylight saving time, and since my timezone is never more than an hour away from UTC, I should change all my Linux installs (SalineOS, Salix, Arch and now SolydX) to UTC and ignore what Windows shows....

Paul.

User avatar
Richard
Posts: 162
Joined: 09 Jun 2013 20:54
Location: Venezuela via Louisiana

Re: [Solved] Change from UTC to local time

Postby Richard » 08 Jul 2013 10:59

This works for me to allow co-existence with less pain:
in a root console:
# date && date MMDDhhmmCCYY.00 && hwclock --systohc
then
# dpkg-reconfigure tzdata (for Debian 5 --> tzconfig)

Some say that only reconfig of tzdata is sufficient, if hwclock --systohc has been run.
Refracta-7.2......32bit
SolydX-201311..32bit
Manjaro-0.8.7.1-x32

dmn473
Posts: 1
Joined: 20 Jul 2013 17:20

Re: Change from UTC to local time

Postby dmn473 » 20 Jul 2013 17:39

toothandnail wrote:
drc wrote:
toothandnail wrote:Would be nice if I could give Windows up completely, or convince the silly thing to use UTC the way it is supposed to be set...
This is a bit late, but you actually can do that, and I figure this post might help future Googlers find a solution to this annoyance. I boot Win7, Win8, and Debian, all of which are set to UTC thanks to the wonderful Arch Wiki: https://wiki.archlinux.org/index.php/Ti ... in_Windows

Basically, in Windows, you need to fire up regedit and add a new dword in HKLM\SYSTEM\CurrentControlSet\Control\TimeZoneInformation called "RealTimeIsUniversal" with a value of 1. Make sure the clock in Windows is accurate, boot Linux, make sure its clock is accurate, and you're done. Or you can simply create a .reg file with the following content and run it:

Code: Select all

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
     "RealTimeIsUniversal"=dword:00000001
Take note of the warning in the above link regarding the suspend/hibernate bug in XP/Vista SP1, though. You may want to stick with localtime if you're using either of them. But I can verify it works without a hitch in 7/8.

toothandnail
Posts: 94
Joined: 02 Jun 2013 18:45
Location: Oxfordshire, UK

Re: [Solved] Change from UTC to local time

Postby toothandnail » 21 Jul 2013 03:21

Thanks for the thought. The Arch wiki is certainly a very useful source of information, much of which is applicable to any Linux distro. As it happens, I had read that, and used the registry hack. Windows (Vista in this case) being Windows, it ignored me and continued treating UTC time as local time.

Still, I recently obtained a spare hard drive caddy for my T400, so I've now got Win 7 installed on the original 160 GB drive that came with the machine. Hopefully I'll recover the ~90 GB that Vista is currently occupying on my normal drive, though that will require a bit of shuffling. The other problem is that since I will have to physically change drives to use Win 7, it will probably never get updated, and will then bitch and moan when I do need to use it.... Still, it does get round the UTC time setting problem quite neatly.

Paul.


Return to “Newbie Questions”

Who is online

Users browsing this forum: No registered users and 1 guest