Another time question (Solved)

New to SolydXK? This is the place to start.
Please check the other subforums to see if there's a more suitable place for your question.
User avatar
jsalpha2
Posts: 296
Joined: 28 May 2013 12:28

Another time question (Solved)

Postby jsalpha2 » 05 Jun 2013 00:13

I've got SolddX set up and showing the correct time, but when I shut down and reboot to Windows, time jumps 4 hours into the future. If it says 8:00PM and I reboot to Windows, it will show midnight. Checked the time in the bios. It's ok.
If I go into Mint and then back to Windows time stays the same. As I'm shutting down and trying to read the messages that flash by I see something about the time, but don't know how to slow the screen down enough to copy the text.

toothandnail
Posts: 94
Joined: 02 Jun 2013 18:45
Location: Oxfordshire, UK

Re: Another time question

Postby toothandnail » 05 Jun 2013 18:39

jsalpha2 wrote:I've got SolddX set up and showing the correct time, but when I shut down and reboot to Windows, time jumps 4 hours into the future. If it says 8:00PM and I reboot to Windows, it will show midnight. Checked the time in the bios. It's ok.
If I go into Mint and then back to Windows time stays the same. As I'm shutting down and trying to read the messages that flash by I see something about the time, but don't know how to slow the screen down enough to copy the text.
That sounds like a problem with one OS using UTC and the other(s) using local time. Most Linux distros offer a choice between localtime and UTC when you install them. Debian (and SolydX) don't.

As a check, what is your time zone offset from UTC? If its 4 hours, you can confirm the problem.

Windows is dumb, and doesn't like UTC, though there is a registry hack that you can use which should make it use UTC instead of defaulting to local time. Trouble is, the hack doesn't always work - certainly hasn't for me.

If the time difference matches your UTC offset, you will need to convert SolydX from UTC to local time. To do that, when you're in SolydX, open a terminal and enter this command:

Code: Select all

sudo hwclock --localtime --hctosys
You'll then need to go to /etc and edit the adjtime file. I thought it would normally be rewritten when the hwclock command is used, but it didn't seem to in my case. Open the file with an editor (you'll need root access to write it), and change UTC to LOCAL.

Then make sure your hardware clock is set correctly (best done through the machine BIOS) and the problem should be solved.

Paul.

User avatar
jsalpha2
Posts: 296
Joined: 28 May 2013 12:28

Re: Another time question

Postby jsalpha2 » 05 Jun 2013 22:53

Thanks toothandnail, I had to google to figure out what UTC was and how to find the offset. The chart I found says I'm 5 hours off, but figuring daylight saving time should bring it back to 4. I tried running the command after reading your other post and kept getting hardware clock not found. I think I was forgetting the sudo or something. Now it seems to be fixed.
I did not do this step yet. "You'll then need to go to /etc and edit the adjtime file." But it seems to be fixed without that step.
I'm going to look in that file just out of curiosity anyway. Thanks again.


Return to “Newbie Questions”

Who is online

Users browsing this forum: Bing [Bot] and 26 guests