wicd applet

Questions specific to the Xfce DE go here
Posts: 42
Joined: 23 Feb 2013 16:20

wicd applet

Postby 17xeros » 16 Mar 2013 00:46

I get a D-bus error message when the desktop appears "Could not connect to wicd's D-Bus interface". Although the applet is not working I can connect to the internet. Quitting the applet and starting it again or logout and loging back makes the applet working fine.
I tired this

Code: Select all

dpkg-reconfigure wicd
update-rc.d wicd defaults
that I found in a few dscussions like: http://www.backtrack-linux.org/forums/s ... hp?t=31064
but it didn't work.
I removed the wicd applet from the startup and added just

Code: Select all

. It worked for a few days. Now it delays about a minute before it connects to the internet,
Is there a way to make the wicd applet work properly?
It's all geek to me
Zetor 25A. Zetor 2.1L 25hp, 12V 150Amp-hours, 4x2 2WD

User avatar
Posts: 52
Joined: 10 Aug 2013 05:40
Location: Spain

Re: wicd applet

Postby Tuna130 » 08 Jun 2017 17:00

Networkmanager and Wicd don't like each other. I had trouble with that, and wicd would not work untill I disabled all instances of networkmanager. It seems quite integrated in the OS, for example my bluetooth app tried to get networkmanager to restart. You may want to search and kill with 'htop'. Finally I gave up on wicd, because it would not work with hidden SSID's, nor with VPN connections also gave me trouble with the 5Gz wifi connection.

User avatar
Posts: 2222
Joined: 09 Oct 2013 12:45

Re: wicd applet

Postby ilu » 09 Jun 2017 15:10

I do not really understand why you tried to use wicd to connect to the internet since networkmanager is the tool of choice in SolydX. I don't think anybody here can help you with that.

User avatar
Posts: 492
Joined: 08 Jun 2014 08:17
Location: Bournemouth, UK

Re: wicd applet

Postby xendistar » 09 Jun 2017 20:58

I have used WIcd many years ago (not on SolydXK), first you had to complete remove Netowork Manager then install WiCD. At the time Wicd was far superior in handling Wifi connection. I have not had any issue with network manager (for Wifi connections) but then again I only tried it on an old laptop but it worked perfectly.

Return to “Xfce specific (SolydX)”

Who is online

Users browsing this forum: No registered users and 5 guests