Page 1 of 1

Update Manager not starting [SOLVED]

Posted: 22 Oct 2014 18:19
by t0psy
I have run updatemanager from the terminal and I get the folling error:-


** (updatemanager:4554): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Traceback (most recent call last):
File "/usr/bin/updatemanager", line 119, in <module>
showMsg(title, msg)
File "/usr/bin/updatemanager", line 98, in showMsg
dialog.set_icon_from_name("update-manager")
AttributeError: 'MessageDialog' object has no attribute 'set_icon_from_name'


I have followed a previous post but it did not resolve my problem.


I have tried:-
sudo apt-get update; sudo apt-get install updatemanager; updatemanager -u

apt policy updatemanager
updatemanager:
Installed: 2.4.3
Candidate: 2.4.3
Version table:
*** 2.4.3 0
500 http://ftp.nluug.nl/os/Linux/distr/soly ... roduction/ solydxk/main amd64 Packages
100 /var/lib/dpkg/stat

Any help much appreciated.
I appear however to be able to update via the terminal so do I need UM?

Re: Update Manager not starting

Posted: 23 Oct 2014 02:52
by kurotsugi
first thing first, please give us the result of 'inxi -Fxz'. it will help us to get a hint what happened in your system :3
I appear however to be able to update via the terminal so do I need UM?
it depends on you. if you're fine working with terminal (just like me) then you probably doesn't need UM. the UM was made to make the upgrade easier but I prefer do it via terminal since I'm more comfortable with it.

Re: Update Manager not starting

Posted: 23 Oct 2014 07:40
by t0psy
Thanks, nice to know it's not essential, Iv'e got quite used to my drop-down terminal (should be default it's so handy).
The results are:-

dave@dell:~$ inxi -Fxz
System: Host: dell Kernel: 3.14-2-amd64 x86_64 (64 bit gcc: 4.8.3) Desktop: N/A Distro: SolydXK 1 testing
Machine: System: Dell product: Latitude E6230 v: 01
Mobo: Dell model: 0R6V5Y v: A00 Bios: Dell v: A13 date: 06/20/2014
CPU: Dual core Intel Core i5-3320M (-HT-MCP-) cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10366
Clock Speeds: 1: 1202 MHz 2: 2472 MHz 3: 1199 MHz 4: 1199 MHz
Graphics: Card: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
Display Server: X.Org 1.16.1 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.22hz
GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 10.2.6 Direct Rendering: Yes
Audio: Card Intel 7 Series/C210 Series Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k3.14-2-amd64
Network: Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e v: 2.3.2-k port: f080 bus-ID: 00:19.0
IF: eth0 state: down mac: <filter>
Card-2: Broadcom BCM4313 802.11bgn Wireless Network Adapter driver: bcma-pci-bridge bus-ID: 02:00.0
IF: wlan0 state: up mac: <filter>
Drives: HDD Total Size: 250.1GB (17.4% used) ID-1: /dev/sda model: Samsung_SSD_840 size: 250.1GB
Partition: ID-1: / size: 18G used: 7.0G (42%) fs: ext4 dev: /dev/sda5
ID-2: /home size: 159G used: 30G (20%) fs: ext4 dev: /dev/sda6
ID-3: swap-1 size: 4.40GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
Sensors: System Temperatures: cpu: 25.5C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 196 Uptime: 3 min Memory: 591.3/3867.9MB Init: systemd runlevel: 5 Gcc sys: 4.9.1
Client: Shell (bash 4.3.251) inxi: 2.1.28
dave@dell:~$

Re: Update Manager not starting

Posted: 23 Oct 2014 17:35
by kurotsugi
it might not solve the update manager issue but it will be easier to analyze the problem if you upgrade your system into the latest UP.

Code: Select all

Kernel: 3.14-2-amd64 x86_64 
this part means that you're not on the latest UP.

Re: Update Manager not starting

Posted: 23 Oct 2014 17:49
by t0psy
Thanks I have put back the latest kernal 3.16 I used 3.14 as the latest give gfx errors on boot.
With this kernel UM still does not run and the result from "inxi -Fxz 'I get :-

dave@dell:~$ inxi -Fxz
System: Host: dell Kernel: 3.16-2-amd64 x86_64 (64 bit gcc: 4.8.3) Desktop: N/A Distro: SolydXK 1 testing
Machine: System: Dell product: Latitude E6230 v: 01
Mobo: Dell model: 0R6V5Y v: A00 Bios: Dell v: A13 date: 06/20/2014
CPU: Dual core Intel Core i5-3320M (-HT-MCP-) cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10365
Clock Speeds: 1: 2262 MHz 2: 1417 MHz 3: 2284 MHz 4: 1966 MHz
Graphics: Card: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
Display Server: X.Org 1.16.1 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.22hz
GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 10.2.6 Direct Rendering: Yes
Audio: Card Intel 7 Series/C210 Series Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k3.16-2-amd64
Network: Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e v: 2.3.2-k port: f080 bus-ID: 00:19.0
IF: eth0 state: down mac: <filter>
Card-2: Broadcom BCM4313 802.11bgn Wireless Network Adapter driver: bcma-pci-bridge bus-ID: 02:00.0
IF: wlan0 state: up mac: <filter>
Drives: HDD Total Size: 250.1GB (17.5% used) ID-1: /dev/sda model: Samsung_SSD_840 size: 250.1GB
Partition: ID-1: / size: 18G used: 7.2G (44%) fs: ext4 dev: /dev/sda5
ID-2: /home size: 159G used: 30G (20%) fs: ext4 dev: /dev/sda6
ID-3: swap-1 size: 4.40GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
Sensors: System Temperatures: cpu: 47.5C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 197 Uptime: 1 min Memory: 628.1/3867.5MB Init: systemd runlevel: 5 Gcc sys: 4.9.1
Client: Shell (bash 4.3.251) inxi: 2.1.28
dave@dell:~$

Re: Update Manager not starting

Posted: 20 Jan 2015 17:47
by t0psy
My updatemanager does still not run, however...

if I type "updatemanager --force" in a terminal it runs.

I did this from a prompt in the textfile /usr/bin/updatemanager that said updatemanager cannot run in a live environment.

Any ideas how I make this run without "--force"?

Re: Update Manager not starting

Posted: 20 Jan 2015 18:45
by MAYBL8
This might be the answer to your issue:
http://forums.solydxk.com/viewtopic.php ... ive#p40635

Re: Update Manager not starting

Posted: 21 Jan 2015 11:18
by t0psy
Brilliant!

I followed the thread, typed in the termial:-

apt purge ^live-

removed some files and it now runs.

Thanks very much, marking as solved.