Power-off icon goes to sleep and initial volume too high!

Questions specific to the Xfce DE go here
SteliosSk
Posts: 7
Joined: 13 Jun 2014 14:12

Power-off icon goes to sleep and initial volume too high!

Postby SteliosSk » 21 Jan 2017 14:11

In an old Fujitsu-Siemens laptop (Amilo 1451) I have installed solydx 32 bit. I have two major problems:
1. When I use the sound for the first time in a session (watch a video, or listen to a song), the volume is too high! the sound is too loud and distorted! And when I lower the volume, let's say to 50%, after a while it goes to 100% volume by itself! Is there a way to make it behave normally?
2. When I press the power-off icon of the whisker menu, the machine goes to sleep and the moon symbol starts flashing. When I press the (hard) power button it awakes and goes to login screen. I login and press the power-off icon at the top of the screen and goes to default xfce desktop. How can I make it to power-off the laptop when I press the power-off icon?

User avatar
ilu
Posts: 1640
Joined: 09 Oct 2013 12:45

Re: Power-off icon goes to sleep and initial volume too high!

Postby ilu » 21 Jan 2017 16:23

Please post the output of "inxi -Frxz" (that info never hurts).

ad 1. 50% and 100% refer to what the speaker widget shows?

ad 2. This seems to be a widespread issue with Amilo and some others, some possible solutions are collected here:
https://ubuntuforums.org/archive/index.php/t-2217602.html

SteliosSk
Posts: 7
Joined: 13 Jun 2014 14:12

Re: Power-off icon goes to sleep and initial volume too high!

Postby SteliosSk » 21 Jan 2017 19:14

ad 1a. At a new session the volume is too loud and distorted. Any idea, how to correct it?
ad 1b. The percentage is just to show that the sound goes from the adjusted volume to the full volume.
ad2. Adding "acpi=off" in the grub.cfg file worked for me, thank you . :clap: Now when I click on the power-off icon it powers off. :clap:

As far as the inxi concerns, here is the result:

System: Host: stelios-laptop Kernel: 3.16.0-4-586 i686 (32 bit gcc: 4.8.4)
Desktop: N/A Distro: SolydXK 8 solydxk
Machine: System: FUJITSU SIEMENS product: Amilo M1451G Series
Mobo: N/A model: M50EA0
Bios: American Megatrends v: 1.04C date: 09/30/2005
CPU: Single core Intel Pentium M (-UP-) cache: 2048 KB
flags: (pae sse sse2) bmips: 3733 clocked at 1862 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] RV370/M22 [Mobility Radeon X300]
bus-ID: 03:00.0
Display Server: X.Org 1.16.4 drivers: ati,radeon (unloaded: fbdev,vesa)
Resolution: 1280x800@60.00hz
GLX Renderer: Gallium 0.4 on ATI RV370
GLX Version: 2.1 Mesa 10.3.2 Direct Rendering: Yes
Audio: Card Intel 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k3.16.0-4-586
Network: Card-1: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
driver: 8139too v: 0.9.28 port: c800 bus-ID: 01:0c.0
IF: eth0 state: down mac: <filter>
Card-2: Intel PRO/Wireless 2200BG [Calexico2] Network Connection
driver: ipw2200 v: 1.2.2kmprq bus-ID: 01:03.0
IF: eth1 state: up mac: <filter>
Drives: HDD Total Size: 80.0GB (15.4% used)
ID-1: /dev/sda model: FUJITSU_MHT2080B size: 80.0GB
Partition: ID-1: / size: 15G used: 5.1G (37%) fs: ext4 dev: /dev/sda1
ID-2: /home size: 59G used: 6.5G (12%) fs: ext4 dev: /dev/sda2
Sensors: System Temperatures: cpu: 55.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Repos: Active apt sources in file: /etc/apt/sources.list
deb http://repository.solydxk.com solydxk main upstream import
deb http://ftp.debian.org/debian jessie main contrib non-free
deb http://security.debian.org jessie/updates main contrib non-free
deb http://ftp.debian.org/debian jessie-backports main contrib non-free
Info: Processes: 147 Uptime: 8 min Memory: 565.7/1516.0MB
Init: systemd runlevel: 5 Gcc sys: 4.9.2
Client: Shell (bash 4.3.301) inxi: 2.1.28

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: Power-off icon goes to sleep and initial volume too high!

Postby Zill » 21 Jan 2017 20:51

SteliosSk: I suggest you open a terminal and then enter the following command:

Code: Select all

alsamixer

Hit F6 and select your soundcard.

You can then use the cursor keys (not the mouse!) to change various channels and levels. I suggest you could try reducing the "PCM" level to see if this reduces the distortion you are experiencing. Experiment to find the best levels for the various channels, then hit the "Esc" key to exit alsamixer.

SteliosSk
Posts: 7
Joined: 13 Jun 2014 14:12

Re: Power-off icon goes to sleep and initial volume too high!

Postby SteliosSk » 24 Jan 2017 15:50

I used alsamixer and the initial volume of "Master" was 1218 !!!!
I then reduced it to 80 and tried to increased it. It went up to 100 and stopped !!!
So, as you can understand, the initial loud volume and consequently distortion is because of 1218 !!!
Any way, is there a way to adjust the initial volume so, it won'tbe more than 80 or 90, when I turn on the laptop?

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: Power-off icon goes to sleep and initial volume too high!

Postby Zill » 24 Jan 2017 17:10

Did you also use alsamixer to reduce the "PCM" level as I suggested?

SteliosSk
Posts: 7
Joined: 13 Jun 2014 14:12

Re: Power-off icon goes to sleep and initial volume too high!

Postby SteliosSk » 25 Jan 2017 14:15

Yes, I did, but at the next start the volume l was too loud and distorted, again.
Oh, btw, by now (after 2-3 days) the "acpi=off" parameter in grub.cfg , has been vanished and the power-off icon brings the laptop to sleep mode, again.

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: Power-off icon goes to sleep and initial volume too high!

Postby Zill » 25 Jan 2017 17:30

SteliosSk wrote:... now (after 2-3 days) the "acpi=off" parameter in grub.cfg , has been vanished and the power-off icon brings the laptop to sleep mode, again.

You should not edit /boot/grub/grub.cfg directly as any manual changes will be overwritten. The correct file to edit is /etc/default/grub and then run 'update-grub' afterwards to update /boot/grub/grub.cfg

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: Power-off icon goes to sleep and initial volume too high!

Postby Zill » 25 Jan 2017 17:44

SteliosSk wrote:Yes, I did, but at the next start the volume l was too loud and distorted, again.

I suggest you could try setting the levels with alsamixer then saving these settings with the following command:

Code: Select all

sudo alsactl store

The settings should then be saved in file /var/lib/alsa/asound.state


Return to “Xfce specific (SolydX)”

Who is online

Users browsing this forum: No registered users and 1 guest