Execute Script Within Thunar

Questions specific to the Xfce DE go here
User avatar
wildman
Posts: 228
Joined: 12 Feb 2014 23:31
Location: Kentucky, USA

Execute Script Within Thunar

Postby wildman » 25 Jul 2017 17:38

Starting with version 1.6.5, Thunar will no longer execute a script (with execute permission set) by double-clicking it. Instead the default action is to open the script in the default text editor. There is nothing in the right-click context menu or Thunar Preferences to change this behavior. This was done for security reasons but it can be very annoying for a Python or Perl programmer.

If you would like to revert to the previous default behavior, there is a fix. Open Settings Editor and select Thunar then click New. Enter the following and click Save...

Property: /misc-exec-shell-scripts-by-default
Type: Boolean
Value: True

Restart Thunar if it is running for the change to take effect.

For those interested Thunar has other "hidden" settings...
http://docs.xfce.org/xfce/thunar/hidden-settings
Attachments
settingseditor.png
settingseditor.png (49.31 KiB) Viewed 166 times
Wildman
May the Source be with you.

Return to “Xfce specific (SolydX)”

Who is online

Users browsing this forum: No registered users and 1 guest