Volume seems be muted forever

Questions specific to the Xfce DE go here
Posts: 3
Joined: 25 Mar 2017 19:32

Volume seems be muted forever

Postby Smojo » 23 Sep 2017 22:56


I used SolydX for a while now and most things work fine.

Some days ago I used my hardware (FN) keys to mute the sound.
I pressed the key several times and than I was not able to turn it on again. It stayed off.

When I reboot the system I see the striked through sound symbol in the task bar.
I can be "enable" the sound via FN-Key again, but this does not really turns on the sound again.
Even the symbol is not striked through anymore the system does not play any sound (tested videos and music).

I can leave the supposed enable sound as it is, reboot and the symbol is striked thought again when the system comes up.

Any idea what went wrong or how I can analyze this?

Thanks and regards.

User avatar
Posts: 2682
Joined: 09 Oct 2013 12:45

Re: Volume seems be muted forever

Postby ilu » 24 Sep 2017 02:05

That FN key seems to be another way to muck up Linux sound (besides having a headphone plugged in during install or not or plugging it in or off in the wrong moment or dual-booting MSWin or whatever else ...).

To get your sound back, play some music/youtube and open PulseAudio (pavucontrol). Check carefully for muted channels.

If it is installed open alsamixer in a terminal (if alsamixer is not installed ignore this). Make sure you see all the switches in alsamixer by hitting f5, choose the right card with f6 and cklick fullscreen to make sure you see all switches. Check all the channels in both programs. Unmutung something in alsa usually means it gets muted in pulse (which is hard to see) and vice versa.

I've had so many sound problems and muting and unmuting has always fixed it ... eventually. Another tactic is to wait it out, it might fix itself. It has worked, I swear!

Posts: 3
Joined: 25 Mar 2017 19:32

Re: Volume seems be muted forever

Postby Smojo » 26 Sep 2017 23:43

Thanks @ilu

This was easy. I just opened PulseAudio and at the third tab the sound was muted.
After that the sound worked again.

In the mean while I plugged in headphones and I was able to mute the sound there as well by using the FN key. :facepalm:

But now both is working again.
Thanks a lot.

Return to “Xfce specific (SolydX)”

Who is online

Users browsing this forum: No registered users and 2 guests