Page 1 of 1

(solved) All icons disappeared after updating very old system

Posted: 25 Jan 2019 21:31
by sega dude
I updated the packages on an older version of a SolydX install that had not been updated since 2015. They were updated via

Code: Select all

sudo apt-get update
and

Code: Select all

sudo apt-get upgrade

Upon reboot, all of the icons are missing. There are no icons in the whisker menu, on the xfce panel, in applications, in the file manager and more places. In some applications and on the desktop, it shows an icon that is a sheet of paper with a red x on it. Selecting different icons in Appearance in Settings has no effect. I tried some xfce specific fixes I found online, but nothing worked. I got the SolydX image from here, it is an image specifically designed for maemo development (it's called "SOLYDmaemo"). Any ideas on what went wrong and how I can fix it? Any help would be greatly appreciated.

Here is an screenshot of what it looks like.

It is installed in VirtualBox on a Windows 10 host if that helps.

Re: All icons disappeared after update

Posted: 26 Jan 2019 13:12
by Arjen Balfoort
Sorry, I don't know SolydMaemo. You probably should ask the maker of that ISO.

If your system hasn't been updated since 2015 you need quite some knowledge to upgrade your system to the current version. You should always run

Code: Select all

apt dist-upgrade
but most likely that won't be enough and you'll need to tweak the rest by hand. In these cases I recommend to do a clean install. Less time consuming and you can be sure it will be a stable system.

Re: All icons disappeared after update

Posted: 26 Jan 2019 17:10
by ilu
You should always download your SolydX ISOs from this site only. Tweak them afterwards towards whatever is your fancy. And update regularly.

Re: All icons disappeared after updating very old system

Posted: 27 Jan 2019 16:20
by sega dude
I took a snapshot of the VirtualBox VM before upgrading the packages in case something went wrong. I restored the snapshot and tried a dist-upgrade like Arjen said. This time the icons did not disappear. I haven't used the system much yet, but so far everything seems to be working properly.

Re: All icons disappeared after updating very old system

Posted: 27 Jan 2019 17:02
by ilu
Congrats on having a working backup. Honestly. You rule dude. :ugeek: