Failed to start Load Kernel Modules {resolved}

Questions specific to the KDE DE go here
JSladek
Posts: 132
Joined: 19 Jun 2014 23:15
Location: Suffolk VA

Failed to start Load Kernel Modules {resolved}

Postby JSladek » 05 Jun 2017 13:05

SolydK-64 - For probably a number of years, I have been seeing the subject message at the start of the boot process. There has never seemed to be a problem with use of any programs. It is simply that the message is .... annoying. But in the event that a future major problem can develop, I should get this issue resolved.

jim@jim ~ $ systemctl status systemd-modules-load
● systemd-modules-load.service - Load Kernel Modules
Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static)
Active: failed (Result: exit-code) since Mon 2017-06-05 14:29:39 UTC; 3min 5s ago
Docs: man:systemd-modules-load.service(8)
man:modules-load.d(5)
Process: 184 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
Main PID: 184 (code=exited, status=1/FAILURE)

jim@jim ~ $ sudo journalctl _PID=184
-- Logs begin at Mon 2017-06-05 14:29:39 UTC, end at Mon 2017-06-05 15:01:51 UTC
Jun 05 14:29:39 jim systemd-modules-load[184]: Inserted module 'lp'
Jun 05 14:29:39 jim systemd-modules-load[184]: Inserted module 'ppdev'
Jun 05 14:29:39 jim systemd-modules-load[184]: Inserted module 'parport_pc'
Jun 05 14:29:39 jim systemd-modules-load[184]: Inserted module 'fuse'
Jun 05 14:29:39 jim systemd-modules-load[184]: Inserted module 'loop'
Jun 05 14:29:39 jim systemd-modules-load[184]: Inserted module 'nf_nat_pptp'
Jun 05 14:29:39 jim systemd-modules-load[184]: Failed to find module 'etc'
Jun 05 14:29:39 jim systemd-modules-load[184]: Failed to find module 'xyz'

Now, I'm really starting to tread into the unknown ......

User avatar
ilu
Posts: 1633
Joined: 09 Oct 2013 12:45

Re: Failed to start Load Kernel Modules

Postby ilu » 05 Jun 2017 16:05

You've certainly done an internet search before asking, haven't you? ;-)

First thing I found is https://bbs.archlinux.org/viewtopic.php?pid=1612721#p1612721 - Arch is always good. Please follow their instructions from that post on and post the respective output. The problem is sometimes caused by virtualbox-guest-dkms - do you have VB guest additions installed?

You could also have a look whether "sudo journalctl -b -u systemd-modules-load.service" produces anything useful.

JSladek
Posts: 132
Joined: 19 Jun 2014 23:15
Location: Suffolk VA

Re: Failed to start Load Kernel Modules

Postby JSladek » 05 Jun 2017 16:50

ilu: Yes - I initially did an internet search to start me off. I am now following where the crumbs lead me. I do have virtualbox installed, but I have not seen any messages yet that indicate a problem in that area.

After my first posting, I removed "etc" and "xyz" from /etc/modules-load.d/netfilter.conf and that eliminated the initial boot error. BUT now I have a boot error "Failed to start /etc/rc.local Compatibility" and if I follow that trail, then:

jim@jim ~ $ systemctl status rc-local.service
● rc-local.service - /etc/rc.local Compatibility
Loaded: loaded (/lib/systemd/system/rc-local.service; static)
Active: failed (Result: exit-code) since Mon 2017-06-05 15:56:53 UTC; 6min ago
Process: 774 ExecStart=/etc/rc.local start (code=exited, status=32)

jim@jim ~ $ sudo journalctl _PID=774
-- Logs begin at Mon 2017-06-05 15:56:51 UTC, end at Mon 2017-06-05 16:04:15 UTC
Jun 05 15:56:53 jim rc.local[774]: mount: cgroup is already mounted or /dev/cgro
Jun 05 15:56:53 jim rc.local[774]: cgroup is already mounted on /sys/fs/cgroup/s
Jun 05 15:56:53 jim rc.local[774]: cgroup is already mounted on /sys/fs/cgroup/c
Jun 05 15:56:53 jim rc.local[774]: cgroup is already mounted on /sys/fs/cgroup/c
Jun 05 15:56:53 jim rc.local[774]: cgroup is already mounted on /sys/fs/cgroup/d
Jun 05 15:56:53 jim rc.local[774]: cgroup is already mounted on /sys/fs/cgroup/f
Jun 05 15:56:53 jim rc.local[774]: cgroup is already mounted on /sys/fs/cgroup/n
Jun 05 15:56:53 jim rc.local[774]: cgroup is already mounted on /sys/fs/cgroup/b
Jun 05 15:56:53 jim rc.local[774]: cgroup is already mounted on /sys/fs/cgroup/p

This doesn't look like anything that would harm the system, but it is still a "failed message" on bootup.

Referring to your note:

sudo journalctl -b -u systemd-modules-load.service shows the same results as I got on PID 184 except that the two failed modules are no longer listed because of their removal from /etc/modules-load.d/netfilter.conf

It now appears that I am well away from the direction that the ArchLinux reference was following and the subject of this initial query. So far, I don't appear to have broken anything.

User avatar
ilu
Posts: 1633
Joined: 09 Oct 2013 12:45

Re: Failed to start Load Kernel Modules

Postby ilu » 05 Jun 2017 20:39

Sorry, I'm out of my league here.
JSladek wrote:So far, I don't appear to have broken anything.

Let's hope for the best ... :ugeek:

kurotsugi
Posts: 1937
Joined: 09 Jan 2014 00:17

Re: Failed to start Load Kernel Modules {resolved}

Postby kurotsugi » 06 Jun 2017 02:14

I haven't investigate the issue but I think you'll be safe. rc.local was part sysvinit but there were lot of problem with it so no one seems using it in these days. some distro even remove that function while the other highly advised that user shouldn't use it. debian keep the function but it's not used by default. /etc/rc.local doesn't even exist anymore on debian realm.

Code: Select all

cat /etc/rc.local
cat: /etc/rc.local: No such file or directory


Return to “KDE specific (SolydK)”

Who is online

Users browsing this forum: No registered users and 1 guest