Sub-menu icons don't "stick" {fixed}

Questions specific to the KDE DE go here
JSladek
Posts: 132
Joined: 19 Jun 2014 23:15
Location: Suffolk VA

Sub-menu icons don't "stick" {fixed}

Postby JSladek » 22 Sep 2017 17:37

I am using the Application version of the Menu launcher in SolydK-9 and have my items in a tree structure through the use of sub-menus. My overall system theme is SolydK Dark, Desktop theme is Oxygen and Icon theme is Breeze Dark.

When I build my menu tree, I put icons at the sub-menu as well as the applications. I find that after I save and close down the editor, the sub-menu icons are all replaced by a "default" triad icon (three square dots in a triangular configuration) EXCEPT FOR the sub-menu icon for Settings which was originally a first level Menu title that I relocated to the position of a sub-menu under System.

I also tried to delete all of the sub-menu icons with the empty icon selection including the Settings icon, but after I went through the saving process, the "default" triad icons returned as did the icon for the sub-menu Settings.

Icons for any application under any of the sub-menus "stick".

Anybody have any ideas on what will make the "non-system" sub-menu icons "stick"?

JSladek
Posts: 132
Joined: 19 Jun 2014 23:15
Location: Suffolk VA

Re: Sub-menu icons don't "stick"

Postby JSladek » 09 Oct 2017 19:34

There may be an easier way, but I ended up going into /home/xxx/.local/share/desktop-directories and editing each of the directory files changing "Icon" from the default "package" to the name of the icon of choice for that directory. A tedious process to say the least, but it worked. Too bad it couldn't be done through the Menu Editor.


Return to “KDE specific (SolydK)”

Who is online

Users browsing this forum: No registered users and 1 guest