Plasma does not start anymore

Questions specific to the KDE DE go here
Posts: 16
Joined: 17 Nov 2017 08:43

Plasma does not start anymore

Postby fdpg1963 » 05 Dec 2017 12:44

Hello all,

So happy with my SolidK 9 until today. Yesterday I have shut my laptop in the regular way as always. Power down. Guess what, this morning Plasma does not start at all! After login the KDE logo appears for a while like usual and then the screen gets dark with only the mouse cursor which I can move. No recovery boot or whatever did help. Live version still runs fine strange enough.

Must say the same error happened with KDE Neon. Maybe my laptop and KDE are not a happy couple.

For now I switched to SolidX but it was not a good experience...

Regards, Folkert

User avatar
Arjen Balfoort
Site Admin
Posts: 8844
Joined: 26 Jan 2013 19:36
Location: Netherlands

Re: Plasma does not start anymore

Postby Arjen Balfoort » 05 Dec 2017 13:52

I had that once. I started in recovery mode and moved away my account directory, copied /etc/skel to /home/myaccount and changed ownership to my account:

Code: Select all

mv /home/myaccount /home/myaccount.bak
cp -r /etc/skel /home/
mv /home/skel /home/myaccount
chown -R myaccount:myaccount /home/myaccount
After that I copied only what I needed bit by bit from /home/myaccount.bak to /home/myaccount/

SolydXK needs you!
Development | Testing | Translations

Posts: 26
Joined: 12 Apr 2015 00:00

Re: Plasma does not start anymore

Postby docke » 06 Dec 2017 01:02

Also it happened to me yesterday.
I overcame this problem with Alt+Ctrl+Del and i've got a screen to Logout, then I Login again and the problem was solved.

Posts: 16
Joined: 17 Nov 2017 08:43

Re: Plasma does not start anymore

Postby fdpg1963 » 06 Dec 2017 06:36

This trick helped me with Neon KDE but not with SolydK. Tried everything including reboots, recovery mode but nothing helped.
I need a solid laptop for daily use so right now I'm running SolydX, Xfce is not my favorite DE but it runs fast and stable for now.

I'm still not 100% convinced about the stability of Plasma because I had trouble with it in 2 distro's. Xfce lacks options but is mature in terms of development.

Posts: 12
Joined: 21 Aug 2015 20:13

Re: Plasma does not start anymore

Postby freedom » 19 Jan 2018 17:52

I had similar problem after installation of SolydK 9
Not black screen and mouse pointer but wallpaper and panel loaded but that's it.
I've searched and it appears that there is a bug regarding default system tray and information popups.

Solution was to remove system tray from panel and then add it back.

Return to “KDE specific (SolydK)”

Who is online

Users browsing this forum: No registered users and 2 guests