Kde 4.10 keeps locking up and crashing

Questions specific to the KDE DE go here
arm1e
Posts: 19
Joined: 17 Aug 2013 22:23

Kde 4.10 keeps locking up and crashing

Postby arm1e » 18 Aug 2013 10:19

I have installed solydk having used other kde4 distros, but this one keeps randomly locking up and crashing the system. When I try to force logout (ctrl-alt-bkspace) the Screen goes blank and the system hangs endlessly.

This has worked on both the open source and Nvidia proprietary drivers. Does anyone else have this issue, or know of a fix?

Thanks

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: Kde 4.10 keeps locking up and crashing

Postby zerozero » 18 Aug 2013 10:42

arm1e

- is the system fully updated? what method you used? what's the output of

Code: Select all

inxi -r
- are you (re)using a previous home? if yes can you recreate the same issues with a new user?

- give us also the output of

Code: Select all

inxi -Fxx
so we know better the hardware we are dealing with
bliss of ignorance

skin27
Posts: 5
Joined: 28 Jun 2013 08:45

Re: Kde 4.10 keeps locking up and crashing

Postby skin27 » 29 Aug 2013 07:17

I have a similar experience on my Dell laptop. System hangs while browsing and updating the system. Before locking up CPU/RAM usage seems normal. After locking up I cannot do anything. Can take some minutes to get back to normal. Cannot pinpoint the problem yet, here are the output of the commands on my system:

inxi -r

/etc/apt/sources.list
deb http://packages.solydxk.nl/ solydxk main upstream import kdenext community
deb http://debian.solydxk.nl/production testing main contrib non-free
deb http://debian.solydxk.nl/production/multimedia testing main non-free
deb http://debian.solydxk.nl/security testing/updates main contrib non-free

inxi -Fxx

System: Host: solydk1 Kernel: 3.9-1-686-pae i686 (32 bit, gcc: 4.7.3)
Desktop: KDE 4.10.5 (Qt 4.8.5) dm: kdm Distro: SolydXK 1 solydxk
Machine: System: Dell product: Inspiron 2200 Chassis: type: 8
Mobo: Dell model: 0U6962 Bios: Dell version: A05 date: 06/21/2005
CPU: Single core Intel Celeron M (-UP-) cache: 1024 KB flags: (nx pae sse sse2) bmips: 2792.88 clocked at 1396.440 MHz
Graphics: Card: Intel Mobile 915GM/GMS/910GML Express Graphics Controller bus-ID: 00:02.0 chip-ID: 8086:2592
X.Org: 1.12.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1024x768@60.0hz
GLX Renderer: Mesa DRI Intel 915GM x86/MMX/SSE2 GLX Version: 1.4 Mesa 9.1.4 Direct Rendering: Yes
Audio: Card: Intel 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller
driver: snd_intel8x0 ports: ed00 ec40 bus-ID: 00:1e.2 chip-ID: 8086:266e
Sound: Advanced Linux Sound Architecture ver: k3.9-1-686-pae
Network: Card-1: Intel 82562ET/EZ/GT/GZ - PRO/100 VE (LOM) Ethernet Controller Mobile
driver: e100 ver: 3.5.24-k2-NAPI port: df40 bus-ID: 02:08.0 chip-ID: 8086:1068
IF: eth1 state: down mac: 00:14:22:c2:63:2b
Card-2: Broadcom BCM4318 [AirForce 54g] 802.11a/b/g PCI Express Transceiver
driver: b43-pci-bridge bus-ID: 02:03.0 chip-ID: 14e4:4319
IF: wlan0 state: up mac: 00:14:a5:45:d7:33
Drives: HDD Total Size: 40.0GB (-)
1: id: /dev/sda model: WDC_WD400VE size: 40.0GB serial: WD-WXE905389189
Partition: ID: / size: 34G used: 6.0G (19%) fs: ext4
Sensors: System Temperatures: cpu: 60.5C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 130 Uptime: 1:00 Memory: 377.7/747.4MB Runlevel: 2 Gcc sys: 4.7.3 alt: 4.4/4.6
Client: Shell (bash 4.2.45 running in konsole) inxi: 1.9.12

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: Kde 4.10 keeps locking up and crashing

Postby zerozero » 29 Aug 2013 10:07

skin27
i see 2 things here that might not be related with those lock-ups but we never know
1- this system has 747.4MB ram and is using in that output half of it with 1 minute of uptime (i assume that without app opened yet)
2- i don't see a swap partition anywhere.

depending on the usage you can easily go out of memory and lock up&crash; actually with around 400MB free all you need is open FF and a few tabs
bliss of ignorance

skin27
Posts: 5
Joined: 28 Jun 2013 08:45

Re: Kde 4.10 keeps locking up and crashing

Postby skin27 » 29 Aug 2013 12:33

Thanks, I will try to enlarge the swap space and see if this helps

RichLobo
Posts: 35
Joined: 01 Sep 2013 22:02

Re: Kde 4.10 keeps locking up and crashing

Postby RichLobo » 01 Sep 2013 22:19

arm1e wrote:I have installed solydk having used other kde4 distros, but this one keeps randomly locking up and crashing the system. When I try to force logout (ctrl-alt-bkspace) the Screen goes blank and the system hangs endlessly.

This has worked on both the open source and Nvidia proprietary drivers. Does anyone else have this issue, or know of a fix?

Thanks
This appears to be a consistent problem, it is happening to me as well at about once per day. The screen locks up, keyboard and mouse also lockup except that the courser continues to move as directed. Neither right or left click work nor any of the keyboard commands that I have tried. Once it locks up I power down and reboot, everything then works OK.

I have 6GB of memory and a 4+GB swap partition. Any clues?

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: Kde 4.10 keeps locking up and crashing

Postby zerozero » 01 Sep 2013 22:48

RichLobo
welcome to the forums and sorry to hear that you are issues with SolydXK

please post the output of

Code: Select all

inxi -Fxx
(this will give us an idea of the hardware we are facing)
bliss of ignorance

RichLobo
Posts: 35
Joined: 01 Sep 2013 22:02

Re: Kde 4.10 keeps locking up and crashing

Postby RichLobo » 02 Sep 2013 00:16

Thank you for your reply, I've been using Linux distros for many years now. I am not a newbie but I am also not a programmer. I'm thankful for any help you can give me.

Code: Select all

$ inxi -Fxx
System:    Host: timothy-sx2803 Kernel: 3.9-1-amd64 x86_64 (64 bit, gcc: 4.7.3) 
           Desktop: KDE 4.10.5 (Qt 4.8.5) dm: kdm Distro: solydk64 1 solydxk
Machine:   System: Gateway product: SX2803 version: P01-B2 Chassis: type: 3
           Mobo: Gateway model: SX2803 Bios: AMI version: P01-B2 date: 03/24/2010
CPU:       Dual core Pentium CPU E6700 (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 ssse3 vmx) bmips: 12769.4 
           Clock Speeds: 1: 1603.00 MHz 2: 1603.00 MHz
Graphics:  Card: Intel 4 Series Integrated Graphics Controller bus-ID: 00:02.0 chip-ID: 8086:2e22 
           X.Org: 1.12.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1600x900@60.0hz 
           GLX Renderer: Mesa DRI Intel G45/G43 GLX Version: 2.1 Mesa 9.1.4 Direct Rendering: Yes
Audio:     Card: Intel 82801JI (ICH10 Family) HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:3a3e 
           Sound: Advanced Linux Sound Architecture ver: k3.9-1-amd64
Network:   Card-1: Ralink RT3090 Wireless 802.11n 1T/1R PCIe driver: rt2800pci ver: 2.3.0 bus-ID: 02:00.0 chip-ID: 1814:3090
           IF: wlan0 state: down mac: 74:de:2b:3e:cf:3e
           Card-2: Intel 82567V-2 Gigabit Network Connection 
           driver: e1000e ver: 2.2.14-k port: d880 bus-ID: 00:19.0 chip-ID: 8086:10ce
           IF: eth1 state: up speed: 100 Mbps duplex: full mac: f8:0f:41:1d:08:29
Drives:    HDD Total Size: 1016.2GB (0.5% used)
           1: id: /dev/sda model: WDC_WD10EADX size: 1000.2GB serial: WD-WCAV5U509555 
           2: USB id: /dev/sdb model: Cruzer_Facet size: 16.0GB serial: 4C532000030706102425-0:0 
Partition: ID: / size: 9.8G used: 5.4G (58%) fs: ext4 ID: /boot size: 477M used: 28M (7%) fs: ext4 
           ID: /home size: 536G used: 5.0G (1%) fs: ext4 ID: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap 
Sensors:   System Temperatures: cpu: 42.0C mobo: N/A 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 175 Uptime: 48 min Memory: 1486.8/3933.3MB Runlevel: 2 Gcc sys: 4.7.3 alt: 4.4/4.6 
           Client: Shell (bash 4.2.45 running in konsole) inxi: 1.9.12

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: Kde 4.10 keeps locking up and crashing

Postby zerozero » 03 Sep 2013 00:15

RichLobo
[sorry for the delay :P ]
i can't find anything obviously wrong in that output; ok, that graphics card is not state-of-the-art but should run kde just fine;
if you disable the most intensive desktop effects (wobbly windows, blur) and switch to xrender do you still suffer the same problems?

===
another route of action:
do you have any special setup (that wasn't there in the default installation?)
- for example i saw several reports that icon-tasks causes several problems (freezing and locking)
or
- can you connect the lockings to any particular task and/or app?
bliss of ignorance

RichLobo
Posts: 35
Joined: 01 Sep 2013 22:02

Re: Kde 4.10 keeps locking up and crashing

Postby RichLobo » 03 Sep 2013 03:20

ZeroZero,
Thank you again for your reply, don't worry about the time. There is a little difference between London time and California time. :D

Your conclusions are similar to mine. I'm retired so I am not sinking a lot of money into computers or other gadgets. It works OK, not spectacular but OK.

I first suspected my cable connection since I have had periodic problems there. Even today I had trouble keeping a signal and had to reboot my cable modem... Time Warner Cable is notorious in this area. But the symptoms were not exactly connection like symptoms, nothing responded when I clicked on it, not even on the panel. It was funny that the mouse courser keep moving [I've had lockups where everything stopped] but right/left and center clicks did nothing, even the wheel was dead. The keyboard was also dead.

On each occasion I had a browser open, actually two - Firefox and Google Chrome. My wife uses chrome and I use FF - she is really a newbie to computers and it is too confusing for her to share a browser with me. It has not happened again but I will be sure to make a note of what was going on at the time it happens again.

There is nothing unusual in my installation. Dual boot with Windows 7 Home Premium. I have only added Google Chrome and Personal Finance Manager. I made a few theme adjustments but nothing wild. I only reported it when I saw that someone else had reported a similar occurrence - perhaps there is a common thread. It has not been to critical for me to just power down and reboot.


Return to “KDE specific (SolydK)”

Who is online

Users browsing this forum: No registered users and 2 guests