Page 1 of 1

Help with sudo/kdesudo

Posted: 23 Dec 2013 01:12
by whatsvictory
This I think could be an issue with kdesudo but not entirely sure. I installed SolydK for some family and the household needs 2 (husband & wife) sudo accounts. They are new to Linux and I'd like everything to be smooth for them. The issue for me right now is that I have tried to add both sudo-to-be users to the sudo group and am getting the root password prompt any time I try to do anything outside the terminal that requires elevated privileges like use the Software Manager. I have tried disabling root "root -l" and using visudo to change the sudoers file trying both "user ALL=(ALL:ALL) ALL" & "user ALL=(ALL) ALL" with no luck. Right now I have root reenabled but can work just fine with sudo in the terminal and kdesudo works fine as wll from alt-f2 just nothing from an icon. Any ideas?

Re: Help with sudo/kdesudo

Posted: 23 Dec 2013 10:22
by smackthepony
Take a look here http://www.penguintutor.com/linux/file- ... -reference
From what i understand from it both users have to be in the same group and the group has to be given administrative rights.
Anyway there are more knowledgable folks here that should be able to get this solved.

Re: Help with sudo/kdesudo

Posted: 17 Mar 2014 19:52
by graphius
I may have a similar problem. I can use sudo from the command line, but when trying to open root privilege programs (such as software installation) from the KDE menu, I am asked for a password, but the password is not recognized.
ie sudo from the command line works, but kdesudo seems to have a different password.

EDIT -- Fixed. It seems that the software installation link on the "favourites" page of the menu was borked. I removed it and then readded it from the system menu and now it works.