about Upgrade-system

Questions specific to the KDE DE go here
User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

[Q] about Upgrade-system

Postby MAYBL8 » 09 Apr 2013 19:05

Why when I do upgrade-system do I get this:
I'm not saying yes.
By the way I am running on SolydK SID

Code: Select all

danc@danc-e535 ~/Downloads/muon/libqapt-1.9.97 $ sudo upgrade-system
1) Updating package lists:
I: Package lists updated.
2) Checking for upgradable packages:
I: No upgradable package to install.
3) Checking for orphan packages:
I: Purging orphan packages...
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  apturl-common* bogofilter* evolution-data-server-common* fuse-utils* gir1.2-atk-1.0* gir1.2-freedesktop* gir1.2-gdkpixbuf-2.0*
  gir1.2-pango-1.0* google-gadgets-common* grub* gs* gs-common* hplip-data* kdebase-workspace-dev* lib32nss-mdns* libatk1.0-dev*
  libatkmm-1.6-dev* libblas3gf* libboo2.0.9-cil* libboost-python1.48.0* libcairo-script-interpreter2* libcairo2-dev* libcairomm-1.0-dev*
  libcmis-0.2-0* libdbus1.0-cil* libdebconf-kde-dev* libdebconf-kde0* libdecoration0* libept-dev* libertas-firmware* libexpat1-dev*
  libfontconfig1-dev* libfreetype6-dev* libgadu3* libgdata1.7-cil* libgdata1.9-cil* libgdk-pixbuf2.0-dev* libglib2.0-bin* libglib2.0-dev*
  libglibmm-2.4-dev* libgnome2-perl* libgtk2.0-dev* libgtkmm-2.4-dev* libice-dev* libjs-jquery-ui* libkdecorations4* libkopete4*
  libkwineffects1abi3* libkwinglutils1* liblapack3gf* liblouis-data* liblucene2-java* libmediastreamer1* libminiupnpc5*
  libmono-addins0.2-cil* libmono-cairo2.0-cil* libmono-cairo4.0-cil* libmono-sharpzip2.84-cil* libmono-simd2.0-cil*
  libmono-sqlite2.0-cil* libmono-sqlite4.0-cil* libmono-system-messaging2.0-cil* libmono-system-web-applicationservices4.0-cil*
  libmono-zeroconf1.0-cil* libmsn0.3* libnatpmp1* libndesk-dbus1.0-cil* libotr2* libpango1.0-common* libpango1.0-dev* libpangomm-1.4-dev*
  libpcre3-dev* libpcrecpp0* libpixman-1-dev* libpng12-dev* libpolkit-qt-1-dev* libqjson-dev* libqoauth-dev* libqtgstreamer-dev*
  libsigc++-2.0-dev* libsm-dev* libssl-dev* libssl-doc* libtaglib2.0-cil* libtextcat-data* libx264-129* libxcb-render0-dev*
  libxcb-shm0-dev* libxcomposite-dev* libxcursor-dev* libxdamage-dev* libxfixes-dev* libxft-dev* libxi-dev* libxinerama-dev*
  libxrandr-dev* libxrender-dev* python-beautifulsoup* python-brlapi* python-decorator* python-egenix-mxdatetime* python-feedparser*
  python-gdata* python-geoip* python-gnome2* python-httplib2* python-libtorrent* python-mako* python-nevow* python-notify* python-oauth*
  python-opencv* python-paramiko* python-parted* python-pexpect* python-pygame* python-rdflib* python-simplejson* python-smbc*
  x11proto-composite-dev* x11proto-damage-dev* x11proto-fixes-dev* x11proto-randr-dev* x11proto-render-dev* x11proto-xinerama-dev*
  xsane-common*
0 upgraded, 0 newly installed, 126 to remove and 0 not upgraded.
After this operation, 162 MB disk space will be freed.
Do you want to continue [Y/n]? 


User avatar
Arjen Balfoort
Site Admin
Posts: 9361
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

[Q] about Upgrade-system

Postby Arjen Balfoort » 09 Apr 2013 19:25

Do you get the same list if you type:

Code: Select all

deborphan


SolydXK needs you!
Development | Testing | Translations

User avatar
GeneC
Posts: 747
Joined: 12 Feb 2013 17:49
Location: Woods of Maine

[Q] about Upgrade-system

Postby GeneC » 09 Apr 2013 19:27

Dan

Is this the first time you run upgrade-system? It looks like it. Yes, it will remove very much stuff from your system (In addition to doing DU), it also runs a powerful version of deb-orphan.

This really doesn't belong on this thread I would say.. ;) It has nothing to do with the update pack, plus your tracking SID..

Just for reference I did run sudo upgrade-system on my system (soldyx-tracking sid) last month.

My results.. I said YES to everything. all runs fine.
Your removals look a bit more severe, but your running KDE.

Code: Select all

gene@solydx64:~$ sudo upgrade-system
[sudo] password for gene: 
1) Updating package lists:
I: Package lists updated.
2) Checking for upgradable packages:
I: No upgradable package to install.
3) Checking for orphan packages:
I: Purging orphan packages...
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  dnet-common* fuse-utils* grub* lib32nss-mdns* libertas-firmware* linux-headers-3.2.0-4-common* python-central*
  python-geoip* python-opencv* python-parted* python-qt4* python-reportbug*
0 upgraded, 0 newly installed, 12 to remove and 0 not upgraded.
After this operation, 48.7 MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 154719 files and directories currently installed.)
Removing dnet-common ...
Purging configuration files for dnet-common ...
Removing fuse-utils ...
Removing grub ...
Purging configuration files for grub ...
Removing lib32nss-mdns ...
Purging configuration files for lib32nss-mdns ...
Removing libertas-firmware ...
Removing linux-headers-3.2.0-4-common ...
Removing python-central ...
Purging configuration files for python-central ...
Removing python-geoip ...
Removing python-opencv ...
Removing python-parted ...
Removing python-qt4 ...
Removing python-reportbug ...
Processing triggers for man-db ...
Processing triggers for python-support ...
I: Purging orphan packages...
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  libc6-i386* libopencv-legacy2.3* libopencv-ml2.3* libopencv-objdetect2.3* libqt4-dbus* libqt4-declarative*
  libqt4-designer* libqt4-help* libqt4-scripttools* libqt4-svg* libqt4-test* libqtassistantclient4* libqtwebkit4*
  python-debianbts* python-sip*
0 upgraded, 0 newly installed, 15 to remove and 0 not upgraded.
After this operation, 54.3 MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 151252 files and directories currently installed.)
Removing libc6-i386 ...
Purging configuration files for libc6-i386 ...
dpkg: warning: while removing libc6-i386, directory '/usr/lib32' not empty so not removed
Removing libopencv-legacy2.3 ...
Purging configuration files for libopencv-legacy2.3 ...
Removing libopencv-ml2.3 ...
Purging configuration files for libopencv-ml2.3 ...
Removing libopencv-objdetect2.3 ...
Purging configuration files for libopencv-objdetect2.3 ...
Removing libqt4-dbus:amd64 ...
Removing libqt4-declarative:amd64 ...
Purging configuration files for libqt4-declarative:amd64 ...
Removing libqt4-designer:amd64 ...
Purging configuration files for libqt4-designer:amd64 ...
Removing libqt4-help:amd64 ...
Purging configuration files for libqt4-help:amd64 ...
Removing libqt4-scripttools:amd64 ...
Purging configuration files for libqt4-scripttools:amd64 ...
Removing libqt4-svg:amd64 ...
Purging configuration files for libqt4-svg:amd64 ...
Removing libqt4-test:amd64 ...
Purging configuration files for libqt4-test:amd64 ...
Removing libqtassistantclient4:amd64 ...
Purging configuration files for libqtassistantclient4:amd64 ...
Removing libqtwebkit4:amd64 ...
Purging configuration files for libqtwebkit4:amd64 ...
Removing python-debianbts ...
Removing python-sip ...
Processing triggers for python-support ...
I: Purging orphan packages...
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  libopencv-calib3d2.3* libopencv-video2.3* libqt4-script* libqt4-xmlpatterns* python-soappy*
0 upgraded, 0 newly installed, 5 to remove and 0 not upgraded.
After this operation, 9,051 kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 150815 files and directories currently installed.)
Removing libopencv-calib3d2.3 ...
Purging configuration files for libopencv-calib3d2.3 ...
Removing libopencv-video2.3 ...
Purging configuration files for libopencv-video2.3 ...
Removing libqt4-script:amd64 ...
Purging configuration files for libqt4-script:amd64 ...
Removing libqt4-xmlpatterns:amd64 ...
Purging configuration files for libqt4-xmlpatterns:amd64 ...
Removing python-soappy ...
Processing triggers for python-support ...
I: Purging orphan packages...
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  libopencv-features2d2.3* libqt4-network* python-fpconst*
0 upgraded, 0 newly installed, 3 to remove and 0 not upgraded.
After this operation, 3,049 kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 150740 files and directories currently installed.)
Removing libopencv-features2d2.3 ...
Purging configuration files for libopencv-features2d2.3 ...
Removing libqt4-network:amd64 ...
Purging configuration files for libqt4-network:amd64 ...
Removing python-fpconst ...
Processing triggers for python-support ...
I: Purging orphan packages...
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  libopencv-flann2.3* libopencv-highgui2.3*
0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
After this operation, 840 kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 150713 files and directories currently installed.)
Removing libopencv-flann2.3 ...
Purging configuration files for libopencv-flann2.3 ...
Removing libopencv-highgui2.3 ...
Purging configuration files for libopencv-highgui2.3 ...
I: Purging orphan packages...
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  libopencv-imgproc2.3*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 1,777 kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 150701 files and directories currently installed.)
Removing libopencv-imgproc2.3 ...
Purging configuration files for libopencv-imgproc2.3 ...
I: Purging orphan packages...
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  libopencv-core2.3* libtbb2*
0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
After this operation, 2,195 kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 150695 files and directories currently installed.)
Removing libopencv-core2.3 ...
Purging configuration files for libopencv-core2.3 ...
Removing libtbb2 ...
Purging configuration files for libtbb2 ...
I: No orphan package to purge.
4) Cleaning package cache.
I: System upgrade completed.
gene@solydx64:~$ 

Man page

Code: Select all

UPGRADE-SYSTEM(8)                                  Debian GNU/Linux                                 UPGRADE-SYSTEM(8)

NAME
       upgrade-system - Command for upgrading and sanitizing a Debian system

SYNOPSIS
       upgrade-system

DESCRIPTION
       upgrade-system  is  an  APT  front-end  that simplifies regular upgrading of Debian systems, only requiring an
       administrator's intervention whenever updated packages necessitate the configuration of new features.

       The command sequentially performs the following operations:

       ·  Synchronize the list of available Debian packages.

       ·  Upgrade all installed packages to their newest versions.

       ·  Recursively uninstall all obsolete package dependencies.

       ·  Clean retrieved archives off the APT cache.

ENVIRONMENT
       Setting  the  FLAUSCH  environment  variable  enables  useful  advanced  system  sanitization  features.   See
       upgrade-system.conf(5) for more details.

FILES
       /etc/upgrade-system.conf

 Manual page upgrade-system(8) line 1 (press h for help or q to quit)
http://manpages.ubuntu.com/manpages/pre ... tem.8.html
GeneC

Debian (Testing)
Siduction (Debian SID)

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

[Q] about Upgrade-system

Postby MAYBL8 » 09 Apr 2013 20:34

danc@danc-e535 ~/Downloads/muon/libqapt-1.9.97 $ deborphan
libotr2:amd64
libkwineffects1abi3:amd64
liblapack3gf:all
libgadu3:amd64
kdebase-workspace-dev:all
libmsn0.3:amd64
libx264-129:amd64
libkdecorations4:amd64
libcmis-0.2-0:amd64
libmediastreamer1:amd64
libkopete4:amd64
libblas3gf:all
libkwinglutils1:amd64


User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

[Q] about Upgrade-system

Postby MAYBL8 » 09 Apr 2013 20:38

I don't need to run it. Was just playing around to see what damage I could cause.
I like living on the edge.
I don't want to completely have to reinstall everything.

I'll do some further testing if you want me to but I can leave this one alone.
Maybe I will back up first.
Thanks


User avatar
Arjen Balfoort
Site Admin
Posts: 9361
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

about Upgrade-system

Postby Arjen Balfoort » 10 Apr 2013 06:43

about Upgrade-system - moved from "UP 2013.04.06 12:00 UTC".


SolydXK needs you!
Development | Testing | Translations


Return to “KDE specific (SolydK)”

Who is online

Users browsing this forum: No registered users and 4 guests