[SOLVED] Kickoff menu and annoying Firefox bookmarks

Questions specific to the KDE DE go here
User avatar
palimmo
Posts: 735
Joined: 19 Nov 2013 19:44
Contact:

[SOLVED] Kickoff menu and annoying Firefox bookmarks

Postby palimmo » 18 Jul 2014 19:16

Whatever I type into the kickoff menu searchbox, I start seeing my Firefox bookmarks.
How can I disable this feature?

thanks!
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: Kickoff menu and annoying Firefox bookmarks

Postby zerozero » 19 Jul 2014 00:53

:lol: it can a bit annoying, yes.
try to disable baloo (desktop search)
bliss of ignorance

User avatar
palimmo
Posts: 735
Joined: 19 Nov 2013 19:44
Contact:

Re: Kickoff menu and annoying Firefox bookmarks

Postby palimmo » 19 Jul 2014 08:05

zerozero wrote::lol: it can a bit annoying, yes.
try to disable baloo (desktop search)

Thanks zero zero.
Would disabling baloo remove only this feature? What else?
How can I disable baloo?


P.S. In system monitor there is no "baloo" process running...
And no "desktop search" in system settings.

P.S. Another curious thing...
I can see in kickoff the two entries "nepomuk backup" and "nepomuk cleaner"... but both of them doesn't work
(KDEInit could not launch 'nepomukbackup': Could not find 'nepomukbackup' executable)
:? Is it related?



thanks!
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/

User avatar
palimmo
Posts: 735
Joined: 19 Nov 2013 19:44
Contact:

Re: Kickoff menu and annoying Firefox bookmarks

Postby palimmo » 20 Jul 2014 08:21

ideas?
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: Kickoff menu and annoying Firefox bookmarks

Postby zerozero » 20 Jul 2014 15:27

it's strange :roll:
don't you have a desktop search entry in systemsettings?
snapshot284.png

and also what is the output of

Code: Select all

aptitude search baloo

for reference, in my system

Code: Select all

zerozero@home ~ $ aptitude search baloo
i   baloo                                                      - framework for searching and managing metadata.                     
i   libbaloocore4                                              - Core funcationality for Baloo                                       
i   libbaloofiles4                                             - Files funcationality for Baloo                                     
i   libbaloopim4                                               - PIM funcationality for Baloo                                       
i   libbaloowidgets4                                           - Widgets for Baloo                                                   
i   libbalooxapian4                                            - Xapian funcationality for Baloo                       
bliss of ignorance

User avatar
palimmo
Posts: 735
Joined: 19 Nov 2013 19:44
Contact:

Re: Kickoff menu and annoying Firefox bookmarks

Postby palimmo » 20 Jul 2014 15:42

Code: Select all

alessio@alessio-laptop ~ $     aptitude search baloo
alessio@alessio-laptop ~ $   

:shock:

And no "Desktop Search" in System Settings.

c3.png

I wonder if something wrong happened during the UP.... In fact it has not been smooth...
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: Kickoff menu and annoying Firefox bookmarks

Postby zerozero » 20 Jul 2014 16:16

no, sorry, i should have looked closer

Code: Select all

zerozero@home ~ $ apt policy baloo
baloo:
  Installed: 4:4.13.1-1
  Candidate: 4:4.13.1-1
  Version table:
 *** 4:4.13.1-1 0
        100 /var/lib/dpkg/status

baloo is not part of the repos; it was at some point (viewtopic.php?f=33&t=4170#p38649) but was removed because it was a package only available in experimental and potentially not ready to deploy into production; however i kept it in my system (together with others) and have now additional problems because of that (mainly the fact that i can't completely remove kdenext from this system :shock: )

i need to search for another solution for your problem :cry:
bliss of ignorance

User avatar
just
Posts: 296
Joined: 07 Nov 2013 08:06
Location: Rovaniemi, Finland

Re: Kickoff menu and annoying Firefox bookmarks

Postby just » 20 Jul 2014 17:09

palimmo wrote:
Whatever I type into the kickoff menu searchbox, I start seeing my Firefox bookmarks.
How can I disable this feature?

  1. i'm not aware of any gui for it. seems like disabling bookmarks plugin in krunner has no effect. so:

    Code: Select all

    kdesu kate /usr/share/kde4/services/plasma-runner-bookmarks.desktop
  2. search for:

    Code: Select all

    X-KDE-PluginInfo-EnabledByDefault=true
  3. change to:

    Code: Select all

    X-KDE-PluginInfo-EnabledByDefault=false
  4. log out and back in
  5. done
don't remenber if the mod persists on kde upgrades. either re-apply it or use another launcher, like lancelot.

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: Kickoff menu and annoying Firefox bookmarks

Postby zerozero » 20 Jul 2014 17:38

i thought that those search results were connected with nepomuk/baloo :shock:
a new day, something new i learned
bliss of ignorance

User avatar
palimmo
Posts: 735
Joined: 19 Nov 2013 19:44
Contact:

Re: Kickoff menu and annoying Firefox bookmarks

Postby palimmo » 20 Jul 2014 20:58

just wrote:palimmo wrote:
Whatever I type into the kickoff menu searchbox, I start seeing my Firefox bookmarks.
How can I disable this feature?

  1. i'm not aware of any gui for it. seems like disabling bookmarks plugin in krunner has no effect. so:

    Code: Select all

    kdesu kate /usr/share/kde4/services/plasma-runner-bookmarks.desktop
  2. search for:

    Code: Select all

    X-KDE-PluginInfo-EnabledByDefault=true
  3. change to:

    Code: Select all

    X-KDE-PluginInfo-EnabledByDefault=false
  4. log out and back in
  5. done
don't remenber if the mod persists on kde upgrades. either re-apply it or use another launcher, like lancelot.


Excellent!!!!
Thanks a lot!!
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/

User avatar
palimmo
Posts: 735
Joined: 19 Nov 2013 19:44
Contact:

Re: [SOLVED] Kickoff menu and annoying Firefox bookmarks

Postby palimmo » 21 Oct 2014 20:07

New UP and I had to reapply it.
Thanks!
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/

User avatar
palimmo
Posts: 735
Joined: 19 Nov 2013 19:44
Contact:

Re: [SOLVED] Kickoff menu and annoying Firefox bookmarks

Postby palimmo » 10 Jan 2015 14:02

Upgrade to Jessie: this trick always works ;)
Proud user of SolydK!

Dai diamanti non nasce niente, dal letame nascono i fior. http://aquilone.wordpress.com/


Return to “KDE specific (SolydK)”

Who is online

Users browsing this forum: No registered users and 1 guest