Strange behavior of dolphin find search

Questions specific to the KDE DE go here
User avatar
ath_pg
Posts: 21
Joined: 01 Sep 2013 09:34

Strange behavior of dolphin find search

Postby ath_pg » 18 Oct 2014 04:25

Hi guys,
I've update to 10.15 UP, and I found a weird behavior when I tried to find a file in my home folder.
Symptom, the find function works fine when I search in portable disk folder, as shown below
search-ok.png
however, when I use the same dolphin and browse my home folder, for example, Picture folder, the find function does not work and says "Invalid protocol", as shown below
search-error.png
I tried google it, one solution is install kde-baseapp, which I already installed.
I have no baloo, baloo4, baloo-utils installed.
Please help.

Update solution: The baloo is partially installed by default. To get both search function in dolphin and popup tooltip work, you need to install baloo (baloo-utils baloo4 will be auto installed). If you don't like file indexing, edit ~/.kde/share/config/baloofilerc and add below code at the beginning.

Code: Select all

[Basic Settings]
Indexing-Enabled=false

User avatar
Orbmiser
Posts: 829
Joined: 24 Aug 2013 22:58
Location: Portland,Oregon

Re: Strange behavior of dolphin find search

Postby Orbmiser » 18 Oct 2014 04:49

Have Full KDE install and getting same results.
dolphin search error.jpeg
dolphin search error.jpeg (17.45 KiB) Viewed 2936 times
Also on hover over jpeg a Thumbnail popups up with size,dimensions,etc.. but now no info on dimensions of image to mouse over popup. Popup Works for Home but not on my Ntfs usb drives where busy icon spins and spins never generating a thumbnail popup.

.
Portfolio
http://500px.com/Orbmiser
Flickr
http://www.flickr.com/photos/orb9220/

SolydK - Kernel 3.16-2-amd64 - KDE 4.14.1 Update Pack: 2014.10.15

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Strange behavior of dolphin find search

Postby MAYBL8 » 18 Oct 2014 05:33

I think this has something to do with baloo.
I installed it and the invalid protocol goes away but the search doesn't find anything.
More research needs to be done.


User avatar
ath_pg
Posts: 21
Joined: 01 Sep 2013 09:34

Re: Strange behavior of dolphin find search

Postby ath_pg » 18 Oct 2014 05:57

Orbmiser wrote: Also on hover over jpeg a Thumbnail popups up with size,dimensions,etc.. but now no info on dimensions of image to mouse over popup. Popup Works for Home but not on my Ntfs usb drives where busy icon spins and spins never generating a thumbnail popup.

.
Me too. The popup only show size, no pixels in my dolphin.

User avatar
Snap
Posts: 1244
Joined: 25 Aug 2013 20:01
Location: Spain

Re: Strange behavior of dolphin find search

Postby Snap » 18 Oct 2014 07:42

It works fine here, but I don't have baloo installed neither indexing or nepomuk enabled.
This likely means that your installation is broken. -Mr Pixbuf.

Image

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Strange behavior of dolphin find search

Postby MAYBL8 » 18 Oct 2014 11:33

I removed baloo. Didn't make any difference.
The protocol message is still gone.
I used the Find files/folders from the main menu and that works fine.
Going to look and see what Dolphin is using when it is doing a search.


User avatar
ath_pg
Posts: 21
Joined: 01 Sep 2013 09:34

Re: Strange behavior of dolphin find search

Postby ath_pg » 18 Oct 2014 11:40

I can use kfind without problem, but no clue for this problem. I can't figure it out why under some folders it works fine, while under most folders it doesn't.

User avatar
Snap
Posts: 1244
Joined: 25 Aug 2013 20:01
Location: Spain

Re: Strange behavior of dolphin find search

Postby Snap » 18 Oct 2014 11:44

MAYBL8 wrote:I removed baloo. Didn't make any difference.
The protocol message is still gone.
I used the Find files/folders from the main menu and that works fine.
Going to look and see what Dolphin is using when it is doing a search.
Have you tried to disable the nepomuk server?
This likely means that your installation is broken. -Mr Pixbuf.

Image

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Strange behavior of dolphin find search

Postby MAYBL8 » 18 Oct 2014 11:55

Have you tried to disable the nepomuk server?
I don't think I have that.
How do I disable it?


User avatar
Snap
Posts: 1244
Joined: 25 Aug 2013 20:01
Location: Spain

Re: Strange behavior of dolphin find search

Postby Snap » 18 Oct 2014 12:09

Edit ~/.kde/share/config/nepomukserverrc like this:

Code: Select all

[Basic Settings]
Start Nepomuk=false

[Service-nepomukfileindexer]
autostart=false

[Service-nepomukstrigiservice]
autostart=false
logout, loging and check if find works now.

You can also can check baloofilerc if installed

Code: Select all

[Basic Settings]
Indexing-Enabled=false
If using akonadi related apps you may also want to check if this affects the find funtion. (I have them all disabled in my systems).

Code: Select all

akonadictl stop
(start, stop, restart, status)
This likely means that your installation is broken. -Mr Pixbuf.

Image

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Strange behavior of dolphin find search

Postby MAYBL8 » 18 Oct 2014 12:17

added the nepomukserverrc file and now it works.


User avatar
Orbmiser
Posts: 829
Joined: 24 Aug 2013 22:58
Location: Portland,Oregon

Re: Strange behavior of dolphin find search

Postby Orbmiser » 18 Oct 2014 15:40

MAYBL8 wrote:added the nepomukserverrc file and now it works.
Strange that you had to add it? As was just there in mine. And don't use any indexing as had in disabled in System Settings before. But now can't find that indexing enabled/disabled flag in system settings.

My nepomukservercc in my home .kde/share/config/ shows.

Code: Select all

[Baloo]
migrated=true

[Service-nepomukfileindexer]
autostart=false

[Service-nepomuktelepathyservice]
autostart=false

[main Settings]
Maximum memory=50
And see nobody else mention what to do with the Ballo line. As my nepomuk is off it appears.
.
Portfolio
http://500px.com/Orbmiser
Flickr
http://www.flickr.com/photos/orb9220/

SolydK - Kernel 3.16-2-amd64 - KDE 4.14.1 Update Pack: 2014.10.15

User avatar
Snap
Posts: 1244
Joined: 25 Aug 2013 20:01
Location: Spain

Re: Strange behavior of dolphin find search

Postby Snap » 18 Oct 2014 21:59

No idea. It's the first time I see a baloo line into that file. But I have zero experience with baloo. Perhaps it's normal. Is it? My guess is that in your system baloo replaced nepomuk at some point so that's why it shows as nepomuk services already migrated to baloo.
This likely means that your installation is broken. -Mr Pixbuf.

Image

User avatar
Orbmiser
Posts: 829
Joined: 24 Aug 2013 22:58
Location: Portland,Oregon

Re: Strange behavior of dolphin find search

Postby Orbmiser » 19 Oct 2014 00:18

Snap wrote:No idea. It's the first time I see a baloo line into that file. But I have zero experience with baloo. Perhaps it's normal. Is it? My guess is that in your system baloo replaced nepomuk at some point so that's why it shows as nepomuk services already migrated to baloo.
That's my guess also. And resulting search problems I betcha is Balloo & Dolphin not playing nice in the sandbox! :?

.
Portfolio
http://500px.com/Orbmiser
Flickr
http://www.flickr.com/photos/orb9220/

SolydK - Kernel 3.16-2-amd64 - KDE 4.14.1 Update Pack: 2014.10.15

User avatar
ath_pg
Posts: 21
Joined: 01 Sep 2013 09:34

Re: Strange behavior of dolphin find search

Postby ath_pg » 19 Oct 2014 02:29

After trial and error many times, I confirm that if I disable baloofilerc, the dolphin search function works fine no matter akonadi is on or off, and I disable Nepomuk all the time.
However, if I disable file index in baloofilerc, when I hover on files or folders, the cursor busy sign keep rotating forever, just like @Orbmiser mentioned above, the popup info never appear.
In short, if disable baloofilerc, popup doesn't work; if enable baloofilerc, search function in dolphin doesn't work. Tough situation.

User avatar
Snap
Posts: 1244
Joined: 25 Aug 2013 20:01
Location: Spain

Re: Strange behavior of dolphin find search

Postby Snap » 19 Oct 2014 06:01

Ah, Ok. I don't use Show Tooltips so i didn't saw that issue. I find them annoying and too on the way, so when I configure Dolphin I always disable tooltips in General Behavior. But there should be a way to configure baloo.
This likely means that your installation is broken. -Mr Pixbuf.

Image

User avatar
Snap
Posts: 1244
Joined: 25 Aug 2013 20:01
Location: Spain

Re: Strange behavior of dolphin find search

Postby Snap » 19 Oct 2014 06:03

Maybe configuring the included folders can help the search to work...

https://community.kde.org/Baloo/Configuration

My basic (default?) baloofilerc only has exclude filters in it. Once again I don't have baloo installed or any kind of indexing enabled, but I guess it should worth to explore and fiddle with that config file if you use indexing.
This likely means that your installation is broken. -Mr Pixbuf.

Image

User avatar
smitty1
Posts: 242
Joined: 23 Jun 2013 13:50
Location: Pittsburgh, PA USA

Re: Strange behavior of dolphin find search

Postby smitty1 » 19 Oct 2014 10:27

Thanks for that link Snap
I was having the same problem but the link was the clue to fixing it.
First backup baloofilerc. Then add

Code: Select all

[Basic Settings]
   Indexing-Enabled=true
To the beginning of the file & save it. Logout and back in.
This worked in 2 SolydK installs.

No Good Deed Goes Unpunished

User avatar
ath_pg
Posts: 21
Joined: 01 Sep 2013 09:34

Re: Strange behavior of dolphin find search

Postby ath_pg » 19 Oct 2014 11:31

Hi smitty1, did you install baloo? I don't install baloo and also disable nepomuk, after I added your code in baloofilerc, the "invalid protocol" still exists, and my baloofilerc is like

Code: Select all

[Basic Settings]
Indexing-Enabled=true

[General]
exclude filters=autom4te,*.rcore,CTestTestfile.cmake,*.o,*.omf,*.swap,.hg,*.m4,*.orig,.obj,moc_*.cpp,conftest,.pch,.xsession-errors*,CMakeTmpQmake,*.tmp,qrc_*.cpp,po,.svn,.histfile.*,lzo,.bzr,.git,litmain.sh,cmake_install.cmake,CMakeFiles,*.pc,*.nvram,*.elc,*.la,.moc,CMakeCache.txt,confdefs.h,*.gmo,*.csproj,*.rej,config.status,lost+found,confstat,*.pyc,_darcs,CVS,.uic,*.part,libtool,*.aux,*.po,CMakeTmp,Makefile.am,*.lo,ui_*.h,*.loT,*~,*.moc,*.vm*,*.class,core-dumps
exclude filters version=2

User avatar
smitty1
Posts: 242
Joined: 23 Jun 2013 13:50
Location: Pittsburgh, PA USA

Re: Strange behavior of dolphin find search

Postby smitty1 » 19 Oct 2014 11:44

Hi ath _pg
No i did not have baloo installed.

Code: Select all

jim@k-vm-sid:~$ apt-cache policy baloo
baloo:
  Installed: (none)
  Candidate: 4:4.14.1-1
  Version table:
     4:4.14.1-1 0
        500 http://http.us.debian.org/debian/ unstable/main amd64 Packages
And my baloofilerc file only contained the exclude filters. I do not use nepomuk.
I think if you change the Indexing enabled line to false your Dolphin find will work again.

No Good Deed Goes Unpunished


Return to “KDE specific (SolydK)”

Who is online

Users browsing this forum: No registered users and 3 guests