[SOLVED] Install libqt4-phonon without removing anything?

Questions specific to the KDE DE go here
Deleted User 2764

[SOLVED] Install libqt4-phonon without removing anything?

Postby Deleted User 2764 » 15 Nov 2014 23:23

I wanted to install libqt4-phonon to see if that will get amarok and dolphin to finally play audio files. I can't though because it wants to uninstall practically the whole distribution or at least uninstall all of KDE! Why is that? And is there a way to get around it so I can safely install (and if it isn't the solution, safely uninstall) libqt4-phonon?

Deleted User 2764

Re: How do I install libqt4-phonon without removing anything

Postby Deleted User 2764 » 16 Nov 2014 00:18

Found out I don't really need this as I got amarok working. But, just for discussion, can anyone come up with a way to install this (in case someone does want to install it) without losing half of KDE in the process?

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: How do I install libqt4-phonon without removing anything

Postby zerozero » 16 Nov 2014 00:35

from the description
zerozero@home ~ $ apt-cache show libqt4-phonon
Package: libqt4-phonon
Source: qt4-x11 (4:4.8.6+git64-g5dc8b2b+dfsg-2)
Version: 4:4.8.6+git64-g5dc8b2b+dfsg-2+b1
Installed-Size: 507
Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Architecture: amd64
Depends: libc6 (>= 2.14), libgcc1 (>= 1:4.1.1), libqt4-designer (= 4:4.8.6+git64-g5dc8b2b+dfsg-2+b1), libqtcore4 (= 4:4.8.6+git64-g5dc8b2b+dfsg-2+b1), libqtdbus4 (= 4:4.8.6+git64-g5dc8b2b+dfsg-2+b1), libqtgui4 (= 4:4.8.6+git64-g5dc8b2b+dfsg-2+b1), libstdc++6 (>= 4.1.1)
Pre-Depends: multiarch-support
Conflicts: libphonon4
Description-en: Qt 4 Phonon module
Qt is a cross-platform C++ application framework. Qt's primary feature
is its rich set of widgets that provide standard GUI functionality.
.
The Qt Phonon module provides a cross-platform multimedia framework that
enables the use of audio and video content in Qt applications.
.
The sole purpose of this package to provide Phonon libraries until libphonon4
is built from the phonon source package. Therefore it's only useful when
bootstraping new architectures or rebuilding the whole archive from scratch.

Description-md5: 06c81e8c63c158ff25a5d86361eaffe1
Multi-Arch: same
Homepage: http://qt-project.org/
Tag: implemented-in::c++, role::shared-lib, uitoolkit::qt
Section: libs
Priority: optional
Filename: pool/main/q/qt4-x11/libqt4-phonon_4.8.6+git64-g5dc8b2b+dfsg-2+b1_amd64.deb
Size: 161922
MD5sum: b7ebe7cc9a7566137b6ec7adb72ec5cd
SHA1: dd2e2015c57aaef4379d8457b0ee2ff0ffe2735b
SHA256: 6f62c115a5b73d143e1793c6ad3c5bc577f08dbc0a9055b950091088df57bead
highlight is mine.
this is not a package intended for end-user, you should install

Code: Select all

zerozero@home ~ $ apt-cache show libphonon4
Package: libphonon4
Source: phonon
Version: 4:4.8.0-3
Installed-Size: 609
Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Architecture: amd64
Depends: libc6 (>= 2.14), libpulse-mainloop-glib0 (>= 0.99.1), libpulse0 (>= 0.99.1), libqt4-dbus (>= 4:4.8.1), libqtcore4 (>= 4:4.8.1), libqtgui4 (>= 4:4.8.1), libstdc++6 (>= 4.1.1)  
Pre-Depends: multiarch-support 
Breaks: phonon-backend-xine (<< 4:4.6.0really4.3.80)  
Description-en: multimedia framework from KDE - core library 
 Phonon is the Qt 4 multimedia API, which provides a task-oriented abstraction  
 layer for capturing, mixing, processing, and playing audio and video content.     
 .          
 This package contains the core library of the Phonon cross-platform multimedia  
 framework from KDE. It is required to run applications that use Phonon.     
Description-md5: 4566feed5f0036ee4cfb4a0956976557    
Multi-Arch: same      
Homepage: http://phonon.kde.org/           
Tag: implemented-in::c++, role::shared-lib     
Section: libs     
Priority: optional   
Filename: pool/main/p/phonon/libphonon4_4.8.0-3_amd64.deb                    
Size: 161108  
MD5sum: a499149d72c1154becc348b3ab1fefe8
SHA1: 818abae2441f8e9f5d6fc32931d2b86a05cb9126
SHA256: 515495c81c4012c6335e721eea0ac682e2b163f18ada6536441827f6df29a86b
think it should already be installed.
bliss of ignorance

Deleted User 2764

Re: How do I install libqt4-phonon without removing anything

Postby Deleted User 2764 » 16 Nov 2014 00:42

I was hoping you'd reply with some useful info and you did! 8-)

Confirmed. libphonon4 is in fact installed by default.

Thanks for all the info!


Return to “KDE specific (SolydK)”

Who is online

Users browsing this forum: No registered users and 2 guests