Page 1 of 1

Slightly annoying problem with dual monitors.

Posted: 17 Mar 2015 11:08
by Andrew
I have dual monitors set up on the desktop. A 24" & a 19". The 24" is set as primary. I run SolydK HE on that computer. What my annoyance is, I have to add a panel to the second monitor because when I minimize a browser window, it minimizes to the second monitor, & have no way to maximize it again without a panel. Also, browser windows open in the second monitor, while system windows open in the first.

Why is that? Can I change it so all windows open in the 24" monitor, so I don't have to add a panel to the second monitor? It does this same thing in SolydK BE.

Just out of interest, I installed Linux Mint 17 on the 2nd HDD & all windows open (& minimize) in the 24" monitor, so I don't have to add a panel to the 19". Would that just be a Debian/Solyd vs Ubuntu thing?

Re: Slightly annoying problem with dual monitors.

Posted: 25 Apr 2015 09:59
by Arjen Balfoort
I see you haven't received an answer yet.
Unfortunately I cannot help you with this: I only have one monitor.

Re: Slightly annoying problem with dual monitors.

Posted: 26 Apr 2015 23:24
by Zero Angel
I'm guessing it may have something to do with how your specific video driver implements dual monitor. Just a guess.

You can also run 'xrandr' (in terminal) to see if it thinks that your second monitor is your primary monitor.

If you can't figure it out. There is a workaround. System Settings -> Window Rules

You can create a new rule that says, for example "Window Class -> Exact Match -> firefox" -> "Screen -> Apply Initially -> 1"

That should cause newly created Windows from the 'firefox' application to appear on monitor 1 initially.

Re: Slightly annoying problem with dual monitors.

Posted: 29 May 2015 02:34
by uncle mark
I fought this myself just the other day when doing this new install.

The problem is with the Task Manager Settings. Under Filters, it will have

Only show tasks from the current desktop

checked. Uncheck that and you should be good.