Underlined letters in K menu

Questions specific to the KDE DE go here
Magnus Johansson
Posts: 56
Joined: 31 Dec 2015 13:13

Underlined letters in K menu

Postby Magnus Johansson » 07 Jan 2016 09:20

Hello!

I am used to have underlined letters in the K menu as per default, but in SolydK 8 32 201512 with KDE 4.14.2 they are there only after using the Alt key when selecting menu items two times, so the first two times I open the K menu there are no underlined letters in the menu. Is there a way to change this to have underlined letters from the start?

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Underlined letters in K menu

Postby MAYBL8 » 07 Jan 2016 12:28

It looks like if you change the widget style from Oxygen to something else you loose the underscores.


Magnus Johansson
Posts: 56
Joined: 31 Dec 2015 13:13

Re: Underlined letters in K menu

Postby Magnus Johansson » 07 Jan 2016 14:19

MAYBL8 wrote:It looks like if you change the widget style from Oxygen to something else you loose the underscores.
Do you lose the underscores permanently or can you get them back with Alt?

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Underlined letters in K menu

Postby MAYBL8 » 07 Jan 2016 15:10

I was wrong earlier. I opened up one of my other Solydk systems and changing the Widget style had no effect on the Underline so it must be something else.


Magnus Johansson
Posts: 56
Joined: 31 Dec 2015 13:13

Re: Underlined letters in K menu

Postby Magnus Johansson » 07 Jan 2016 15:24

MAYBL8 wrote:I was wrong earlier. I opened up one of my other Solydk systems and changing the Widget style had no effect on the Underline so it must be something else.
In what way were you wrong? Does your first SolydK system now behave like your second one?

User avatar
MAYBL8
Posts: 1487
Joined: 10 Mar 2013 18:41
Location: Maryland Heights, MO USA
Contact:

Re: Underlined letters in K menu

Postby MAYBL8 » 07 Jan 2016 16:24

I changed the styles and the underscore didn't disappear.

Edit:
I found this post:
https://forum.kde.org/viewtopic.php?f=17&t=96763

Don't know if this will help with your situation.


Magnus Johansson
Posts: 56
Joined: 31 Dec 2015 13:13

Re: Underlined letters in K menu

Postby Magnus Johansson » 07 Jan 2016 18:32

MAYBL8 wrote:I changed the styles and the underscore didn't disappear.

Edit:
I found this post:
https://forum.kde.org/viewtopic.php?f=17&t=96763

Don't know if this will help with your situation.
Thanks. I ran the program "oxygen-settings" mentioned in the KDE forum post, but it was already set to always show shortcuts (i.e. -- I assume -- the underscored letters). It seems to be a bug that causes them to be hidden from start.

User avatar
Ghstryder
Posts: 41
Joined: 01 Sep 2015 01:38
Location: Detroit, Michigan, USA

Re: Underlined letters in K menu

Postby Ghstryder » 07 Jan 2016 18:44

Was the setting for 'shortcuts' or for 'accelerators'?

Magnus Johansson
Posts: 56
Joined: 31 Dec 2015 13:13

Re: Underlined letters in K menu

Postby Magnus Johansson » 07 Jan 2016 19:12

Ghstryder wrote:Was the setting for 'shortcuts' or for 'accelerators'?
For "snabbtangenter" since I use the Swedish version. I do not know what that translates to -- probably "accelerators". The options for them are found in the first drop-down list on the first tab in the program window pane "Grafisk komponentstil".

User avatar
Ghstryder
Posts: 41
Joined: 01 Sep 2015 01:38
Location: Detroit, Michigan, USA

Re: Underlined letters in K menu

Postby Ghstryder » 07 Jan 2016 19:30

Google Translate:

snabbtangenter = shortcuts
Grafisk komponentstil = Widget Style
Accelerators=Accelerators

I'm using Plasma 5. From the Ctrl + Tab exercise, I know the Plasma 5 / KDE 4 menus are somewhat different. I don't have time now, but I'll boot to something with KDE4 and see what it says. Here, it definitely states 'accelerators'.

Magnus Johansson
Posts: 56
Joined: 31 Dec 2015 13:13

Re: Underlined letters in K menu

Postby Magnus Johansson » 07 Jan 2016 20:48

Ghstryder wrote:Google Translate:

snabbtangenter = shortcuts
Grafisk komponentstil = Widget Style
Accelerators=Accelerators

I'm using Plasma 5. From the Ctrl + Tab exercise, I know the Plasma 5 / KDE 4 menus are somewhat different. I don't have time now, but I'll boot to something with KDE4 and see what it says. Here, it definitely states 'accelerators'.
"Shortcuts" usually translates to "genvägar", and "accelerators" to "acceleratorer". However, I seem to have discovered a feature in this assumed bug. If I open the K menu and then holds down Alt the underscores appear in the menu. If I then open e.g. Firefox by pressing N and then W, the K menu is set to show underscores directly the next time I open it without the need to hold down Alt. If I press Alt this next time I remove the underscores. Can you confirm this behavior?

User avatar
Ghstryder
Posts: 41
Joined: 01 Sep 2015 01:38
Location: Detroit, Michigan, USA

Re: Underlined letters in K menu

Postby Ghstryder » 07 Jan 2016 21:14

Ok - I booted the current Stable version from a USB Stick
This is KDE 4.14.2

1 - I switched from the Application Launcher Style Menu to the Classic Menu - at that point I see the underscores with no further action on my part
2 - I opened System Settings
3 - I opened Application Appearance
4 - Style is selected by default - I have QtCurve selected by default.
5 - I clicked the Configure Button
6 - I selected General - there is a check box labeled "Hide shortcut underline until "Alt" key is pressed. This is a programmed feature, not a bug

Once again, things seem to work here with no action on my part other than switching menus. It might be interesting to hear from someone with an installed copy of stable.

Magnus Johansson
Posts: 56
Joined: 31 Dec 2015 13:13

Re: Underlined letters in K menu

Postby Magnus Johansson » 08 Jan 2016 19:20

Ghstryder wrote:Ok - I booted the current Stable version from a USB Stick
This is KDE 4.14.2

1 - I switched from the Application Launcher Style Menu to the Classic Menu - at that point I see the underscores with no further action on my part
2 - I opened System Settings
3 - I opened Application Appearance
4 - Style is selected by default - I have QtCurve selected by default.
5 - I clicked the Configure Button
6 - I selected General - there is a check box labeled "Hide shortcut underline until "Alt" key is pressed. This is a programmed feature, not a bug

Once again, things seem to work here with no action on my part other than switching menus. It might be interesting to hear from someone with an installed copy of stable.
Thanks. Now I have unchecked "Hide shortcut underline until 'Alt' is pressed." which for some reason was the default in my installation.


Return to “KDE specific (SolydK)”

Who is online

Users browsing this forum: No registered users and 3 guests