How to get folder background 100% transparent?

Questions specific to the KDE DE go here
SolydForEver
Posts: 342
Joined: 13 Oct 2014 05:25
Location: East part of The Netherlands

How to get folder background 100% transparent?

Postby SolydForEver » 28 Apr 2016 15:23

Hi,

I'm setting up SolydK (first in a virtual machine to make sure everything is working as I want it to) and now I have the following situation:
I created 4 virtual desktops. Tried 4 activities first but somehow this doe snot work as easy as different desktops.
Desktops are called: General, Photography, Multimedia and Office and each contains icons related to these names. They also have different backgrounds, also somehow related.
When I started I copied items from the kick-off menu to the desktop which is set as a folder. But, they appeared small. I know I can enlarge them one-by-one but that was too much work. Plus, how to get them the same size and how to get them all in one line next to each other?
So, I created an empty panel and copied the icons to that panel, making sure I set the size of the icons to large. I like that, especially with the used evolvere icon theme.
What disturbs me now is the fact that I see the panels so clearly. Is there a way to make the panels completely 100% transparent so it looks as if they are not there, but still I have the advance of having them and using them?

Is there for example a theme which does that, is there a setting somewhere I can use, an effect I should enable and setup to do this?
Who can help me with this?

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: How to get panel background 100% transparent?

Postby Zill » 28 Apr 2016 20:07

XFCE (SolydX) has the option to autohide a panel and so I guess this could do what you want as it means that the panel appears to be, effectively, 100% transparent until you hover the cursor over its position.

Right Click the Panel and select: Panel > Panel Preferences > Display > Automatically show and hide the panel.

I haven't used KDE for years but I would expect it to also have this autohide functionality.

SolydForEver
Posts: 342
Joined: 13 Oct 2014 05:25
Location: East part of The Netherlands

Re: How to get panel background 100% transparent?

Postby SolydForEver » 29 Apr 2016 14:48

Hello Zill and thank you for your answer.

I can not find the settings you wrote but I think they are for XFCE, right? Now that I read your message I have been searching around and I don't quite know if I described my "problem" correctly.
snapshot1.png
When you look at the picture you see my first "General" desktop. On it I placed what I think is a panel, but when I right-click it it says it is a folder and added icons to it.
What I would like is that either the panel or the folder (whatever it is called) has a background with 100% transparency so I don't see it. I only see the icons placed inside it.
On this picture it is not even so bad, but on the other desktops I use pictures as background and then they are disturbing the view.
I hope I made myself a bit more clear this way.

User avatar
Zill
Posts: 1850
Joined: 13 Aug 2013 14:28
Location: Lincolnshire, UK

Re: How to get panel background 100% transparent?

Postby Zill » 29 Apr 2016 15:57

SolydForEver: Thank you for the clarification and I think I see what you are trying to achieve now... You just want to see the icons on the panel without seeing the panel background colour?

I think this should be achievable and, with SolydX, I believe it should be a matter of playing around with the XFCE panel background colour and opacity settings.

However, as I don't use SolydK, I cannot give specific advice on the KDE settings required. Hopefully, some other users more familiar with the current KDE versions will be able to help with this.

User avatar
Arjen Balfoort
Site Admin
Posts: 9249
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: How to get panel background 100% transparent?

Postby Arjen Balfoort » 30 Apr 2016 10:51

Why don't you just mark your desktop to show as a folder?
This is default behavior in the new ISOs (at least the nightly builds).

Right click on your desktop > Desktop settings > View > Layout: Folder
You can change the location to show in the Location menu (Show the Desktop folder is default).


SolydXK needs you!
Development | Testing | Translations

SolydForEver
Posts: 342
Joined: 13 Oct 2014 05:25
Location: East part of The Netherlands

Re: How to get panel background 100% transparent?

Postby SolydForEver » 30 Apr 2016 13:09

Thank you gentlemen for your help.
@Schoelje: as I wrote in my initial message, when I use folder instead if desktop the icons appear very small. I know how to enlarge them one by one, but since I have a lot of them it is a lot of work. Add to that the fact that it is difficult to make them all the same size since it is not a matter of typing a value but enlarging them by dragging, plus how to arrange them neatly in a row?
Now I added a folder widget to the desktop, copied the icons in there and select to place them on a grid, set the size to my liking and it works.
The only thing I would like to have now is the background of the folder widgets to be 100% transparent.

So, as Zill also mentioned already, i hope there are some KDE people around here who can help me with this. It is not a real problem, it's just aesthetic.

User avatar
Arjen Balfoort
Site Admin
Posts: 9249
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: How to get panel background 100% transparent?

Postby Arjen Balfoort » 30 Apr 2016 13:13

Still in Desktop Settings, you can find the Icons menu just below the Location menu.
There you can change the overall icon size and the way the icons are arranged.


SolydXK needs you!
Development | Testing | Translations

SolydForEver
Posts: 342
Joined: 13 Oct 2014 05:25
Location: East part of The Netherlands

Re: How to get panel background 100% transparent?

Postby SolydForEver » 30 Apr 2016 13:16

In Desktop Settings I only see View and Mouse Actions in the left field. There is not much I can change there. Am I missing some menu items, if so why and how to make them visible?

User avatar
Arjen Balfoort
Site Admin
Posts: 9249
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: How to get panel background 100% transparent?

Postby Arjen Balfoort » 30 Apr 2016 13:32

This is what I get after selecting the folder view in the View menu (hit Apply and open Desktop settings again):
kde-dekstop-settings.jpg
kde-dekstop-settings.jpg (40.96 KiB) Viewed 2295 times


SolydXK needs you!
Development | Testing | Translations

SolydForEver
Posts: 342
Joined: 13 Oct 2014 05:25
Location: East part of The Netherlands

Re: How to get panel background 100% transparent?

Postby SolydForEver » 30 Apr 2016 13:59

Schoelje, thank you again for helping me.

When I right-click on my desktop and select Desktop Settings, I get this:
snapshot1.png
On my desktop I have a folder widget, and when I right-click it and select Folder settings, I get this:
snapshot2.png
Mind you, I have set the desktop to Desktop and NOT to Folder.
But I am happy with what I've got, as I wrote before it is not a real problem.

SolydForEver
Posts: 342
Joined: 13 Oct 2014 05:25
Location: East part of The Netherlands

Re: How to get panel background 100% transparent?

Postby SolydForEver » 08 May 2016 07:48

Schoelje wrote:Why don't you just mark your desktop to show as a folder?
This is default behavior in the new ISOs (at least the nightly builds).

Right click on your desktop > Desktop settings > View > Layout: Folder
You can change the location to show in the Location menu (Show the Desktop folder is default).
Schoelje, I don't know what is different now but I changed my virtual desktops into Folder view and it works. Had some problems to overcome but I managed to do so:
All my desktop icons were named (on the Desktop view already, so before changing to Folder view): programname.desktop
I don't like this so I wanted to delete the ".desktop" part of the name. Found this:

Code: Select all

rename 's/\.desktop$//' *.desktop
Now some of the icons changed into a simple text file, losing the ability to function as a link and losing their picture.
I examined the contents of this file with a working icon and at first I saw no differences. Then, finally, I saw this at the top of the working icon:

Code: Select all

#!/usr/bin/env xdg-open
[Desktop Entry]
Name=Dolphin
Name[af]=Dolphin
etc, etc
The line "[Desktop Entry]" is written in Bold (but somehow I can't get this to work here)
In an icon which did NOT work this line was present, but not at the top of the text file and NOT in bold. Moving it to the right spot would make it bold, give the icon its normal picture again and made it work.
So now I have all my icons directly on the desktops, no folders with not 100% transparent backgrounds anymore and I managed to rename the icons so the .desktop part is gone. Plus we have 25 degrees again meaning I am one happy guy.


Return to “KDE specific (SolydK)”

Who is online

Users browsing this forum: No registered users and 2 guests