Volume Control Issue (solved)

Questions specific to the KDE DE go here
speartip
Posts: 19
Joined: 01 Aug 2017 12:21

Volume Control Issue (solved)

Postby speartip » 03 Aug 2017 08:38

Using Solydk 9 & enjoying the experience. Just one thing is bugging me. I normally set the volume, from the tray icon to 60%. However when I do it drags down the volume of the Applications as well, ie. Amarok. So when I reduce my main volume to 60%, Amarok now plays at 60% of 60%, if you get what I mean. Then when I log out or reboot, the volume defaults back to 100% again. I have used pavucontrol with the same result, and have also tried the suggestion from here:
https://forum.kde.org/viewtopic.php?f=289&t=131535
but no good.
This is not an issue in KDE Neon LTS which I dual boot with, so whether it's Debian specific or the version of pulse being used i'm not sure.
Any help would be appreciated.

User avatar
ScottQuier
Posts: 1781
Joined: 18 Jul 2013 15:55
Location: Newport News, VA

Re: Volume Control Issue

Postby ScottQuier » 03 Aug 2017 10:02

A couple of questions to clarify:
  1. What happens to your system volume when you set the system volume to 60%, then open Amarok and set the volume there to 100%?
  2. The reverse, open Amarok, set the volume to 100% and then open the system volume - to what level is the system volume?
  3. Continuing from #2, now change the volume both at the system level and within Amarok.
  4. Using the above scenarios as guides, what behavior are you expecting/wanting to see?
Scott
Quoting zerozero, "The usage of PPA's in debian-based
systems is risky at best and entails serious compatibility
problems; usually it's the best way to destroy an install"

speartip
Posts: 19
Joined: 01 Aug 2017 12:21

Re: Volume Control Issue

Postby speartip » 03 Aug 2017 10:35

Thanks for your quick reply Scott.

1. As soon as I open Amarok, the system volume reverts back to 100%.
2. If Amarok is at 100% so is system Volume.
3. I can drop Amarok's volume without it affecting system volume, but not the other way around.
4. I should be able to change the system volume, to say 60%, but keep Amarok at 100%. Or that's how it works in other KDE distros. But either way the system volume always reverts back to 100% on every login or reboot.
Basically I want to set my system volume to 60% and it stay there.

User avatar
ScottQuier
Posts: 1781
Joined: 18 Jul 2013 15:55
Location: Newport News, VA

Re: Volume Control Issue

Postby ScottQuier » 03 Aug 2017 14:16

I'll take a look at this later this afternoon, unless someone else comes up with a solution, when I have a chance to get next to my KDE box.

I'm not sure I will have a solution, but I'll do what I can.
Scott
Quoting zerozero, "The usage of PPA's in debian-based
systems is risky at best and entails serious compatibility
problems; usually it's the best way to destroy an install"

speartip
Posts: 19
Joined: 01 Aug 2017 12:21

Re: Volume Control Issue

Postby speartip » 03 Aug 2017 15:20

Thank You.

User avatar
ScottQuier
Posts: 1781
Joined: 18 Jul 2013 15:55
Location: Newport News, VA

Re: Volume Control Issue

Postby ScottQuier » 03 Aug 2017 22:12

In the following, system volume is referred to as 's' and amarok volume as 'a'.

OK, so I've done some research and some testing on my newly installed SolydK-9 system and here's what I've discovered (in no particular order):
  1. There are a number of bugs associated with volume and amarok. Most are quite old, but all report behaviors similar to what you are reporting.
  2. I installed another player (audacious) and it exhibited behavior identical to my experiences with amarok.
  3. With both a and s set to some non-100% value:
    • Adjusting a down has no effect on s
    • Adjusting a up has no immediate effect on s until a rises above s, then s climbs in lock-step with a but at different numerical values
    • Adjusting s either up or down has no effect on a
  4. Logging out has no effect on either a or s (this and the next two address your #4 item)
  5. Rebooting has no effect on either a or s
  6. Starting amarok has no effect on either a or s
  7. I can set s to any value I like and adjust a to my pleasure and keep s steady ... right up until I raise a sufficiently high that it becomes higher than s, at which point s will increase also.
My conclusion about all this is that the volume control inside these two applications seem to behave much like an electrical rheostat, right up until the request "power" is higher than s at which point s is increased.

I have to agree, it would be nice if s would remain constant and a would act as a "force multiplier" (but always .LE. 1.0) against s, but I guess things aren't wired that way.

Finally, as my system does not behave exactly as you report, I have to suggest there's something that's been adjusted on your system (or on mine) to account for the difference. I don't have any idea what that might be.
Scott
Quoting zerozero, "The usage of PPA's in debian-based
systems is risky at best and entails serious compatibility
problems; usually it's the best way to destroy an install"

speartip
Posts: 19
Joined: 01 Aug 2017 12:21

Re: Volume Control Issue

Postby speartip » 04 Aug 2017 08:59

Thanks for all your hard work.
I will just have to live with it at a 100% for now.
I've not made any adjustments to my system, it's simply a stock install with a few extra apps installed.
Interestingly i've also noticed that in pavucontrol , whatever volume I set the system sounds to does stick, but doesn't change the volume at all (ie login & logout sounds).
I tried to run a live Debian 9.1 usb, to see if the behaviour was the same, but couldn't even get to the Desktop as the live usb required a username & password, & after about an hours googling I was still non the wiser as to what it was.
Anyway maybe some update down the line might resolve it. Here's hoping.

speartip
Posts: 19
Joined: 01 Aug 2017 12:21

Re: Volume Control Issue

Postby speartip » 04 Aug 2017 12:49

Just some extra info. I have managed to get Debian 9 installed on a separate partition, & the problems the same. So it seems this is an upstream Debian issue. After Googling, there seems to be plenty of others with the same issue.
It isn't a problem on any ubuntu derivative of 16.04, probably because the version of Pulse there is 8.0 and not 10.0.

kurotsugi
Posts: 2085
Joined: 09 Jan 2014 00:17

Re: Volume Control Issue

Postby kurotsugi » 05 Aug 2017 14:53

it's not a bug but rather a feature. pulseaudio did behave like that. people might saw it as a bug since it's _different_ with windows but in reality it's the default behaviour of pulseaudio. if you ask why? well, some people said, because windows did. https://www.reddit.com/r/linux/comments ... seaudio_a/

you didn't notice this issue on windows because you mainly control one volume slider (i.e: the main volume slider). however, on linux, each app has it's own volume slider. hence, the confussion. if you want to disable this feature, you can edit /etc/pulse/daemon.conf and search this entry

Code: Select all

; resample-method = src-sinc-best-quality
; enable-remixing = yes
; enable-lfe-remixing = no
; lfe-crossover-freq = 0

; flat-volumes = yes
change into "flat-volumes = no" to disable this feature. you can read more information here https://wiki.archlinux.org/index.php/PulseAudio

speartip
Posts: 19
Joined: 01 Aug 2017 12:21

Re: Volume Control Issue

Postby speartip » 05 Aug 2017 19:25

Hi Kurotsugi.
This cannot possibly be a feature. no one can introduce a feature that defaults the volume back to 100% everytime you logout or reboot.
If you check the link in my 1st post, I already tried changing the "flat volumes" to No, & it made no difference whatsoever.
I do not use Windows, so wouldn't know what the default behaviour is there.
Also this is purely a KDE specific problem, on SolydX, the volume behaves as it should.
Thanks for trying to help, but this is definitely a bug.

kurotsugi
Posts: 2085
Joined: 09 Jan 2014 00:17

Re: Volume Control Issue

Postby kurotsugi » 05 Aug 2017 22:41

I can't replicate the issue so I can't help further. the behaviour is indeed from pulse so if you want to investigate you can start from there. reinstall pulseaudio might works. configuring plasma's sound applet might be worth too. else, you can entirely purge pulseaudio. from what I saw, you didn't need a sound server so pulseaudio could be safely removed. you can use alsamixer as pavucontrol replacement. this might be not an ideal solution but considering my circumstances this is my best suggestion.

speartip
Posts: 19
Joined: 01 Aug 2017 12:21

Re: Volume Control Issue

Postby speartip » 06 Aug 2017 07:22

(SOLVED)
I think I've actually managed to resolve this issue.
I said in post 1, that this issue did not exit in KDE Neon. So what I have done is copied the /etc/pulse/daemon.conf file from KDE Neon, and over wrote the file in SolydK. Rebooted & Tadaaaa. Volume is set to 45% where I left it. Opened up Amarok, & the App plays at 100% leaving overall volume at 45%, even notifications are behaving now.
I will play around for a day or 2 just to make sure.
If this is an issue for anyone else, please post back & I will attach my daemon.conf file from KDE Neon.

User avatar
ilu
Posts: 2004
Joined: 09 Oct 2013 12:45

Re: Volume Control Issue

Postby ilu » 06 Aug 2017 11:29

Please post the daemon config for future reference. Arjen might want to fix this in the next ISO. It also might help people browsing the internet because of this issue.

speartip
Posts: 19
Joined: 01 Aug 2017 12:21

Re: Volume Control Issue

Postby speartip » 06 Aug 2017 13:30

OK. This is the content of the daemon.conf file that works on my system. Please remember to back up your existing file before making any changes.

Code: Select all

# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.

## Configuration file for the PulseAudio daemon. See pulse-daemon.conf(5) for
## more information. Default values are commented out.  Use either ; or # for
## commenting.

; daemonize = no
; fail = yes
; allow-module-loading = yes
; allow-exit = yes
; use-pid-file = yes
; system-instance = no
; local-server-type = user
; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
; lock-memory = no
; cpu-limit = no

; high-priority = yes
; nice-level = -11

; realtime-scheduling = yes
; realtime-priority = 5

; exit-idle-time = 20
; scache-idle-time = 20

; dl-search-path = (depends on architecture)

; load-default-script-file = yes
; default-script-file = /etc/pulse/default.pa

; log-target = auto
; log-level = notice
; log-meta = no
; log-time = no
; log-backtrace = 0

; resample-method = speex-float-1
; enable-remixing = yes
; enable-lfe-remixing = yes
; lfe-crossover-freq = 120

flat-volumes = no

; rlimit-fsize = -1
; rlimit-data = -1
; rlimit-stack = -1
; rlimit-core = -1
; rlimit-as = -1
; rlimit-rss = -1
; rlimit-nproc = -1
; rlimit-nofile = 256
; rlimit-memlock = -1
; rlimit-locks = -1
; rlimit-sigpending = -1
; rlimit-msgqueue = -1
; rlimit-nice = 31
; rlimit-rtprio = 9
; rlimit-rttime = 200000

; default-sample-format = s16le
; default-sample-rate = 44100
; alternate-sample-rate = 48000
; default-sample-channels = 2
; default-channel-map = front-left,front-right

; default-fragments = 4
; default-fragment-size-msec = 25

; enable-deferred-volume = yes
deferred-volume-safety-margin-usec = 1
; deferred-volume-extra-delay-usec = 0

Hope this helps someone.

User avatar
Redraw
Posts: 69
Joined: 19 Jan 2017 11:01
Location: S.E.Q.Australia

Re: Volume Control Issue

Postby Redraw » 24 Aug 2017 10:30

hope nobody minds but here is my 5cents worth after I read your problem I was bit worried only installed SolydK9 less than 24 hours ago and oh no I could have sound level issues ( neighbors wont like that at all ) so I checked and rechecked the sound level on mine and it seems ? to be OK
Here is what is on my desktopbox , Clementine to play the music , gMusicbrowser to adjust the sound level in all the tunes and to double check all tags is correct as I add them into library ( Replay Gain thing in setting second page ) but the difference is I put in Kmix Volume control ( oh not as good as it was in K8 { have it changed also } )and no other changes . I don't know if thats helpful or relevant

speartip
Posts: 19
Joined: 01 Aug 2017 12:21

Re: Volume Control Issue (solved)

Postby speartip » 29 Aug 2017 11:15

Just to add a bit more info to this.
The suggestion made by Kurotsugi, to just change flat-volumes to no, in /etc/pulse/daemon.conf, does indeed work, but a hard shut-down, rather than a reboot is needed on my system to make it take effect.
This may help others with the same issue.


Return to “KDE specific (SolydK)”

Who is online

Users browsing this forum: No registered users and 1 guest