Plasma does not start anymore

Questions specific to the KDE DE go here
fdpg1963
Posts: 16
Joined: 17 Nov 2017 08:43

Plasma does not start anymore

Postby fdpg1963 » 05 Dec 2017 12:44

Hello all,

So happy with my SolidK 9 until today. Yesterday I have shut my laptop in the regular way as always. Power down. Guess what, this morning Plasma does not start at all! After login the KDE logo appears for a while like usual and then the screen gets dark with only the mouse cursor which I can move. No recovery boot or whatever did help. Live version still runs fine strange enough.

Must say the same error happened with KDE Neon. Maybe my laptop and KDE are not a happy couple.

For now I switched to SolidX but it was not a good experience...

Regards, Folkert

User avatar
Arjen Balfoort
Site Admin
Posts: 8884
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Plasma does not start anymore

Postby Arjen Balfoort » 05 Dec 2017 13:52

I had that once. I started in recovery mode and moved away my account directory, copied /etc/skel to /home/myaccount and changed ownership to my account:

Code: Select all

mv /home/myaccount /home/myaccount.bak
cp -r /etc/skel /home/
mv /home/skel /home/myaccount
chown -R myaccount:myaccount /home/myaccount
After that I copied only what I needed bit by bit from /home/myaccount.bak to /home/myaccount/


SolydXK needs you!
Development | Testing | Translations

docke
Posts: 26
Joined: 12 Apr 2015 00:00

Re: Plasma does not start anymore

Postby docke » 06 Dec 2017 01:02

Also it happened to me yesterday.
I overcame this problem with Alt+Ctrl+Del and i've got a screen to Logout, then I Login again and the problem was solved.

fdpg1963
Posts: 16
Joined: 17 Nov 2017 08:43

Re: Plasma does not start anymore

Postby fdpg1963 » 06 Dec 2017 06:36

This trick helped me with Neon KDE but not with SolydK. Tried everything including reboots, recovery mode but nothing helped.
I need a solid laptop for daily use so right now I'm running SolydX, Xfce is not my favorite DE but it runs fast and stable for now.

I'm still not 100% convinced about the stability of Plasma because I had trouble with it in 2 distro's. Xfce lacks options but is mature in terms of development.

freedom
Posts: 12
Joined: 21 Aug 2015 20:13

Re: Plasma does not start anymore

Postby freedom » 19 Jan 2018 17:52

I had similar problem after installation of SolydK 9
Not black screen and mouse pointer but wallpaper and panel loaded but that's it.
I've searched and it appears that there is a bug regarding default system tray and information popups.

Solution was to remove system tray from panel and then add it back.

User avatar
SilverBear
Posts: 7
Joined: 18 Jul 2018 03:35
Location: Chautauqua County, NY, USA

Re: Plasma does not start anymore

Postby SilverBear » 25 Oct 2018 04:17

freedom wrote:
19 Jan 2018 17:52
I had similar problem after installation of SolydK 9
Not black screen and mouse pointer but wallpaper and panel loaded but that's it.
I've searched and it appears that there is a bug regarding default system tray and information popups.

Solution was to remove system tray from panel and then add it back.
Thanks for this tip, freedom!!

You helped me solve a problem that almost sent me back to Mint 18.3 KDE edition. Well, it actually did send me back to Mintfor a couple hours while I got done what I was trying to do when SolydK black-screened me out of a desktop environment.
So, after my work was finished, I came here to do some research, and maybe ask about my weird problem -- and found your hint.

Just in case it happens to anyone else, here's my sad story. And today was the second time the exact same black screen disaster struck. The identical issue occurred about a month ago. But that time I gave up on trying to find out what was wrong from examining log files from the command line, and just renamed /home/silverbear to "/home/old-sb" and then generated a new /home/silverbear directory through KDE.

The Trigger:
It happened while trying to connect my ethernet-wired desktop box to the wifi HP printer on the network. I've printed documents successfully before, but this time the printer driver "cannot locate" the wireless printer. So I uninstall it, and then try to re-install it and bang!
Black screen.
Ctl-Alt-Bkspace gives me the GUI login screen, so I log into a new session, and Plasma starts up, I get my scenic wallpaper displaying, but no panel. After a few more seconds of unusually long waiting, the whole screen goes black, except for a visible, movable mouse cursor.


The Solution:
Using your tip, I did a search and found this page:
https://superuser.com/questions/1069066 ... ry#1353468

In case that linked page disappears, I'll quote it:
The configuration file is:

~/.config/plasma-org.kde.plasma.desktop-appletsrc

Whithin this file you can find a section listing all showed icons. Here you can remove what you wan't view.

To detect the mentioned section, look for a [Containment] containing plugin=org.kde.plasma.private.systemtray

When you've removed what you want, simply kill plasmashell

killall plasmashell

and restart it

kstart plasmashell
I did it slightly differently. I was already booted into Mint, so I just used Dolphin to locate my SolydK /home partition, found the correct file, which in SolydK is indeed: ~/.config/plasma-org.kde.plasma.desktop-appletsrc and edited it in Kwrite.

I deleted the item under the systemtray section like he says to do -- which in my case was the printer device icon and status notification popup.

I rebooted out of Mint and into SolydK with no problem. And all is once again Solyd! :clap:

Thanks again!
"masai7" Intel i7 3770k; 16GB RAM; GeForce GTX-750 - SolydK 9


Return to “KDE specific (SolydK)”

Who is online

Users browsing this forum: No registered users and 3 guests