Amarok throwing errors after recent update (oldstable)

Questions specific to the KDE DE go here
User avatar
BostonPeng
Posts: 475
Joined: 28 Feb 2013 14:35
Location: Boston, MA
Contact:

Amarok throwing errors after recent update (oldstable)

Postby BostonPeng » 26 Feb 2020 18:11

After getting an update to Amarok 2.8.0-8 (I think I got it last month) I get a database error every time I try to launch it.
KDE Amarok database error 20200226_124748.png
KDE Amarok database error 20200226_124748.png (30.01 KiB) Viewed 4660 times

After doing some checking I found Debian bug #793451 has been filed, resolved and closed. Checking the Debian packages I see version 2.9.0-2 came out in August but hasn't reached Stretch yet.
Debian Amarok package stats 20200226_130741.png
Debian Amarok package stats 20200226_130741.png (27.97 KiB) Viewed 4660 times

Does anyone know a workaround for this issue?
J.M. Hardin

System:
ASUS X555LA notebook

User avatar
ilu
Posts: 2661
Joined: 09 Oct 2013 12:45

Re: Amarok throwing errors after recent update

Postby ilu » 28 Feb 2020 01:59

I have no idea how you received an update last month that was released in 2017. Also the bug report you cited was fixed with amarok 2.8.0-3 which is older than your version. It has nothing to do with 2.9.0.1, which will never reach stretch. Your machine is on stretch = SolydK9 right?

The correct error report is most probably https://bugs.debian.org/cgi-bin/bugrepo ... bug=849326. Check the version of mariadb with dpkg -l *mariadb*.
Some users reported that renaming /usr/share/kde4/apps/amarok/mysqle/errmsg.sys to errmsg.sys.old solves the problem as long as other programs (namely akonadi) do not interfere.

If you are on buster you most probably cannot use amarok since it depends on packages that are not present in buster.

User avatar
BostonPeng
Posts: 475
Joined: 28 Feb 2013 14:35
Location: Boston, MA
Contact:

Re: Amarok throwing errors after recent update

Postby BostonPeng » 28 Feb 2020 02:54

Perhaps I didn't get an Amarok update when I thought I did, but something definitely changed last month because before that I was able to use Amarok without issue. I've considered blowing away Amarok and starting fresh but I have a lot of podcasts in the database and I'd really rather not lose that info. I did the version check on mariadb and this is what I got.

Code: Select all

$  dpkg -l *mariadb*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name               Version        Architecture   Description
+++-==================-==============-==============-==========================================
ii  libmariadbclient18 10.1.44-0+deb9 amd64          MariaDB database client library
un  libmariadbd-dev    <none>         <none>         (no description available)
ii  libmariadbd18:amd6 10.1.44-0+deb9 amd64          MariaDB embedded database, shared library
un  mariadb-client-10. <none>         <none>         (no description available)
un  mariadb-client-cor <none>         <none>         (no description available)
ii  mariadb-client-cor 10.1.44-0+deb9 amd64          MariaDB database core client binaries
un  mariadb-client-cor <none>         <none>         (no description available)
ii  mariadb-common     10.1.44-0+deb9 all            MariaDB common metapackage
un  mariadb-server-5.5 <none>         <none>         (no description available)
I tried renaming /usr/share/kde4/apps/amarok/mysqle/errmsg.sys but got a new error.
KDE Amarok database error 20200227_215212.png
KDE Amarok database error 20200227_215212.png (27.96 KiB) Viewed 4318 times
I'm sorry if my information isn't as clear or as helpful as it should be. I've gotten pretty rusty on filing bug reports.
J.M. Hardin

System:
ASUS X555LA notebook

User avatar
ilu
Posts: 2661
Joined: 09 Oct 2013 12:45

Re: Amarok throwing errors after recent update

Postby ilu » 28 Feb 2020 19:26

That new error message is by akonadi as described in the bug report I linked.

The problem is not Amarok but mariadb/mysql. There's an inconsistency in between mysql versions used on your system. This was adressed in the issue I linked and should have been fixed with mariadb 10.1 which you have installed. No idea why you still have problems but neither the amarok update nor the mariadb update should have happened last month. Something else happened. Try to check which software on your system uses mysql (several things under KDE do) and, maybe easier, check apt logs of the last 6-8 weeks. Use zcat to view them.

User avatar
BostonPeng
Posts: 475
Joined: 28 Feb 2013 14:35
Location: Boston, MA
Contact:

Re: Amarok throwing errors after recent update

Postby BostonPeng » 28 Feb 2020 19:58

Thanks. I need to run out but I'll check it out over the weekend. I miss using Amarok.
J.M. Hardin

System:
ASUS X555LA notebook


Return to “KDE specific (SolydK)”

Who is online

Users browsing this forum: No registered users and 10 guests