I want SolydK and no SolydX

Questions about SolydX and SolydK installation.
Mia
Posts: 10
Joined: 13 Sep 2018 16:51

I want SolydK and no SolydX

Postby Mia » 13 Sep 2018 17:39

Hello,
First of all, excuse me if the question is already asked, but I am French and I read English badly, I am currently using Google Translate.
I installed SolydK in VirtualBox on my old PC several months ago, I found this distribution very beautiful graphically.
Unfortunately, it seems incompatible with my new material. :(
I first wanted to install a copy of the same virtual machine, it bugged at the opening.
So I downloaded the latest version and checked the checksum, but the problem is the same, the menu is not even present, and if I click on something, it immediately crashes.
I tried then to install SolydX, and there it is good. :o
I definitely prefer KDE to Xfce, and do not like Thunar at all compared to Dolphin, so I'm not going to use much, it's a shame.
Would you have a solution to my problem?
Thanks a lot for your answers. :)

User avatar
SilverBear
Posts: 7
Joined: 18 Jul 2018 03:35
Location: Chautauqua County, NY, USA

Re: I want SolydK and no SolydX

Postby SilverBear » 13 Sep 2018 20:48

Welcome to SolydXK, Mia!
I am sorry to hear you have a problem. I prefer KDE (SolydK), too.
But KDE needs more RAM than XFCE desktop (SolydX).
Is it possible to give your virtual machine more RAM?
That would be the first thing to try, je crois.
"masai7" Intel i7 3770k; 16GB RAM; GeForce GTX-750 - SolydK 9

User avatar
ilu
Posts: 2060
Joined: 09 Oct 2013 12:45

Re: I want SolydK and no SolydX

Postby ilu » 13 Sep 2018 21:28

To help you we need more more information: Which exact SolydK ISO did you use? How much memory and disk space did you assign to your VM?
---
Pour vous aider, nous avons besoin de plus d'informations :Quel ISO exactement avez-vous utilisé ? Combien de mémoire et d'espace disque avez-vous alloué à votre VM ?

N'utilisez pas Google mais deepl.com/translator, s'il vous plaît. J'ai trouvé que c'est beaucoup mieux. Et c'est une petite entreprise qui n'a aucun lien avec l'industrie mondiale des collecteurs de données.
---
Please don't use Google but deepl.com/translator. I found that it is much better. And it is a small company without any connections to the global data collection industry.

Mia
Posts: 10
Joined: 13 Sep 2018 16:51

Re: I want SolydK and no SolydX

Postby Mia » 14 Sep 2018 11:35

Hello SilverBear and ilu,

I had already written my message with DeepL, and I had a doubt about translating several words.
Google gave me a translation that better matched what I meant.
But you're right, DeepL is the best way to avoid data collection ;)

I gave 2048 MB of Ram and 20 GB of disk space to the VM.

However, I think that the amount of ram assigned is a possibility to be ruled out for several reasons:
- SolydK is installed on my first PC which is less powerful than the second, and yet it runs perfectly
- I used a copy of the same machine on my second PC (so the same settings)
- then restarted using this time a new iso (solydk_9_64_64_201807)
- KDE has a reputation for being resource-intensive, but Manjaro KDE and Kde Neon, whom I also have in VM, are no problem.

Thank you for your interest :)

Translated with www.DeepL.com/Translator

Mia
Posts: 10
Joined: 13 Sep 2018 16:51

Re: I want SolydK and no SolydX

Postby Mia » 16 Sep 2018 08:16

Good morning, everyone,

A little up before I resign myself to using SolydX, which I must admit is not so unpleasant with the relooking of the distro ;)

kurotsugi
Posts: 2116
Joined: 09 Jan 2014 00:17

Re: I want SolydK and no SolydX

Postby kurotsugi » 19 Sep 2018 11:49

a quick shot would be your graphic card. do you have either nvidia or amd/ati card in your machine? if yes, please make sure you have installed the propietary driver. these kind of cases usually need a deep investigation. at minimum, we'll need to check both kernel and X logs.

anyway, please run "inxi -Fxz" and tell us the result

Mia
Posts: 10
Joined: 13 Sep 2018 16:51

Re: I want SolydK and no SolydX

Postby Mia » 19 Sep 2018 12:51

Thank you for helping me, kurotsugi,

I read in the driver manager that no proprietary drivers are used.
This is no problem for the host, and about twenty installed virtual machines, only SolydK and NuTyX (for the RR version alone), are problematic.

Code: Select all

mia@mia-PC4 ~ $ inxi -Fxz
System:    Host: mia-PC4 Kernel: 4.15.0-34-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: MSI model: H61M-P23 (MS-7680) v: 3.0
           Bios: American Megatrends v: V17.3 date: 07/27/2011
CPU:       Quad core Intel Core i7-2600 (-HT-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27139
           clock speeds: max: 3800 MHz 1: 1596 MHz 2: 1596 MHz 3: 1596 MHz
           4: 1596 MHz 5: 1596 MHz 6: 1596 MHz 7: 1596 MHz 8: 1596 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Hawaii XT [Radeon R9 290X]
           bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           GLX Renderer: AMD HAWAII (DRM 2.50.0 / 4.15.0-34-generic, LLVM 6.0.0)
           GLX Version: 3.0 Mesa 18.0.5 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] Hawaii HDMI Audio
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-34-generic
Network:   Card-1: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet
           driver: atl1c v: 1.0.1.1-NAPI port: d000 bus-ID: 04:00.0
           IF: enp4s0 state: down mac: <filter>
           Card-2: Realtek RTL8192CU 802.11n WLAN Adapter usb-ID: 003-003
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 7001.4GB (42.6% used)
           ID-1: /dev/sda model: ST2000DX001 size: 2000.4GB temp: 49C
           ID-2: /dev/sdb model: SAMSUNG_HD103SI size: 1000.2GB temp: 40C
           ID-3: USB /dev/sdc model: M3_Portable size: 4000.8GB temp: 0C
Partition: ID-1: / size: 46G used: 12G (26%) fs: ext4 dev: /dev/sda2
           ID-2: /boot size: 939M used: 401M (45%) fs: ext2 dev: /dev/sda3
           ID-3: /home size: 917G used: 373G (43%) fs: ext4 dev: /dev/sda5
           ID-4: swap-1 size: 17.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 59.0C mobo: N/A gpu: 53.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 245 Uptime: 1 day Memory: 5773.7/16021.6MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
mia@mia-PC4 ~ $ 
Translated with www.DeepL.com/Translator

kurotsugi
Posts: 2116
Joined: 09 Jan 2014 00:17

Re: I want SolydK and no SolydX

Postby kurotsugi » 20 Sep 2018 07:03

another quick shot would be installing the backport kernel or use the EE version. IIRC was several glitch on the EE version but I've heard it already fixed now. I'm not sure if it worth to fix the issue since it's related with graphic card stuffs. there are lot of stuff need to be investigated. we usually wait until we got new kernel and see whether if the issue got fixed or not.

Mia
Posts: 10
Joined: 13 Sep 2018 16:51

Re: I want SolydK and no SolydX

Postby Mia » 20 Sep 2018 10:05

I didn't get a translation that would allow me to fully understand your answer, but I think you advise me to wait for the next kernel, which is what I will do.
Thank you for your interest in my case.

User avatar
ilu
Posts: 2060
Joined: 09 Oct 2013 12:45

Re: I want SolydK and no SolydX

Postby ilu » 20 Sep 2018 16:31

The R9 290 "Hawaii" GPU doesn't work well with the Radeon driver. And searching for it I see reports about failure with KDE - whereas XFCE works. These GPUs (GCN 1.0 and GCN 1.1) are difficult because they fall into AMDs transition period in between radeon and amdgpu driver. Your card is GCN 1.1 type and it would be better to use amdgpu driver but I'm struggling to get that to work. A newer kernel would be necessary but not enough - also mesa and x11 need to be updated.

So, since this is a virtual machine and I guess that you are of the adventurous kind I would recommend to try the SolydXK Enthusiast’s Editions (EE) which is based on Debian testing. It was broken with KDE but this got fixed recently. (That's what kurotsugi was trying to tell you.)
You can try any of the ISOs in https://downloads.solydxk.com/ce/testing/ and report any issues in this thread https://forums.solydxk.com/viewtopic.ph ... =20#p68897.
--------------
Le GPU R9 290 "Hawaii" ne fonctionne pas bien avec Radeon. Et en le cherchant, je vois des rapports sur les échecs avec KDE - alors que XFCE fonctionne. Ces GPU (GCN 1.0 et GCN 1.1) sont difficiles parce quils tombent dans la période de transition AMD entre radeon et amdgpu. Votre carte est de type GCN 1.1 et il serait préférable d'utiliser le pilote amdgpu, mais j'ai du mal à le faire fonctionner. Un noyau plus récent serait nécessaire mais pas suffisant - mesa et x11 doivent aussi être mis à jour.

Donc, puisqu'il s'agit d'une machine virtuelle et que je suppose que vous êtes du genre aventureux, je vous recommande d'essayer les SolydXK Enthusiast's Editions (EE) qui sont basées sur les Debian testing. Il a été cassé avec KDE mais cela a été corrigé récemment. C'est ce que Kurotsugi essayait de vous dire.
Vous pouvez essayer l'un des ISOs dans https://downloads.solydxk.com/ce/testing/ et signaler n'tout problème dans ce thread https://forums.solydxk.com/viewtopic.ph ... =20#p68897.

Traduit avec www.DeepL.com/Translator - I'm again and again amazed at how good this works. I'm not good at french but I only corrected 4 minor mistakes and the rest now sounds "very french". :)

Mia
Posts: 10
Joined: 13 Sep 2018 16:51

Re: I want SolydK and no SolydX

Postby Mia » 21 Sep 2018 15:33

Sorry I'm late, I saw your answer by chance while cleaning my open windows, I hadn't been notified by email this time.
I wondered what EE was, I now understand that this is a Debian testing database.

You tell me to update mesa and x11, they probably are because I will update all the updates regularly.
I also always install the most recent kernel proposed by Mint, but I have never done a backport.
You also recommend the AMDGPU pilot, but you say you have trouble getting it to work. I don't use the proprietary drivers and I'm reluctant to learn how to install it if it doesn't work well for you.

I use virtual machines precisely because I'm not very adventurous: I don't want to break my system, and it's so easy with snapshot to fix things. :D
I will try the EE iso after the weekend and report the result in the appropriate topic. ;)

Translations differ slightly between DeepL and Google Translation.
I often find Google more relevant, but I can be wrong because I have a very poor command of your language :)

Translated with www.DeepL.com/Translator

User avatar
ilu
Posts: 2060
Joined: 09 Oct 2013 12:45

Re: I want SolydK and no SolydX

Postby ilu » 22 Sep 2018 20:38

Vous pouvez faire comme moi : inclure le texte dans les deux langues. Si la traduction est incorrecte, le lecteur peut vérifier le texte original.

En ce qui concerne les pilotes AMD : Le pilote libre radeon est obsolète (pour les cartes graphiques plus récentes). Le nouveau pilotelibre s'appelle amdgpu. Le nouveau pilote propriétaire est amdgpu-pro. Votre carte devrait fonctionner avec radeon et amdgpu mais radeon peut être bogué. Radeon ne sera plus réparé. Et KDE a toujours été difficile à maintenir.
------------
You could do as I do: include the text in both languages. If the translation ends up wrong, the reader can check the original text.

Reagrding kernel and mesa updates: I meant updating nut just to the newest stabel version but to the newest available version (which is in Debian testing).

Regarding AMD drivers: The open radeon driver is obsolete (for newer graphic cards). The new open driver is called amdgpu. The new proprietary driver is amdgpu-prg. Your card is supposed to work with radeon and amdgpu but radeon can be buggy. Radeon will not get fixed anymore. And KDE has always been difficult to maintain.

User avatar
grizzler
Posts: 2044
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: I want SolydK and no SolydX

Postby grizzler » 23 Sep 2018 06:24

ilu wrote:
20 Sep 2018 16:31
...report any issues in this thread https://forums.solydxk.com/viewtopic.ph ... =20#p68897.
Only if it's an issue to do with maintaining or building ISOs. I think this is more a case of incompatible hardware.
Frank

SolydX EE 64 - tracking Debian Testing

Mia
Posts: 10
Joined: 13 Sep 2018 16:51

Re: I want SolydK and no SolydX

Postby Mia » 24 Sep 2018 08:28

Hello,
Excuse me if I answer late or don't see your messages, I have asked to be notified when a reply is posted, but I don't receive (gmail address). :?
grizzler wrote: Only if it's an issue to do with maintaining or building ISOs. I think this is more a case of incompatible hardware.
Sorry, I already posted the answer.
This is probably a hardware problem, which the 64-bit solydk EE version has not solved.
I even had the idea then to try a 32-bit version, you never know, but no, SolydK is definitely not for me :cry:

----------
Bonjour,
Excusez-moi si je réponds tardivement ou ne vois pas vos messages, j'ai bien demandé à être notifiée quand une réponse est postée, cependant je ne reçois pas (adresse gmail).
"Seulement s'il s'agit d'un problème lié à la maintenance ou à la création d'ISO. Je pense que c'est plus un cas de matériel incompatible."
Désolée, j'ai déjà posté la réponse.
Il s'agit sans doute d'un problème matériel, que la version solydk EE 64 bits n'a pas résolu.
J'ai même eu l'idée ensuite d'essayer une version 32 bits, sait-on jamais, mais non, décidément SolydK n'est pas pour moi


Translated with www.DeepL.com/Translator

User avatar
ilu
Posts: 2060
Joined: 09 Oct 2013 12:45

Re: I want SolydK and no SolydX

Postby ilu » 24 Sep 2018 13:30

grizzler: I have no idea how it is even possible that XFCE works but KDE not. What is KDE doing on the desktop that is so special? 3D accel?

mia: Please post the output of

Code: Select all

glxinfo -i | grep render
LIBGL_DEBUG=verbose glxinfo -i
Email notifications: I'm testing this. Edit email notification works for me.

User avatar
grizzler
Posts: 2044
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: I want SolydK and no SolydX

Postby grizzler » 24 Sep 2018 15:57

In my experience (with the ISOs in particular) KDE / Plasma has always been more problematic than XFCE. I've never bothered to figure out why exactly, but it obviously puts a greater strain on the system.
Frank

SolydX EE 64 - tracking Debian Testing

Mia
Posts: 10
Joined: 13 Sep 2018 16:51

Re: I want SolydK and no SolydX

Postby Mia » 25 Sep 2018 08:21

I definitely have a problem with everything!
I still haven't received any notification for your answer.
Fortunately, I rarely turn off my computer, I put it on standby. The tab thus remains open and I check from time to time ;)

Here is the result of the command:

Code: Select all

mia@mia-PC4 ~ $ glxinfo -i | grep render
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  42
  Current serial number in output stream:  45
mia@mia-PC4 ~ $ LIBGL_DEBUG=verbose glxinfo -i
name of display: :0
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/tls/radeonsi_dri.so
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so
libGL: Can't open configuration file /home/mia/.drirc: No such file or directory.
libGL: Can't open configuration file /home/mia/.drirc: No such file or directory.
libGL: Using DRI2 for screen 0
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  155 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  42
  Current serial number in output stream:  45
mia@mia-PC4 ~ $
I can't decipher the exit, but I see a lot of things that seem "failed", maybe a solution will emerge?
Thank you for your continued interest in my problem.

User avatar
ilu
Posts: 2060
Joined: 09 Oct 2013 12:45

Re: I want SolydK and no SolydX

Postby ilu » 25 Sep 2018 17:04

That's basically the same result I'm seeing. I could not find the reason for the errors.

Code: Select all

libGL: Using DRI2 for screen 0

This is different. My card uses DRI3 which can improve performance.

Please try now

Code: Select all

glxinfo | grep render
glxinfo | grep OpenGL
cat /var/log/Xorg.0.log | grep DRI
vainfo
If you don't have vainfo, install it.

I don't know whether we are getting anywhere. But even if not we will definitely learn something.

Mia
Posts: 10
Joined: 13 Sep 2018 16:51

Re: I want SolydK and no SolydX

Postby Mia » 26 Sep 2018 08:13

ilu wrote: I don't know whether we are getting anywhere. But even if not we will definitely learn something.
I really like this philosophy.
I have only been using Linux for 2 years, and I chose this path because I wanted to understand a little bit about how an OS works (with Windows, it was lost in advance :mrgreen: ).
I am delighted to explore these things with a connoisseur. I still consider myself a very newbie and this is very interesting for me.

Code: Select all

mia@mia-PC4 ~ $ glxinfo | grep render
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer, 
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: AMD HAWAII (DRM 2.50.0 / 4.15.0-34-generic, LLVM 6.0.0)
    GL_ARB_compute_variable_group_size, GL_ARB_conditional_render_inverted, 
    GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_packed_depth_stencil, 
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth, 
    GL_NV_blend_square, GL_NV_conditional_render, GL_NV_depth_clamp, 
    GL_OES_element_index_uint, GL_OES_fbo_render_mipmap, 
mia@mia-PC4 ~ $ glxinfo | grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: AMD HAWAII (DRM 2.50.0 / 4.15.0-34-generic, LLVM 6.0.0)
OpenGL core profile version string: 4.5 (Core Profile) Mesa 18.0.5
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.0.5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:
mia@mia-PC4 ~ $ cat /var/log/Xorg.0.log | grep DRI
[    27.859] (II) glamor: EGL version 1.5 (DRI2):
[    28.144] (II) RADEON(0): [DRI2] Setup complete
[    28.144] (II) RADEON(0): [DRI2]   DRI driver: radeonsi
[    28.144] (II) RADEON(0): [DRI2]   VDPAU driver: radeonsi
[    28.145] (==) RADEON(0): DRI3 disabled
[    28.165] (II) GLX: Initialized DRI2 GL provider for screen 0
mia@mia-PC4 ~ $ vainfo
Le programme « vainfo » n'est pas encore installé. Vous pouvez l'installer en tapant :
sudo apt install vainfo
mia@mia-PC4 ~ $ sudo apt install vainfo
[sudo] Mot de passe de mia : 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Le paquet suivant a été installé automatiquement et n'est plus nécessaire :
  libllvm5.0
Veuillez utiliser « sudo apt autoremove » pour le supprimer.
Les paquets supplémentaires suivants seront installés :
  libva-wayland1
Les NOUVEAUX paquets suivants seront installés :
  libva-wayland1 vainfo
0 mis à jour, 2 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 17,8 ko dans les archives.
Après cette opération, 90,1 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://ubuntu.univ-reims.fr/ubuntu xenial-updates/universe amd64 libva-wayland1 amd64 1.7.0-1ubuntu0.1 [8 276 B]
Réception de:2 http://ubuntu.univ-reims.fr/ubuntu xenial-updates/universe amd64 vainfo amd64 1.7.0-1ubuntu0.1 [9 560 B]
17,8 ko réceptionnés en 0s (69,2 ko/s)
Sélection du paquet libva-wayland1:amd64 précédemment désélectionné.
(Lecture de la base de données... 393090 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libva-wayland1_1.7.0-1ubuntu0.1_amd64.deb ...
Dépaquetage de libva-wayland1:amd64 (1.7.0-1ubuntu0.1) ...
Sélection du paquet vainfo précédemment désélectionné.
Préparation du dépaquetage de .../vainfo_1.7.0-1ubuntu0.1_amd64.deb ...
Dépaquetage de vainfo (1.7.0-1ubuntu0.1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu10) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Paramétrage de libva-wayland1:amd64 (1.7.0-1ubuntu0.1) ...
Paramétrage de vainfo (1.7.0-1ubuntu0.1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu10) ...
mia@mia-PC4 ~ $ vainfo
libva info: VA-API version 0.39.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/radeonsi_drv_video.so
libva info: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit
mia@mia-PC4 ~ $ 


Return to “Installation”

Who is online

Users browsing this forum: No registered users and 2 guests