Page 1 of 2

Problems after upgrading to 2.4.3 [SOLVED]

Posted: 26 Oct 2014 15:18
by Deleted User 855
I'm not sure if I should post each issue separately or list them here? For now, I'll start with just this one in case fixing it affects the others. After upgrading the update icon constantly tells me there are updates but when I run it, it says my system is up to date. Rebooting doesn't help. Not sure what info to give but I attachec a copy of the text from konsole.

Re: Problems after upgrading to 2.4.3

Posted: 26 Oct 2014 16:13
by rokytnji
Making this easier

Code: Select all

melisa@solydk ~ $ updatemanager
/usr/bin/../lib/solydxk/updatemanager/updatemanagertray.py melisa &
kdesudo -n -i 'update-manager' -d --comment "<b>Please enter your password</b>" '/usr/bin/../lib/solydxk/updatemanager/updatemanager.py melisa &'
up=2014.07.15
up=2014.10.15
up=2014.07.15
up=2014.10.15
Command to execute: ps -ef | grep updatemanagertray.py
Exit - UM tray already running
up=2014.07.15
up=2014.10.15
up=2014.07.15
up=2014.10.15
['melisa', '&']
Command to execute: ps -ef | grep updatemanager.py
UM log = /var/log/updatemanager.log
Terminal execute command: echo "Gathering information..."
Command to execute: uname -m
/usr/bin/../lib/solydxk/updatemanager/updatemanager.py:134: Warning: The property GtkSettings:gtk-cursor-blink is deprecated and shouldn't be used anymore. It will be removed in a future version.
  self.swTerminal.add(self.terminal)
/usr/bin/../lib/solydxk/updatemanager/updatemanager.py:134: Warning: The property GtkSettings:gtk-cursor-blink-time is deprecated and shouldn't be used anymore. It will be removed in a future version.
  self.swTerminal.add(self.terminal)
/usr/bin/../lib/solydxk/updatemanager/updatemanager.py:134: Warning: The property GtkSettings:gtk-cursor-blink-timeout is deprecated and shouldn't be used anymore. It will be removed in a future version.
  self.swTerminal.add(self.terminal)
INFO      Gathering information...
Command to execute: uname -r
Command to execute: env LANG=C bash -c 'apt-cache policy updatemanager | grep "Installed:"'
show URL: http://home.solydxk.com/umfiles/prd/update-pack.html
Command to execute: ps -U root -u root -o comm=
INFO      0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
INFO      Hit http://packages.solydxk.com solydxk InRelease
INFO      Hit http://packages.solydxk.com solydxk/main i386 Packages
INFO      Hit http://packages.solydxk.com solydxk/upstream i386 Packages
INFO      Hit http://packages.solydxk.com solydxk/import i386 Packages
INFO      Hit http://packages.solydxk.com solydxk/kdenext i386 Packages
INFO      Ign http://packages.solydxk.com solydxk/import Translation-en_US
INFO      Ign http://packages.solydxk.com solydxk/import Translation-en
INFO      Ign http://packages.solydxk.com solydxk/kdenext Translation-en_US
INFO      Ign http://packages.solydxk.com solydxk/kdenext Translation-en
INFO      Ign http://packages.solydxk.com solydxk/main Translation-en_US
INFO      Ign http://packages.solydxk.com solydxk/main Translation-en
INFO      Ign http://packages.solydxk.com solydxk/upstream Translation-en_US
INFO      Ign http://packages.solydxk.com solydxk/upstream Translation-en
INFO      Hit http://debian.solydxk.com testing InRelease
INFO      Hit http://debian.solydxk.com testing/updates InRelease
INFO      Hit http://debian.solydxk.com testing/main i386 Packages
INFO      Hit http://debian.solydxk.com testing/contrib i386 Packages
INFO      Hit http://debian.solydxk.com testing/non-free i386 Packages
INFO      Hit http://debian.solydxk.com testing/main i386 Packages
INFO      Hit http://debian.solydxk.com testing/non-free i386 Packages
INFO      Hit http://debian.solydxk.com testing/updates/main i386 Packages
INFO      Hit http://debian.solydxk.com testing/updates/contrib i386 Packages
INFO      Hit http://debian.solydxk.com testing/updates/non-free i386 Packages
INFO      Hit http://community.solydxk.com solydxk InRelease
INFO      Hit http://community.solydxk.com solydxk/main i386 Packages
INFO      Ign http://debian.solydxk.com testing/contrib Translation-en_US
INFO      Ign http://debian.solydxk.com testing/contrib Translation-en
INFO      Ign http://debian.solydxk.com testing/main Translation-en_US
INFO      Ign http://debian.solydxk.com testing/main Translation-en
INFO      Ign http://debian.solydxk.com testing/non-free Translation-en_US
INFO      Ign http://debian.solydxk.com testing/non-free Translation-en
INFO      Ign http://debian.solydxk.com testing/main Translation-en_US
INFO      Ign http://debian.solydxk.com testing/main Translation-en
INFO      Ign http://debian.solydxk.com testing/non-free Translation-en_US
INFO      Ign http://debian.solydxk.com testing/non-free Translation-en
INFO      Ign http://debian.solydxk.com testing/updates/contrib Translation-en_US
INFO      Ign http://debian.solydxk.com testing/updates/contrib Translation-en
INFO      Ign http://debian.solydxk.com testing/updates/main Translation-en_US
INFO      Ign http://debian.solydxk.com testing/updates/main Translation-en
INFO      Ign http://debian.solydxk.com testing/updates/non-free Translation-en_US
INFO      Ign http://debian.solydxk.com testing/updates/non-free Translation-en
INFO      Reading package lists... Done
INFO      Command finished (pid=7038, nid=umrefresh)
Terminal execute command: dpkg --configure -a; DEBIAN_FRONTEND=gnome apt-get --assume-yes -o Dpkg::Options::=--force-confdef -o Dpkg::Options::=--force-confold --force-yes -f install; apt-get update
Command to execute: apt-show-versions -i
Create list store eval string: Gtk.ListStore(bool, str, str, str, int, int)
First item is column name (multi-column list): 
First item is column name (multi-column list): Package
First item is column name (multi-column list): Installed
First item is column name (multi-column list): Available
Create column names: ['', 'Package', 'Installed', 'Available']
First item is column name: skip first item
Create column: Gtk.TreeViewColumn("", Gtk.CellRendererToggle(), active=0)
Column added: 
Create column: Gtk.TreeViewColumn("Package", Gtk.CellRendererText(), text=1, weight=4, size=5)
Column added: Package
Create column: Gtk.TreeViewColumn("Installed", Gtk.CellRendererText(), text=2, weight=4, size=5)
Column added: Installed
Create column: Gtk.TreeViewColumn("Available", Gtk.CellRendererText(), text=3, weight=4, size=5)
Column added: Available
Create list store eval string: Gtk.ListStore(str, int, int)
First item is column name (multi-column list): 
Create column names: ['']
First item is column name: skip first item
Create column: Gtk.TreeViewColumn("", Gtk.CellRendererText(), text=0, weight=1, size=2)
Column added: 
Command to execute: env LANG=C bash -c 'apt-show-versions'
up=2014.07.15
up=2014.10.15
Command to execute: env LANG=C bash -c 'apt-get dist-upgrade --assume-no'
Create list store eval string: Gtk.ListStore(str, str, str, int, int)
First item is column name (multi-column list): Package
First item is column name (multi-column list): Current version
First item is column name (multi-column list): New version
Create column names: ['Package', 'Current version', 'New version']
First item is column name: skip first item
Create column: Gtk.TreeViewColumn("Package", Gtk.CellRendererText(), text=0, weight=3, size=4)
Column added: Package
Create column: Gtk.TreeViewColumn("Current version", Gtk.CellRendererText(), text=1, weight=3, size=4)
Column added: Current version
Create column: Gtk.TreeViewColumn("New version", Gtk.CellRendererText(), text=2, weight=3, size=4)
Column added: New version
show URL: http://home.solydxk.com/umfiles/prd/update-pack.html
Command to execute: apt-get --assume-no upgrade
So your thread gets the attention it deserves later on.

Re: Problems after upgrading to 2.4.3

Posted: 26 Oct 2014 20:07
by Deleted User 855
rokytnji wrote:Making this easier

So your thread gets the attention it deserves later on.
Thanks. I hope someone can help. Everything I go to do, I find something else that isn't working. I don't think it's really completing the update but don't know how to make it continue.

Re: Problems after upgrading to 2.4.3

Posted: 27 Oct 2014 10:57
by MAYBL8
I'm getting this:

Code: Select all

dcihon@solydk64 / $ updatemanager

** (updatemanager:13801): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Traceback (most recent call last):
  File "/usr/bin/updatemanager", line 119, in <module>
    showMsg(title, msg)
  File "/usr/bin/updatemanager", line 98, in showMsg
    dialog.set_icon_from_name("update-manager")
AttributeError: 'MessageDialog' object has no attribute 'set_icon_from_name'

Re: Problems after upgrading to 2.4.3

Posted: 27 Oct 2014 11:09
by zerozero
LNXlady wrote:
rokytnji wrote:Making this easier

So your thread gets the attention it deserves later on.
Thanks. I hope someone can help. Everything I go to do, I find something else that isn't working. I don't think it's really completing the update but don't know how to make it continue.
Hi
can you, please, provide us the terminal outputs of

Code: Select all

inxi -r; apt-show-versions -u

Code: Select all

apt dist-upgrade

Re: Problems after upgrading to 2.4.3

Posted: 27 Oct 2014 13:08
by Deleted User 855
zerozero wrote: Hi
can you, please, provide us the terminal outputs of

Code: Select all

inxi -r; apt-show-versions -u

Code: Select all

apt dist-upgrade

Code: Select all

@solydk ~ $ inxi -r; apt-show-versions -u
Repos:     Active apt sources in file: /etc/apt/sources.list
           deb http://packages.solydxk.com/production/ solydxk main upstream import kdenext
           deb http://debian.solydxk.com/production/ testing main contrib non-free
           deb http://debian.solydxk.com/production/multimedia/ testing main non-free
           deb http://debian.solydxk.com/security/ testing/updates main contrib non-free
           deb http://community.solydxk.com/production/ solydxk main
audacity:i386/testing 2.0.5-2 upgradeable to 2.0.5-2+b1
dolphin:i386/testing 4:4.12.4-90r0+b8 upgradeable to 4:4.14.1-1
ffmpeg:i386/testing 10:2.2.4-dmo1 upgradeable to 10:2.4.1-dmo1
libstreamanalyzer0:i386/testing 0.7.8-1.2 upgradeable to 0.7.8-1.2+b2
libstreams0:i386/testing 0.7.8-1.2 upgradeable to 0.7.8-1.2+b2

Code: Select all

@solydk ~ $ apt dist-upgrade
[sudo] password for : 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... The following packages were automatically installed and are no longer required:
  libbalooqueryparser4 libepub0 libpostproc53 libswresample1
Use 'apt-get autoremove' to remove them.
Done
The following NEW packages will be installed:
  libpostproc53 libswresample1
The following packages have been kept back:
  audacity dolphin ffmpeg libstreamanalyzer0 libstreams0
0 upgraded, 2 newly installed, 0 to remove and 5 not upgraded.
Need to get 197 kB of archives.
After this operation, 625 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://debian.solydxk.com/production/multimedia/ testing/main libpostproc53 i386 10:2.4.1-dmo1 [96.2 kB]
Get:2 http://debian.solydxk.com/production/multimedia/ testing/main libswresample1 i386 10:2.4.1-dmo1 [100 kB]
Fetched 197 kB in 0s (231 kB/s)         
Selecting previously unselected package libpostproc53:i386.
(Reading database ... 282659 files and directories currently installed.)
Preparing to unpack .../libpostproc53_10%3a2.4.1-dmo1_i386.deb ...
Unpacking libpostproc53:i386 (10:2.4.1-dmo1) ...
Selecting previously unselected package libswresample1:i386.
Preparing to unpack .../libswresample1_10%3a2.4.1-dmo1_i386.deb ...
Unpacking libswresample1:i386 (10:2.4.1-dmo1) ...
Setting up libpostproc53:i386 (10:2.4.1-dmo1) ...
Setting up libswresample1:i386 (10:2.4.1-dmo1) ...
Processing triggers for libc-bin (2.19-11) ...

Re: Problems after upgrading to 2.4.3

Posted: 27 Oct 2014 13:37
by zerozero
i think we have 2 different problems here:

Code: Select all

The following packages have been kept back:
  audacity dolphin ffmpeg libstreamanalyzer0 libstreams0
audacity and ffmpeg are being kept back for (probably) the same reason and (probably also) a different one from dolphin.

let's try to see further

Code: Select all

sudo apt-get -s install audacity

Code: Select all

sudo apt-get -s install dolphin

Code: Select all

sudo apt-get -s install ffmpeg

Re: Problems after upgrading to 2.4.3

Posted: 27 Oct 2014 15:13
by Deleted User 855
zerozero wrote:i think we have 2 different problems here:

Code: Select all

The following packages have been kept back:
  audacity dolphin ffmpeg libstreamanalyzer0 libstreams0
audacity and ffmpeg are being kept back for (probably) the same reason and (probably also) a different one from dolphin.
let's try to see further

Code: Select all

sudo apt-get -s install audacity

Code: Select all

sudo apt-get -s install dolphin

Code: Select all

sudo apt-get -s install ffmpeg
Hmmm, not good.

Code: Select all

@solydk ~ $ sudo apt-get -s install audacity
[sudo] password for : 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 audacity : Depends: libavformat56 (>= 6:11~beta1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
@solydk ~ $ sudo apt-get -s install dolphin
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 dolphin : Depends: libbaloowidgets4 (>= 4:4.13.2) but it is not going to be installed
           Depends: libkfilemetadata4 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
@solydk ~ $ sudo apt-get -s install ffmpeg
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ffmpeg : Depends: libavcodec56 (>= 10:2.4.1) but it is not going to be installed
          Depends: libavdevice56 (>= 10:2.4.1) but it is not going to be installed
          Depends: libavfilter5 (>= 10:2.4.1) but it is not going to be installed
          Depends: libavformat56 (>= 10:2.4.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Re: Problems after upgrading to 2.4.3

Posted: 27 Oct 2014 15:15
by Deleted User 855
Lots of other stuff not working here, too. GIMP seems to be missing completely, KAlarm isn't working, printers are gone and I can't readd them, doesn't recognize USB devices etc.

Re: Problems after upgrading to 2.4.3

Posted: 28 Oct 2014 11:36
by zerozero
sorry for the delay :roll:

2 things:

1. check the output of

Code: Select all

file /tmp
if it says

Code: Select all

/tmp: symbolic link to '/var/tmp'
you need to do this

Code: Select all

sudo rm /tmp
sudo mv /var/tmp /tmp
sudo mkdir -m 1777 /var/tmp
sudo reboot
2. post the output of

Code: Select all

apt policy libavcodec56 libavcodec-extra-56
sudo apt-get -s install libavcodec56

Re: Problems after upgrading to 2.4.3

Posted: 28 Oct 2014 14:05
by Deleted User 855
zerozero wrote:sorry for the delay :roll:

2 things:

1. check the output of

Code: Select all

file /tmp
if it says

Code: Select all

/tmp: symbolic link to '/var/tmp'
you need to do this

Code: Select all

sudo rm /tmp
sudo mv /var/tmp /tmp
sudo mkdir -m 1777 /var/tmp
sudo reboot
2. post the output of

Code: Select all

apt policy libavcodec56 libavcodec-extra-56
sudo apt-get -s install libavcodec56
It did say the symbolic link thing so I ran those codes. Here is the output of the #2 codes:

Code: Select all

@solydk ~ $ apt policy libavcodec56 libavcodec-extra-56
libavcodec56:
  Installed: (none)
  Candidate: 10:2.4.1-dmo1
  Version table:
     10:2.4.1-dmo1 0
        500 http://debian.solydxk.com/production/multimedia/ testing/main i386 Packages
        100 /var/lib/dpkg/status
     6:11-1 0
        500 http://debian.solydxk.com/production/ testing/main i386 Packages
libavcodec-extra-56:
  Installed: 6:11-1
  Candidate: 6:11-1
  Version table:
 *** 6:11-1 0
        500 http://debian.solydxk.com/production/ testing/main i386 Packages
        100 /var/lib/dpkg/status
@solydk ~ $ sudo apt-get -s install libavcodec56
[sudo] password for : 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following package was automatically installed and is no longer required:
  libpostproc53
Use 'apt-get autoremove' to remove it.
The following packages will be REMOVED:
  libavcodec-extra-56
The following NEW packages will be installed:
  libavcodec56
0 upgraded, 1 newly installed, 1 to remove and 5 not upgraded.
Remv libavcodec-extra-56 [6:11-1] [libmediastreamer-base3:i386 libasound2-plugins:i386 ]
Inst libavcodec56 (10:2.4.1-dmo1 SolydXK:1/testing [i386])
Conf libavcodec56 (10:2.4.1-dmo1 SolydXK:1/testing [i386])
The update icon is still showing updates needed. Should I try the updater again now?
*ETA: Tried it, still not working.

Re: Problems after upgrading to 2.4.3

Posted: 28 Oct 2014 23:33
by zerozero
LNXlady wrote:It did say the symbolic link thing so I ran those codes.
ok, now the problem that you mentioned here
LNXlady wrote: printers are gone and I can't readd them
should be fixed.
LNXlady wrote:The update icon is still showing updates needed. Should I try the updater again now?
*ETA: Tried it, still not working.
we used the -s switch in the command above: it's just a simulation to look&see what might happen without performing actual changes to the system.
now we know a bit more.
please issue the same command but this time for real (removing the -s switch)

Code: Select all

sudo apt-get install libavcodec56
now, let's see what was removed because of this problem (gimp for sure but anything else?)
post the output of

Code: Select all

cat /var/log/apt/history.log | grep Remove

Re: Problems after upgrading to 2.4.3

Posted: 29 Oct 2014 01:01
by Deleted User 855
zerozero wrote: post the output of

Code: Select all

cat /var/log/apt/history.log | grep Remove

Code: Select all

@solydk ~ $ cat /var/log/apt/history.log | grep Remove
Remove: browser-plugin-vlc:i386 (2.0.6-2)
Remove: libffmpegthumbnailer4:i386 (2.0.8-dmo4), libchromaprint0:i386 (1.2-dmo2), libxine2-x:i386 (1.2.6-dmo3), libwxsvg3:i386 (1.5-dmo2), mjpegtools:i386 (2.1.0-dmo2), gimp:i386 (2.8.10-1), phonon-backend-vlc:i386 (0.8.0-dmo2), browser-plugin-vlc:i386 (2.0.6-4), liblavfile-2.1-0:i386 (2.1.0-dmo2), libxine2-ffmpeg:i386 (1.2.6-dmo3), ffmpegthumbnailer:i386 (2.0.8-dmo4), xine-ui:i386 (0.99.9-dmo1), liblavplay-2.1-0:i386 (2.1.0-dmo2), transcode:i386 (1.1.7-dmo6), liblavfile-2.0-0:i386 (2.0.0-dmo6), libgegl-0.2-0:i386 (0.2.0-dmo4), vlc-plugin-notify:i386 (2.2.0~pre3-dmo3), liblavplay-2.0-0:i386 (2.0.0-dmo6), vlc:i386 (2.2.0~pre3-dmo3), dvdstyler:i386 (2.8-dmo2), libquicktime2:i386 (1.2.4-dmo6), bombono-dvd:i386 (1.2.2-dmo7), libavformat56:i386 (2.4.1-dmo1), libavcodec56:i386 (2.4.1-dmo1), minidlna:i386 (1.1.4-dmo2), vlc-nox:i386 (2.2.0~pre3-dmo3)
Remove: digikam-private-libs:i386 (4.0.0-1+b2), libopencv-contrib2.4:i386 (2.4.8+dfsg1-2.2), amarok:i386 (2.8.0-2+b1), libvtv0:i386 (4.9.0-7), libmarblewidget18:i386 (4.13.1-2), libopencv-objdetect2.4:i386 (2.4.8+dfsg1-2.2), libquazip0:i386 (0.5.1-2), libopencv-calib3d2.4:i386 (2.4.8+dfsg1-2.2), kipi-plugins:i386 (4.0.0-1+b2), sysvinit-core:i386 (2.88dsf-53.2), libopencv-legacy2.4:i386 (2.4.8+dfsg1-2.2), python-opencv:i386 (2.4.8+dfsg1-2.2), libopencv-features2d2.4:i386 (2.4.8+dfsg1-2.2), libperl5.18:i386 (5.18.2-4), digikam:i386 (4.0.0-1+b2), libopencv-highgui2.4:i386 (2.4.8+dfsg1-2.2), nepomuk-core-runtime:i386 (4.12.4-90r0), libkontactinterface4:i386 (4.12.4-90r0+b8)
Remove: digikam-private-libs:i386 (4.0.0-1+b2), libopencv-contrib2.4:i386 (2.4.8+dfsg1-2.2), amarok:i386 (2.8.0-2+b1), libvtv0:i386 (4.9.0-7), libmarblewidget18:i386 (4.13.1-2), libopencv-objdetect2.4:i386 (2.4.8+dfsg1-2.2), libquazip0:i386 (0.5.1-2), libopencv-calib3d2.4:i386 (2.4.8+dfsg1-2.2), kipi-plugins:i386 (4.0.0-1+b2), sysvinit-core:i386 (2.88dsf-53.2), libopencv-legacy2.4:i386 (2.4.8+dfsg1-2.2), python-opencv:i386 (2.4.8+dfsg1-2.2), libopencv-features2d2.4:i386 (2.4.8+dfsg1-2.2), libperl5.18:i386 (5.18.2-4), digikam:i386 (4.0.0-1+b2), libopencv-highgui2.4:i386 (2.4.8+dfsg1-2.2), nepomuk-core-runtime:i386 (4.12.4-90r0), libkontactinterface4:i386 (4.12.4-90r0+b8)
Remove: libxine2-bin:i386 (1.2.6-dmo3), libswresample1:i386 (2.4.1-dmo1), libmwaw-0.2-2:i386 (0.2.1-1), libfreehand-0.0-0:i386 (0.0.0-3), libwxgtk-webview3.0-0:i386 (3.0.1-3), dvdstyler-data:i386 (2.8-dmo2), libfame-0.9-1:i386 (0.9.1-dmo1), libxine2-misc-plugins:i386 (1.2.6-dmo3), libsord-0-0:i386 (0.12.2~dfsg0-1), libaubio4:i386 (0.4.1-2+b1), liblivemedia32:i386 (2014.05.27-dmo1), liblivemedia36:i386 (2014.09.11-dmo1), libqtgstreamer-0.10-0:i386 (0.10.2-2.1), libxml++2.6-2:i386 (2.36.0-2.1), libwxsvg2:i386 (1.4-dmo1), liblilv-0-0:i386 (0.20.0~dfsg0-1), bombono-dvd-data:i386 (1.2.2-dmo7), multimedia-tasks:i386 (0.2), libconfig++9:i386 (1.4.9-2), libsuil-0-0:i386 (0.8.2~dfsg0-1), libx265-21:i386 (1.1-dmo1), libetonyek-0.0-0:i386 (0.0.4-2), python3-software-properties:i386 (0.92.25debian1), libvamp-sdk2:i386 (2.5-dmo5), dvdauthor:i386 (0.7.0-1.2+b1), librubberband2:i386 (1.8.1-5), python-fpconst:i386 (0.7.2-5), libsratom-0-0:i386 (0.4.6~dfsg0-1), libav-tools:i386 (2.2.4-dmo1), libakonadi-xml4:i386 (4.14.1-1), libraptor1:i386 (1.4.21-11), libokularcore4:i386 (4.13.1-2), libepub0:i386 (0.2.2-4), xjadeo:i386 (0.7.7-1), mkvtoolnix:i386 (7.1.0-1), libqmi-glib0:i386 (1.4.0-1), linux-headers-3.14-1-common:i386 (3.14.12-1), liblo7:i386 (0.28-3), libpostproc53:i386 (2.4.1-dmo1), linux-image-3.14-1-486:i386 (3.14.12-1), mikmod:i386 (3.2.6-1), libqtglib-2.0-0:i386 (0.10.2-2.1), linux-headers-3.14-1-486:i386 (3.14.12-1), libshine3:i386 (3.1.0-2), libffado2:i386 (2.2.1-2), libva-drm1:i386 (1.3.1-3), libmbim-glib0:i386 (1.8.0-1), libodfgen-0.0-0:i386 (0.0.4-2), linux-image-3.14-2-486:i386 (3.14.13-2), libltc11:i386 (1.1.4-1), linux-image-3.14-1-686-pae:i386 (3.14.12-1), linux-headers-3.14-2-486:i386 (3.14.13-2), liborcus-0.6-0:i386 (0.5.1-8+b1), liblrdf0:i386 (0.4.0-5), libusageenvironment2:i386 (2014.09.11-dmo1), libdc1394-utils:i386 (2.2.2-3), libpoppler44:i386 (0.24.5-4), libqtgstreamerutils-0.10-0:i386 (0.10.2-2.1), libabw-0.0-0:i386 (0.0.2-3), mpg123:i386 (1.20.1-2), software-properties-common:i386 (0.92.25debian1), libserd-0-0:i386 (0.20.0~dfsg1-1), libe-book-0.0-0:i386 (0.0.3-2), libgnomecanvasmm-2.6-1c2a:i386 (2.26.0-1), linux-headers-3.14-1-686-pae:i386 (3.14.12-1), scons:i386 (2.3.1-1), libimlib2:i386 (1.4.6-2+b1), liboil0.3:i386 (0.3.17-2)
Remove: libavcodec-extra-56:i386 (11-1)

Re: Problems after upgrading to 2.4.3

Posted: 30 Oct 2014 01:50
by zerozero
ok, so far that i can see the app/lib that are missing (and there are some) are
gimp
phonon-backend-vlc
bombono-dvd
vlc
amarok
kipi-plugins
nepomuk-core-runtime
digikam
software-properties-common
mpg123
browser-plugin-vlc
xine-ui
transcode
dvdstyler
minidlna
you should try to install them with

Code: Select all

sudo apt-get install --reinstall <packagename>
do not ry to reinstall everything that you see in the list you provided me earlier; some of them should remain removed (the old kernel, sysvinit)
the list i gave you above is (i think) the basics.

===
after you complete this "task :) " there is (if memory serves me well) one last item to tackle: dolphin.

but before we get to it (and once you finish reinstalling the software that was removed) give us the output of

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade

Re: Problems after upgrading to 2.4.3

Posted: 30 Oct 2014 21:30
by Deleted User 855
zerozero wrote: ===
after you complete this "task :) " there is (if memory serves me well) one last item to tackle: dolphin.

but before we get to it (and once you finish reinstalling the software that was removed) give us the output of

Code: Select all

sudo apt-get update && sudo apt-get dist-upgrade
Thanks for your help with this. I've gotten those things reintalled. I hate upgrading because it never goes smoothly. That's why I switched to Solydk, because it was a rolling release. I guess it isn't going to be one anymore, though?

Code: Select all

@solydk ~ $     sudo apt-get update && sudo apt-get dist-upgrade [sudo] password for :  Get:1 http://packages.solydxk.com solydxk InRelease [14.1 kB] Get:2 http://debian.solydxk.com testing InRelease [7,700 B]                 Hit http://community.solydxk.com solydxk InRelease Hit http://debian.solydxk.com testing InRelease       Get:3 http://packages.solydxk.com solydxk/main i386 Packages [38.0 kB]    Hit http://debian.solydxk.com testing/updates InRelease                     Hit http://community.solydxk.com solydxk/main i386 Packages                 Get:4 http://debian.solydxk.com testing/main i386 Packages [9,001 kB]       Hit http://packages.solydxk.com solydxk/upstream i386 Packages              Hit http://packages.solydxk.com solydxk/import i386 Packages                Hit http://packages.solydxk.com solydxk/kdenext i386 Packages               Ign http://community.solydxk.com solydxk/main Translation-en_US             Ign http://community.solydxk.com solydxk/main Translation-en                Ign http://packages.solydxk.com solydxk/import Translation-en_US Ign http://packages.solydxk.com solydxk/import Translation-en Ign http://packages.solydxk.com solydxk/kdenext Translation-en_US Ign http://packages.solydxk.com solydxk/kdenext Translation-en Ign http://packages.solydxk.com solydxk/main Translation-en_US              Ign http://packages.solydxk.com solydxk/main Translation-en                 Ign http://packages.solydxk.com solydxk/upstream Translation-en_US          Ign http://packages.solydxk.com solydxk/upstream Translation-en             Hit http://debian.solydxk.com testing/contrib i386 Packages                 Hit http://debian.solydxk.com testing/non-free i386 Packages                Hit http://debian.solydxk.com testing/main i386 Packages                    Hit http://debian.solydxk.com testing/non-free i386 Packages                Hit http://debian.solydxk.com testing/updates/main i386 Packages            Hit http://debian.solydxk.com testing/updates/contrib i386 Packages         Hit http://debian.solydxk.com testing/updates/non-free i386 Packages        Ign http://debian.solydxk.com testing/contrib Translation-en_US             Ign http://debian.solydxk.com testing/contrib Translation-en                Ign http://debian.solydxk.com testing/main Translation-en_US                Ign http://debian.solydxk.com testing/main Translation-en                   Ign http://debian.solydxk.com testing/non-free Translation-en_US            Ign http://debian.solydxk.com testing/non-free Translation-en               Ign http://debian.solydxk.com testing/main Translation-en_US                Ign http://debian.solydxk.com testing/main Translation-en                   Ign http://debian.solydxk.com testing/non-free Translation-en_US            Ign http://debian.solydxk.com testing/non-free Translation-en               Ign http://debian.solydxk.com testing/updates/contrib Translation-en_US     Ign http://debian.solydxk.com testing/updates/contrib Translation-en        Ign http://debian.solydxk.com testing/updates/main Translation-en_US        Ign http://debian.solydxk.com testing/updates/main Translation-en           Ign http://debian.solydxk.com testing/updates/non-free Translation-en_US    Ign http://debian.solydxk.com testing/updates/non-free Translation-en       Fetched 9,061 kB in 35s (256 kB/s)                                          Reading package lists... Done Reading package lists... Done Building dependency tree        Reading state information... Done Calculating upgrade... The following packages were automatically installed and are no longer required:   libavdevice55 libavfilter4 Use 'apt-get autoremove' to remove them. Done The following NEW packages will be installed:   libavdevice56 libavfilter5 libbalooqueryparser4 libbaloowidgets4   libkfilemetadata4 The following packages will be upgraded:   audacity dolphin ffmpeg libstreamanalyzer0 libstreams0   solydk-system-adjustments solydxk-system 7 upgraded, 5 newly installed, 0 to remove and 0 not upgraded. Need to get 5,969 kB of archives. After this operation, 4,383 kB of additional disk space will be used. Do you want to continue? [Y/n] y Get:1 http://packages.solydxk.com/production/ solydxk/main solydxk-system all 1.2.6 [28.6 kB] Get:2 http://debian.solydxk.com/production/multimedia/ testing/main libavfilter5 i386 10:2.4.1-dmo1 [752 kB] Get:3 http://packages.solydxk.com/production/ solydxk/main solydk-system-adjustments all 1.3.4 [42.9 kB] Get:4 http://debian.solydxk.com/production/multimedia/ testing/main libavdevice56 i386 10:2.4.1-dmo1 [117 kB] Get:5 http://debian.solydxk.com/production/ testing/main audacity i386 2.0.5-2+b1 [2,005 kB] Get:6 http://debian.solydxk.com/production/ testing/main libbalooqueryparser4 i386 4:4.14.1-1 [42.7 kB] Get:7 http://debian.solydxk.com/production/ testing/main libkfilemetadata4 i386 4:4.14.0-1+b2 [68.8 kB] Get:8 http://debian.solydxk.com/production/ testing/main libbaloowidgets4 i386 4:4.14.0-1 [64.0 kB] Get:9 http://debian.solydxk.com/production/ testing/main dolphin i386 4:4.14.1-1 [1,230 kB] Get:10 http://debian.solydxk.com/production/multimedia/ testing/main ffmpeg i386 10:2.4.1-dmo1 [1,213 kB] Get:11 http://debian.solydxk.com/production/ testing/main libstreamanalyzer0 i386 0.7.8-1.2+b2 [306 kB]                                                  Get:12 http://debian.solydxk.com/production/ testing/main libstreams0 i386 0.7.8-1.2+b2 [98.2 kB]                                                        Fetched 5,969 kB in 24s (243 kB/s)                                           Reading changelogs... Done                                                   Selecting previously unselected package libavfilter5:i386.                   (Reading database ... 284831 files and directories currently installed.)     Preparing to unpack .../libavfilter5_10%3a2.4.1-dmo1_i386.deb ...            Unpacking libavfilter5:i386 (10:2.4.1-dmo1) ...                              Selecting previously unselected package libavdevice56:i386.                  Preparing to unpack .../libavdevice56_10%3a2.4.1-dmo1_i386.deb ...           Unpacking libavdevice56:i386 (10:2.4.1-dmo1) ...                             Preparing to unpack .../audacity_2.0.5-2+b1_i386.deb ...                     Unpacking audacity (2.0.5-2+b1) over (2.0.5-2) ...                           Selecting previously unselected package libbalooqueryparser4.                Preparing to unpack .../libbalooqueryparser4_4%3a4.14.1-1_i386.deb ...       Unpacking libbalooqueryparser4 (4:4.14.1-1) ...                              Selecting previously unselected package libkfilemetadata4.                   Preparing to unpack .../libkfilemetadata4_4%3a4.14.0-1+b2_i386.deb ...       Unpacking libkfilemetadata4 (4:4.14.0-1+b2) ... Selecting previously unselected package libbaloowidgets4. Preparing to unpack .../libbaloowidgets4_4%3a4.14.0-1_i386.deb ... Unpacking libbaloowidgets4 (4:4.14.0-1) ... Preparing to unpack .../dolphin_4%3a4.14.1-1_i386.deb ... Unpacking dolphin (4:4.14.1-1) over (4:4.12.4-90r0+b8) ... Preparing to unpack .../ffmpeg_10%3a2.4.1-dmo1_i386.deb ... Unpacking ffmpeg (10:2.4.1-dmo1) over (10:2.2.4-dmo1) ... Preparing to unpack .../libstreamanalyzer0_0.7.8-1.2+b2_i386.deb ... Unpacking libstreamanalyzer0 (0.7.8-1.2+b2) over (0.7.8-1.2) ... Preparing to unpack .../libstreams0_0.7.8-1.2+b2_i386.deb ... Unpacking libstreams0 (0.7.8-1.2+b2) over (0.7.8-1.2) ... Preparing to unpack .../solydxk-system_1.2.6_all.deb ... Unpacking solydxk-system (1.2.6) over (1.2.5) ... Preparing to unpack .../solydk-system-adjustments_1.3.4_all.deb ... Unpacking solydk-system-adjustments (1.3.4) over (1.3.3) ... dpkg: warning: solydk-system-adjustments: config file 'etc/skel/.gtkrc-2.0' is a circular link  (= '/etc/skel/.gtkrc-2.0-kde4') Processing triggers for mime-support (3.56) ... Processing triggers for menu (2.1.47) ... Processing triggers for man-db (2.6.7.1-1) ... Processing triggers for desktop-file-utils (0.22-1) ... Processing triggers for hicolor-icon-theme (0.13-1) ... Setting up libavfilter5:i386 (10:2.4.1-dmo1) ... Setting up libavdevice56:i386 (10:2.4.1-dmo1) ... Setting up audacity (2.0.5-2+b1) ... Setting up libbalooqueryparser4 (4:4.14.1-1) ... Setting up libkfilemetadata4 (4:4.14.0-1+b2) ... Setting up libbaloowidgets4 (4:4.14.0-1) ... Setting up dolphin (4:4.14.1-1) ... Setting up ffmpeg (10:2.4.1-dmo1) ... Installing new version of config file /etc/ffserver.conf ... Setting up libstreams0 (0.7.8-1.2+b2) ... Setting up libstreamanalyzer0 (0.7.8-1.2+b2) ... Setting up solydxk-system (1.2.6) ... Installing new version of config file /etc/apt/apt.conf.d/80solydxk-apt ... snd-hda-intel model already set pcspkr already blacklisted Setting up solydk-system-adjustments (1.3.4) ... dpkg: warning: solydk-system-adjustments: config file '/etc/skel/.gtkrc-2.0' is a circular link  (= '/etc/skel/.gtkrc-2.0-kde4') Processing triggers for libc-bin (2.19-11) ... Processing triggers for menu (2.1.47) ... melisa@solydk ~ $                                                                              

Re: Problems after upgrading to 2.4.3

Posted: 31 Oct 2014 10:05
by zerozero
great news :D this last command sorted out the last issues

Code: Select all

The following NEW packages will be installed:   
libavdevice56 libavfilter5 libbalooqueryparser4 libbaloowidgets4   libkfilemetadata4 
The following packages will be upgraded:   
audacity dolphin ffmpeg libstreamanalyzer0 libstreams0   solydk-system-adjustments solydxk-system 
7 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
as far as i can see the system is now OK.

===
LNXlady wrote:I hate upgrading because it never goes smoothly. That's why I switched to Solydk, because it was a rolling release.
this is kind of a contradiction :P
rolling releases by definition have to be updated and frequently.
sometimes those needed updates can be disruptive as they were for you now. it comes with the "package" of running a rolling release.

with the upcoming changes you will have a choice: a true rolling release model or a stable, non-disruptive release.

Re: Problems after upgrading to 2.4.3

Posted: 31 Oct 2014 12:54
by Deleted User 855
After a week of not being able to get any work done, I am happy to have the desktop pc up and running again with your help. My laptop also didn't like the upgrade but since I couldn't be without any computer for this long, I put another distro on there to use in the meantime. Happy to have Solydk back in use. Thanks very much for your help.

Re: Problems after upgrading to 2.4.3 [SOLVED]

Posted: 01 Nov 2014 00:10
by zerozero
when you can't afford downtime with your system, the present Business Editions and future Stable editions are (IMO) better options.

Re: Problems after upgrading to 2.4.3 [SOLVED]

Posted: 01 Nov 2014 12:23
by Zill
zerozero wrote:when you can't afford downtime with your system, the present Business Editions and future Stable editions are (IMO) better options.
+1

Excellent advice for all current and future SolydXK users.

Re: Problems after upgrading to 2.4.3 [SOLVED]

Posted: 01 Nov 2014 13:35
by Deleted User 855
zerozero wrote:when you can't afford downtime with your system, the present Business Editions and future Stable editions are (IMO) better options.
The Stable edition is the one I'm being moved to automatically, right?