[pseudo-Solved] Kernel 3.16 in SolydX 32bits Jessie

Questions about SolydX and SolydK installation.
tacos40
Posts: 52
Joined: 14 Jul 2014 14:35
Location: Spain

[pseudo-Solved] Kernel 3.16 in SolydX 32bits Jessie

Postby tacos40 » 30 Mar 2015 00:00

Hello everybody :-)

I have upgraded recently SolydX 32bits in old PC (1 procesor) to HE / Jessie, almost without issue. It had 2014/dec Solydx.
I would say it is 100% upgraded and updated, 2015/march/30 hehe :-) . Basic steps/command below, if useful (*)

It seems all is working correctly... except the Kernel 3.16.0.4-586 (old PC, no PAE) and I am forced to use old kernel 3.14-2-486 . I dont know how important it is, so any comment welcome about 3.14 vs 3.16. I would like to solve the issue, if possible.

Symptoms: When booting default (linux-image 3.16) it seems all ok, but at some point Screen corrupts / start to blink.
In the 3.16 recovery, the screen corrupts appears too, so it is of no help. I have found booting 3.14 works all OK.
VGA card is AMD/ATI (9800) but I would say it is unlikely the cause, as kernel 3.14 ... 3.13 worked without issue.

Thank you in advance for any hint / ref or troubleshooting guide. e.g. Where can I see useful logs (syslog, etc).

Best regards :-)

(*) Basic steps/commands used to upgrade and workaround minor errors:

Code: Select all

a) Edit /etc/apt/sources.list for new repositories (solydx -> jessie)
b) Update updatemanager (v2.4.5 -> v2.6.2)
c) apt-get update
d) apt-get -s dist-upgrade THEN apt-get dist-upgrade
e) dpkg-divert --list |grep artwork THEN dpkg-divert --remove ... 
f) apt-get -f -s install THEN apt-get -f install
g) some reboots, grup-pc install and finally update with updatemanager v2.6.2
h) Updated OK.

tacos40
Posts: 52
Joined: 14 Jul 2014 14:35
Location: Spain

Re: Kernel 3.16 in SolydX 32bits Jessie

Postby tacos40 » 03 Apr 2015 15:33

UPDATE: This is only informative, no solution is required:

I have "dist-upgraded" to Jessie another 32 bit SolydX laptop and behaviour was very similar to previous desktop.
Apparently without issues, except for the dpkg-divert / remove in artwork pacjkages, easy to fix once known.
Relevant details:

a) This laptop is 2 cpu (linux-3.14-2-pae) and it used to work with both cpus until upgraded. Once upgraded it can
only work with linux-3.14-2 (non-pae, so 1 cpu :-( ). There is no way it to work with 3.16 (pae or non-pae)

b) This laptop had a functional WiFi connection. Once upgraded, wlan0 configuration was lost and I have not found
a way to make it work again.

I assume the 32bit SolydX / Debian line is broken (unreliable) so I will look for an alternative; I'm very sad,
as I did like this distribution in laptop (I had the Samrigg X men wallpaper :-) ).

The 64bit is OK (in other laptops / desktops) :-) <--- UEFI and MBR

User avatar
grizzler
Posts: 2197
Joined: 04 Mar 2013 15:45
Location: The Hague, NL

Re: [pseudo-Solved] Kernel 3.16 in SolydX 32bits Jessie

Postby grizzler » 03 Apr 2015 16:49

Newer kernels in old machines, I've seen that go wrong as well myself (although not recently - my nine year old laptop with AMD/ATI Radeon 9600 has no issues with 3.16.0-4-586 from the latest SolydX 32 and WiFi is working like a charm...).

I didn't find anything useful on the web after your first message, so I didn't reply. Apparently nobody else has any suggestion either...
Frank

SolydX EE 64 - tracking Debian Testing

tacos40
Posts: 52
Joined: 14 Jul 2014 14:35
Location: Spain

Re: [pseudo-Solved] Kernel 3.16 in SolydX 32bits Jessie

Postby tacos40 » 03 Apr 2015 22:41

Grizzler: Thank you very much for your generosity :-)
This attitude in forum is one of the things I like of SolydXK!

About the kernel: The weird detail in this case is that... kernel 3.14-2 "pae" (dual CPU)...

- ...used to work like a charm before upgrading (easy to verify with gnome-system-monitor)
- ... stopped working after upgrading : the very same kernel 3.14-2 "pae"

About the wireless: It's just one more thing noticeable upon upgrading; I'm sure I can fix it, but there is no point to spend more time with current 32 bits / debian, as packages and/or upgrading logic as such, are not "tested enough". Maybe a logical consequence: "Jessie/testing" is *not* aimed at old PC; "elder entities prefer stable things" :-)

Another detail: the VGA card is of no importance for this issue with kernels (upon upgrading):

- Desktop, 1 cpu, ATI Radeon 9800: black/blinking characters on screen crash
- Laptop, 2 cpu, built-in VGA card (Intel): black/blinking pixels on screen crash

I assume there is something missing in the upgrading logic; or, on the contrary, something extra it shouldn't be there.


Return to “Installation”

Who is online

Users browsing this forum: No registered users and 3 guests