Page 1 of 1

First Impressions

Posted: 17 Jul 2015 21:54
by Bubble
Obviously the look and feel of a distro need to offer enough to temp one to persevere.

The first prerequisite for any distro is that it works - preferably OOTB - across my (six) machines which mostly have old(er) hardware. The most likely and important sticking points are usually graphics and wifi but so long as the a liveusb (created by Unetbootin) boots to something useable I am willing to pursue the trials if sufficiently encouraged enough to install, then seek solutions/tweaks to resolve any glitches. This process may also test the helpfulness of the forum!

Anyway, once at the live desktop the next important encounter is with the installer which, in this case, is a pleasure. It seems to share some heritage with Mint - but without the excruiting three lengthy probes of the hdd! However, one small irritation - no uppercase permitted for hostname. Why?

1> On my Intel powered Tosh all went well so installed.

2> Next to the notebook - a Packard-Bell DotMA - which is Amd/Ati. First attempt presented me with with a 1024x768 display with no apparent means of remedying it to the correct 1366x768. Unfortunately, in Settings Manager, the Hardware section does not function in live mode. Whilst appreciating that actually pulling down the driver would be futile it would be nice to know if it was available! Anyway, tried the live usb again but this time chose the Advanced option in the belief that it would offer more possibilities. Whilst this did at least result in a correct resolution, in reality is not an "Advanced" option but just disables many "modern" features so would probably be more accurately named "Basic"! Nevertheless, I went ahead and installed but was then amused to discover that the Hardware section of SM offered drivers for the Broadcom wifi though this was working fine ootb!

3> Now to a self-build with nVidia Gforce 6200LE graphics and once again had to resort to "Advanced". At least Wifi recognised again so proceeded with install. Tried the Hardware option and was offered the correct (proprietary?) driver and after a reboot that seemed fine.

4 &5> Two identical self-builds, with on-board Ati 3000 gpu which works fine (without the need for Advanced option!). Needed to install kernel drivers for the RT2870 wifi dongle but that was to be expected.

6> Finally to the oldest machine with Ati 9550 agp graphics, TP-Link nic and Hauppauge DVB-T card. Default install option seems fine.

Further experimentation with notebook <2> and looked at the menu boot options more closely

Default > /ubnkern initrd=/ubninit boot=live config quiet splash
Start SolydX (& Start SolydX 64-bit 201506) > /live/vmlinuz initrd=/live/initrd.img boot=live config quiet splash

These are unexpectedly different so tried Start SolydX (rather than Default) and it worked perfectly! (The downside is that the desktop starts dim - similar to Mint - and needs to be brightened manually, Is there a setting somewhere?).

So returned <3> to retry with Start SolydX which seemed to proceed ok but ended in a blank screen and unresponsive to any keypresses. Looking at the list of "Advanced" boot parameters (memtest noapic noapm nodma nomce nolapic nomodeset nosmp nosplash vga=normal) to experiment by adding individually to the Start SolydX option and homed in on nomodesett (thought vga=normal might do it but not so) which seems to do the trick thus retaining power options etc. Subsequently installed nvidia driver then edited grub.cfg to remove nomodeset (though Plymouth still an issue).

During these trials I also found that checking the box to install multimedia extras is not a good idea as it coincidentally(?) resulted in the installer hanging though not necessarily at the same point. Whether I need them or not and/or can be installed retrospectively I'm not sure but at least Kaffeine seems ok with DVB-T dongle (RTL2828 supported by kernel 3.10+) and DVB-S (saa7132 also supported but needs a couple of cli set-ups to be invoked).

As another observation, I am surprised at the size of SolydX at 1.5Gb given the relatively limited amount of included software. Whilst I have no problem with that as I prefer to add the software that I want not what somebody else thinks I should have, but is nearly twice Mint13 Xfce at 800Mb which after installation of a massive amount, including virtualbox and multiple DEs, is now a 2.2Gb remaster. Similarly PCLos Kde Minime starts at 619Mb and has now reached 1.8Gb as a remaster. These remasters also include all the necessary drivers to work ootb on all my machines.

It is a pity that SolydX does not (easily) support remastering. I've looked at but that's a lot of work. It's a pity that it is not developed into a script (better still with a gui).

Similarly, for me, Xfce and Compiz are ideally suited - and feels much smoother and less demanding on resources than Kde - but Compiz is not SolydX. Again, I've read through ... win#p44446 but sledgehammers and nuts springs to mind! If one is going that far then we might as well go for the Kde edition in the first place (or install the Kde meta-package and then switch to that environment when we need our fix of desktop effects).

Finally there are oddities with the desktop icons but will pose that as a specific question in another thread.

Sorry that this is longer than intended but was sort of created as I went along as a record of my experiences of 6 trials!