SolydX RPI and solydx-system-adjustments-8

Questions about SolydX and SolydK installation.
solchris
Posts: 21
Joined: 18 Jan 2017 18:55

SolydX RPI and solydx-system-adjustments-8

Postby solchris » 26 Feb 2017 13:57

It seams that the update to get ready for stretch doesn't work correct on SolydX RPI. The package solydx-system-adjustments was marked as defect after update and reboot.
Synaptic also showed that solydx-system-adjustments-8 wasn't installed.
The SolydX icon of the whisker menu also is gone.

Afterwards I tried manually to install solydx-system-adjustments-8 and got following error message.
(System localization is german therefor understanding may be difficult)

Code: Select all

(synaptic:29558): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed
Die GTK-Oberfläche benötigt ein funktionierendes Python-gtk2 und Python-glade2.
Diese können nicht importiert werden. Falle auf Pager zurück.
Der Fehler lautet: No module named glade
(Lese Datenbank ... 130397 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../solydx-system-adjustments-8_2.6.8_all.deb ...
Entpacken von solydx-system-adjustments-8 (2.6.8) ...
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/solydx-system-adjustments-8_2.6.8_all.deb (--unpack):
 Versuch, »/etc/skel/.config/xfce4/helpers.rc« zu überschreiben, welches auch in Paket solydx-system-adjustments 2.6.4 ist
Trigger für desktop-file-utils (0.22-1) werden verarbeitet ...
Trigger für mime-support (3.58) werden verarbeitet ...
Trigger für fontconfig (2.11.0-6.3+deb8u1) werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/solydx-system-adjustments-8_2.6.8_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ein Paket konnte nicht installiert werden. Wiederherstellung wird versucht:
solydxk-system (2.4.7) wird eingerichtet ...
snd-hda-intel model already set
pcspkr already blacklisted
[Errno 2] No such file or directory: '/usr/share/solydxk/info'
evolvere-icon-theme-flat-vivid-sunken (1.2xk6) wird eingerichtet ...
evolvere-icon-theme-flat-vivid-sunken-dark (1.2xk6) wird eingerichtet ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von solydx-system-adjustments:
 solydx-system-adjustments hängt ab von solydx-system-adjustments-8; aber:
  Paket solydx-system-adjustments-8 ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes solydx-system-adjustments (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
usermanager (0.8.4) wird eingerichtet ...
pi-bluetooth (0.1.3) wird eingerichtet ...
solydxk-welcome (1.3.3) wird eingerichtet ...
Neue Version der Konfigurationsdatei /etc/xdg/autostart/solydxk-welcome.desktop wird installiert ...
initramfs-tools (0.120+deb8u2) wird eingerichtet ...
update-initramfs: deferring update (trigger activated)
lightdm-manager (0.8.0) wird eingerichtet ...
evolvere-icon-theme-additional (1.2xk6) wird eingerichtet ...
solydx-raspi-config (2017.02.06) wird eingerichtet ...
Neue Version der Konfigurationsdatei /etc/systemd/system/expandrootfs.service wird installiert ...
Created symlink from /etc/systemd/system/multi-user.target.wants/expandrootfs.service to /etc/systemd/system/expandrootfs.service.
Trigger für initramfs-tools (0.120+deb8u2) werden verarbeitet ...
ln: Die harte Verknüpfung „/boot/initrd.img-4.4.11-v7+.dpkg-bak“ => „/boot/initrd.img-4.4.11-v7+“ konnte nicht angelegt werden: Die Operation ist nicht erlaubt
update-initramfs: Generating /boot/initrd.img-4.4.11-v7+
WARNING: missing /lib/modules/4.4.11-v7+
Ensure all necessary drivers are built into the linux image!
depmod: ERROR: could not open directory /lib/modules/4.4.11-v7+: No such file or directory
depmod: FATAL: could not search modules: No such file or directory
depmod: WARNING: could not open /var/tmp/mkinitramfs_hCRqSB/lib/modules/4.4.11-v7+/modules.order: No such file or directory
depmod: WARNING: could not open /var/tmp/mkinitramfs_hCRqSB/lib/modules/4.4.11-v7+/modules.builtin: No such file or directory
Fehler traten auf beim Bearbeiten von:
 solydx-system-adjustments
May be that the main error is that update tries to overwrite "/etc/skel/.config/xfce4/helpers.rc" which is identified also as part of package "solydx-system-adjustments 2.6.4

solchris
Posts: 21
Joined: 18 Jan 2017 18:55

Re: SolydX RPI and solydx-system-adjustments-8

Postby solchris » 28 Feb 2017 13:03

Through the following steps I have achieved that everything works again

Manually reinstall solydx-system-adjustments
- package was updated from 2.6.4 to 2.6.5
- package solydx-system-adjustments-8 was installed (2.6.9) but reported errors

Manually delete solydx-system-adjustments
- package solydx-system-adjustments-8 was installed (2.6.9) without errors

Change start icon of whisker menu to the SolydX icon
- right click on the SolydX icon of the whisker menu
- select attributes
- left click on symbol
- select picture files
- select file solydx.png (/usr/share/pixmaps/soldyx.png)

User avatar
ilu
Posts: 2602
Joined: 09 Oct 2013 12:45

Re: SolydX RPI and solydx-system-adjustments-8

Postby ilu » 28 Feb 2017 16:13

Thank you for explaining where you found the correct icon, I need that as well for one system. This is a difficult time for updates - I told friends to hold off a bit.


Return to “Installation”

Who is online

Users browsing this forum: No registered users and 5 guests