[Solved] Problems with June 6 Update.

Questions about SolydX and SolydK installation.
rozen
Posts: 12
Joined: 27 Apr 2013 15:23

[Solved] Problems with June 6 Update.

Postby rozen » 09 Jun 2013 04:44

I have updated SolydX 64 bits running on a 5 year old Dell tower - XPS 410 and have so far encountered several problems.

My machine:

rozen@atlas: ~ > inxi -Fxx
System: Host atlas Kernel 3.2.0-4-amd64 x86_64 (64 bit) Distro SolydXK 1 solydxk
CPU: Dual core Intel Core2 6420 (-MCP-) cache 4096 KB flags (lm nx sse sse2 sse3 ssse3 vmx) bmips 8511.36
Clock Speeds: (1) 2127.842 MHz (2) 2127.842 MHz
Graphics: Card NVIDIA G72 [GeForce 7300 LE] X.Org 1.12.4 Res: 1920x1200@60.0hz
GLX Renderer GeForce 7300 LE/PCIe/SSE2 GLX Version 2.1.2 NVIDIA 304.88 Direct Rendering Yes
Audio: Card Intel 82801H (ICH8 Family) HD Audio Controller driver snd_hda_intel BusID: 00:1b.0
Sound: Advanced Linux Sound Architecture Version 1.0.24
Network: Card Intel 82566DC Gigabit Network Connection driver e1000e v: 1.5.1-k at port ecc0 BusID: 00:19.0
Disks: HDD Total Size: 500.1GB (27.1% used) 1: /dev/sdb WDC_WD2500JS 250.1GB 33C
2: /dev/sda ST3250820AS 250.0GB 31C
Partition: ID:/ size: 25G used: 7.3G (32%) fs: rootfs ID:/ size: 25G used: 7.3G (32%) fs: ext4
ID:swap-1 size: 2.65GB used: 0.00GB (0%) fs: swap
Sensors: System Temperatures: cpu: 48.0C mobo: N/A gpu: 0.0:58C
Fan Speeds (in rpm): cpu: N/A
Info: Processes 172 Uptime 9:29 Memory 918.6/3902.0MB Runlevel 2 Client Shell inxi 1.4.23

Problem 1: The upgrade did not update grub. I manually ran

sudo update-grub
sudo grub-install /dev/sda

Problem 2: I installed emacs24 and find that it runs just fine. However, if I try to execute

sudo emacs

I have to login anew.

sudo emacs23 works just fine. So I changed my sudo emacs alias to sudo emacs23. I use sudo emacs all over the place when manipulating configure files in /etc, etc.

Problem 3: The main menu in the panel (XFCE) entry "Log Out" consistently causes me to login anew. For a while the only way to reboot was from the command line. Could not suspend either.

Problem 4: I use Cairo-dock 3.2.1 which I built from source on the previous version of SolydX and experienced many incidents where trying to launch a program would log me out forcing a relogin and one cannot reboot from the login dialog. After trying the Logout icon in the Cairo-dock panel, I was able to reboot and suspend from that menu. I have not tried the main menu again for fear that I could not finish this posting.

Problem 5: The LibreOffice package comes up and displays a crappy illegible font; it appears to be the same lousy font displayed by wine. This is no different from LibeOffice from my previous SolydX version.

I have worked with the new update for only a short time, but will keep trying. I really don't want to go thru the customization every time I have to do a fresh install of Mint. (I tried changing my apt sources.list and doing an update but I couldn't even start the Xserver.

Anyway, I am reporting these problems in hopes it will be helpful.sudo grub-install /dev/sda

Appreciatively,
Don

rozen
Posts: 12
Joined: 27 Apr 2013 15:23

Re: Problems with June 6 Update.

Postby rozen » 09 Jun 2013 14:57

My mistake. I reported that "sudo emacs" with emacs24 caused SolydX to log me out when the real action was for emacs 24 to freeze.

Sorry,
Don

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: Problems with June 6 Update.

Postby zerozero » 09 Jun 2013 16:52

Don,
let's see what we can do about this :P

problem 1:
with this update-pack there was a few actions that required user intervention and the grub update/reinstallation was one:
- at certain point you should be prompted to select grub's new location; failing to select the correct location or skipping this step would result in a situation similar to what you describe.

problem 3:
make sure that menu > settings > settings manager > session and startup >> prompt on logout is selected

problem 5:

Code: Select all

apt install libreoffice-gtk
bliss of ignorance

rozen
Posts: 12
Joined: 27 Apr 2013 15:23

Re: Problems with June 6 Update.

Postby rozen » 10 Jun 2013 04:44

Your suggestions seem to have solved several of my problem and now I will push on.

Thanks So Much,

Don


Return to “Installation”

Who is online

Users browsing this forum: No registered users and 1 guest