Page 1 of 1

Freezes at progress login

Posted: 03 Jun 2019 18:10
by Ajile
Hello everyone, I'm new here.

I'm trying to install SolydX, but the installation process seems to stop working when it says the following:
Progress Linux 1.9 progress tty1
progress login:

I installed SolydX on my previous computer about a month ago to see if the computer issues I was having were related to Windows. SolydX worked fine, but the issues weren't solved (it probably was the power supply unit and/or the motherboard), so I bought a new computer (a HP 290 G2 3,7 GHz Intel Pentium G5400 Micro Tower PC, which is 64-bit). The installation process looks different now (the options to choose from in the UNetbootin menu are the same); I don't remember the "progress login" appearing last time and I think I saw a progress bar last time (it now shows a blinking _ or three orange blocks/dots with sometimes one being white, but little loading/change).

Does anyone have an idea what is going wrong and how I can fix it? I've already tried emptying the USB and putting SolydX on it with UNetbootin again, but the same happens.

Re: Freezes at progress login

Posted: 04 Jun 2019 10:18
by Ajile
The same thing keeps happening on my new computer which has FreeDOS pre-installed on it. It now also said "DPC containment event" nine times in a row, with "Status: 0x1f00" (I don't know what that means, Google says something about a PCIe Bus Error). This is the computer I bought: https://maxict.nl/hp-290-g2-37-ghz-inte ... 32442.html

Re: Freezes at progress login

Posted: 04 Jun 2019 11:27
by ilu
Please tell us which exact ISO file you used. One of the older ISOs or the one being currently tested (viewtopic.php?f=78&t=7537)? Did you check the ISO integrity with the checksum?
And: Does the live system work? Before you start the installation? Could you use the live system to collect some information about your hardware by posting the terminal output of inxi -Fxz ?

The "DPC containment event Status: 0x1f00" looks like this problem https://patchwork.kernel.org/patch/10112467/ which was fixed in kernel 4.16, so - if your problem was with SolydX9 - you should probably try SolydX10 / EE (which has 4.19). Download location: https://downloads.solydxk.com/ce/ee/

Re: Freezes at progress login

Posted: 04 Jun 2019 14:13
by Ajile
Thank you for the reply!

I used the solydx_9_64_201902 download from https://solydxk.com/downloads/solydx and it worked before so the integrity should be alright I think (I still had the file on my laptop). You're right, it isn't the installation, it's starting SolydX. It doesn't get to the desktop screen (where the installation button is). So I can't post hardware data that way (maybe I can by using FreeDOS).

Re: Freezes at progress login

Posted: 04 Jun 2019 14:34
by ilu
As I said, try again with the SolydXEE 201902 ISO (updated kernel, your machine may need it) and report back.

Re: Freezes at progress login

Posted: 05 Jun 2019 14:15
by ydek
Hello Ajile,
Besides the ilu tips you can use another program to write the ISOs like Etcher.

Re: Freezes at progress login

Posted: 05 Jun 2019 20:39
by Ajile
I tried the SolydXEE 201902 ISO (with UNetbootin, I haven't tried Etcher yet) and I thought it worked (because I saw the SolydX background and the right side was blinking to indicate that it was loading, but unfortunately after hours it was still doing that). I then used Ctrl+Alt+Delete twice and it (without restarting) showed the UNetbootin menu with fewer options:
- Memory Diagnostic Tool
- System shutdown
- Start SolydX EE 10 64-bit 201902
- Start SolydX EE 10 64-bit 201902 (safe)

It didn't reply to anything anymore, so I couldn't choose anything from the menu and I had to use the power button to turn my computer off. It showed the following below the blue menu:
[ 0.243767] ACPI Error: Method parse/execution failed \_SB.PCI0.SPI1.FPNT._CRS, AE_AML_INVALID_RESOURCE_TYPE (20180810/psparse-516)
[ 0.243850] ACPI Error: Method execution failed \_SB.PCI0.SPI1.FPNT._CRS, AE_AML_INVALID_RESOURCE_TYPE (20180810/uteval-69)
[ 0.244724] ACPI Error: Method parse/execution failed \_SB.PCI0.SPI2.FPNT._CRS, AE_AML_INVALID_RESOURCE_TYPE (20180810/psparse-516)
[ 0.244816] ACPI Error: Method execution failed \_SB.PCI0.SPI2.FPNT._CRS, AE_AML_INVALID_RESOURCE_TYPE (20180810/uteval-69)

Re: Freezes at progress login

Posted: 05 Jun 2019 22:39
by Arjen Balfoort
In one of the menus there should be the option for safe boot.
Did you try that?

Re: Freezes at progress login

Posted: 05 Jun 2019 23:36
by ilu
Are you sure the APCI error is the cause of the hangup? It might boot regardless, but some people report a loop. Anyway:
  • Kernel discussions say it's a BIOS bug of your motherboard, so see whether you can update your BIOS. There are reports that companies like Dell already refused to fix their BIOS, so maybe complain to your vendor. RMA?
  • Do you boot UEFI or legacy? Try EFI boot if you haven't already.
  • As Arjen said try safe boot

Re: Freezes at progress login

Posted: 06 Jun 2019 18:11
by Ajile
I have no idea what the cause is.

When I choose safe boot it does the "progress login" thing again. I tried holding down the Left-Shift button on boot, but it then only said "SYSLINUX 4.3 [...] Peter Anvin et al", only reacted to Ctrl+Alt+Delete, and then just showed "SYSLINUX 4.3 [...] Peter Anvin et al" again after restarting.

I tried Etcher (which seems to make my USB invisible to Windows explorer on my laptop even though it said it was a success) and it looks different because it uses Grub. It gave many I/O errors, including "Buffering I/O" and "failed to IDENTIFY (I/O error, err_mask=0x4)". It also said "Unable to find a medium containing a live file system".

I tried https://askubuntu.com/questions/953666/ ... -cant-boot but it then keeps loading the right side of the SolydX background indefinitely again.

After Ctrl+Alt+Delete it (among other things) said:
udev requires hotplug support, not started .... failed!

I didn't know how to update the BIOS or use UEFI boot (I think it's legacy) without access to SolydX, so I was thinking: could there be something wrong with my computer (it's supposed to be new, not even refurbished)? Should I try installing Linux Mint or Windows 7?

I then decided to just try it, so I started "Linux Mint 19.1 Tessa - Cinnamon (64-bit)" and it immediately worked. I haven't installed it yet so I can first see if there's a reply to all of the above here, but I might just go with that to keep things simple (not a habit of mine, but the computer issues I mentioned in my first post lasted for three months and in the end both me and a computer repair company couldn't fix them, so I should've just stopped trying earlier).

Re: Freezes at progress login

Posted: 07 Jun 2019 09:27
by ilu
As far as I understand the problem most probably is a faulty ACPI implementation of your motherboard vendor. It was tested with Windows but with nothing else. Linux developers have to reverse engineer the faulty ACPI tables to get things to work. Usually the ACPI errors just delay boot but in your case it seems to be a complete show stopper if even "acpi=off" did not help.

I'm considering to report the problem to Debian. It would be really great if we could get full debug information from the debian/SolydX kernel, but if it doesn't boot ... Could you please try to open a terminal with ctrl-alt-f1 while the SolydX background hangs loading? You'd need to login to the live system (try root - SolydXK Live User password should be solydxk). And then enter:

Code: Select all

sudo dmsg > dmesg.txt
sudo dmidecode > dmidecode.txt
You'll have to copy those files to another pen drive or your data partition (mount it first).

It might very well be that Ubuntu (which Mint is based upon) fixed the problem in their kernel. Could you please use the same commands under Mint live system?

Code: Select all

sudo apt install dmidecode
sudo dmidecode > mintdmidecode.txt
sudo dmsg > mintdmesg.txt
Better don't post, but send those files to me ... @solydxk.com.

Re: Freezes at progress login

Posted: 07 Jun 2019 14:57
by Ajile
Thank you all very much for helping!

I'm going to use Linux Mint for a while and I might switch back in the future (I think I would slightly prefer SolydX). I've now installed Linux Mint and everything seems to be working.

Re: Freezes at progress login

Posted: 08 Jun 2019 14:35
by ilu
That's probably the best way. I could not sort this out. This https://bugzilla.redhat.com/show_bug.cgi?id=1610727 looks like your bug, but reported on a Dell machine which maybe uses the same motherboard your computer has. Dell is involved in Ubuntu development so they probably saw to the bug there.