solydk64 'appears' to be a memory hog [Solved]

Questions about SolydX and SolydK installation.
cwwgateway
Posts: 1215
Joined: 23 Feb 2013 19:14

Re: solydk64 'appears' to be a memory hog

Postby cwwgateway » 09 Mar 2013 19:34

wizard97_4 wrote:
Schoelje wrote: Concluded (for simple souls as I):
To get the used memory: free -m and look at the number on the "buffers/cache" row and the "used" column.
Or short:

Code: Select all

free -m | grep cache: | cut -d' ' -f9
perhaps also:

Code: Select all

free -m | grep buffers/cache | awk '{print $3}'
Both of those work. System monitor applications basically show the result of that command (zerozero has a good system monitor tutorial here: http://forums.solydxk.com/viewtopic.php?f=9&t=168).
Dell XPS 15:
SolydX Debian Testing
SolydK Testing
SolydX Testing
Debian Sid Xfce
Debian Wheezy KDE
Arch Gnome Shell

Gateway:
SolydX Sid
Debian Sid OpenBox
Arch Linux OpenBox
CrunchBang Testing

cecil
Posts: 8
Joined: 26 Feb 2013 19:03

Re: solydk64 'appears' to be a memory hog

Postby cecil » 10 Mar 2013 05:55

Solydk64 'appears' to be a memory hog -- Illustrated Edition

I've reread my original post several times, while terse it seems clear to me.
But every respondent started "with clean install";
so I've clearly failed to communicate the main point.

So let me be explicit.
There is a bug in the start-up scripts/routines in Solydk64-latest.iso.
It is not in Solydk32 or Solydx.

The primary manifestation of this bug is excessive memory usage
when doing a live-boot of the iso, either in virtual-box or from dvd.

The screen-shot below shows Mint-14-KDE at .30_Gib and Solydk64 at .48_Gib.
vbox-mint14-solydk64-memory-reduced.png
vbox-mint14-solydk64-memory-reduced.png (122.87 KiB) Viewed 979 times
-----vbox-mint14-solydk64-memory.png-----

Looking at the memory usage in system-monitor, I saw all the core kde apps had
double entries and immediately recognized this as two kde sessions of the same user.

Live-boot of Solydk64-latest.iso starts two kde sessions.

solydk64.iso-running-in-virtualbox-reduced.png
solydk64.iso-running-in-virtualbox-reduced.png (147.4 KiB) Viewed 979 times
-----solydk64.iso-running-in-virtualbox.png-------

Above is my Mint-KDE with two sessions compared to the Solydk64 v-box boot,
you see the same double listing of all core kde files.

Booting of a v-box install to a virtual-hard-disk shows normal memory usage (~.32Gib),
and so I stated that this "will not effect installed os."
That is not entirely correct.

Since the original post I have burned a DVD.
Booting from the DVD you can see the KDE progress bar start over,
and you can switch between the two identical sessions with Ctrl-alt-F7 / Ctrl-Alt-F8.

I have also done a real install to a partition.
(bye-bye LMDE - fyi .34_GiB with 1920*1080 screen)

Memory usage is normal, but the bug is still there.
Your desktop is on VT8 instead of VT7, Ctrl-Alt-F7 shows one line on a black screen:

(process:nnn)GLib-Warning **:getp uuid_rl(): failed due to unknown user id(0)

This appears to me as a failed attempt to start a root session.

And finally, if you "Log out", you get a black screen instead of a new login screen.

This is not a new bug, it goes back to lmdekde64_up5sr2_201210.iso,
that is the earliest iso I have.
I have not found it in any xfce or 32bit iso.

I hope this clarifies my post.
I am not saying Solydk64 is a memory hog;
I am sayings doing a live boot of the iso makes it 'appear' to be.

User avatar
Arjen Balfoort
Site Admin
Posts: 9394
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: solydk64 'appears' to be a memory hog

Postby Arjen Balfoort » 10 Mar 2013 07:38

I can confirm this bug in the live version of SolydK 64-bit.
Thanks Cecil, for taking the time to report this (and even try to explain it for a simple soul like I).

The glib-warning is related to an old bug in Plymouth (https://bugs.launchpad.net/ubuntu/+sour ... bug/572279).
Booting without Plymouth however, does not prevent the double entries of the K-processes. So, the glib-warning and your bug seem unrelated.
After install the double entries are gone (as you said: it only affects SolydK 64-bit live).

I suspect it has something to do with live-boot and KDE (and maybe also because its multiarch), but tracing this one is going to be very hard and time-consuming.

I'll put this one on my todo list but because it only affects SolydK 64-bit while running live and doesn't break anything, it's not my highest priority.

If anyone can shed some light on this one, I'd be very much obliged.


SolydXK needs you!
Development | Testing | Translations

cecil
Posts: 8
Joined: 26 Feb 2013 19:03

solydk64 'appears' to be a memory hog [Solved]

Postby cecil » 23 Jun 2013 23:55

Live boot of the iso by virtual-box or LiveDVD no longer has excessive memory usage
or double sessions with the new solydk64-201306.iso.

The second problem revealed, booting to VT8 instead VT7, might be related to a new problem.
Ctrl Alt F7 Freezes SolydK64 (because the system desktop is on VT8).
http://forums.solydxk.nl/viewtopic.php?f=13&t=809


Return to “Installation”

Who is online

Users browsing this forum: Bing [Bot] and 6 guests