vainfo/glxinfo fails and libGL error

Questions about hardware, drivers and peripherals.
In the Original Post please also include the output of inxi -Fzx
User avatar
ilu
Posts: 2045
Joined: 09 Oct 2013 12:45

vainfo/glxinfo fails and libGL error

Postby ilu » 24 Sep 2018 13:27

While trying to debug somebody else's problem I noticed that glxinfo produces errors on my system.

Code: Select all

LIBGL_DEBUG=verbose glxinfo -i
name of display: :0.0
libGL: Can't open configuration file /home/.../.drirc: No such file or directory.
libGL: pci id for fd 4: 1002:683f, driver radeonsi
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/tls/radeonsi_dri.so
libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so
libGL: Can't open configuration file /home/.../.drirc: No such file or directory.
libGL: Can't open configuration file /home/.../.drirc: No such file or directory.
libGL: Using DRI3 for screen 0
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  156 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  43
  Current serial number in output stream:  46

Code: Select all

vainfo
libva info: VA-API version 0.39.4
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/radeonsi_drv_video.so
libva info: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit
Edit: My system has only /usr/lib/x86_64-linux-gnu/dri/radeonsi_dri.so. It seems I was missing mesa-va-drivers. I'm not sure whether vainfo is part of the standard install or whether I installed it later.
I still would like to know why glxinfo -i fails.

Return to “Hardware”

Who is online

Users browsing this forum: No registered users and 2 guests