Sound Card Database

Questions about hardware, drivers and peripherals.
In the Original Post please also include the output of inxi -Fzx
cwwgateway
Posts: 1215
Joined: 23 Feb 2013 19:14

Sound Card Database

Postby cwwgateway » 04 Mar 2013 23:58

There have been a number of sound card issues recently, so this will hopefully serve as a database for solutions for specific cards. Most of the sound cards will be identified based on the output of inxi (preferably inxi -Ax, but also inxi -F and inxi -A).

Model=Generic Fix

This has been tested with the following cards:

zerozero's card, here http://forums.solydxk.nl/viewtopic.php?f=6&t=137#p1129

Code: Select all

zerozero@home ~ $ inxi -Axx
Audio:     Card: Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:1e20
           Sound: Advanced Linux Sound Architecture ver: 1.0.24
This was the previous defualt in SolydXK, but it has since been changed to the above.

Change the following at the bottom of /etc/modprobe.d/alsa-base.conf
There is a line that looks like this:

Code: Select all

options snd-hda-intel model=auto
Change it so that it looks like this:

Code: Select all

options snd-hda-intel model=generic
The Most Common Fix
This is now default in SolydXK

For many cards, the following fix will apply. The following cards have been tested with it:

anxova's card, here: http://forums.solydxk.nl/viewtopic.php? ... 4397#p4308

Code: Select all

Audio:     Card Intel 82801H (ICH8 Family) HD Audio Controller driver snd_hda_intel BusID: 00:1b.0
           Sound: Advanced Linux Sound Architecture Version 1.0.24
drum's card, here: http://forums.solydxk.nl/viewtopic.php? ... rt=10#p889

Code: Select all

Audio: Card Intel NM10/ICH7 Family High Definition Audio Controller driver snd_hda_intel BusID: 00:1b.0
Sound: Advanced Linux Sound Architecture Version 1.0.24
My card:

Code: Select all

christopher@chris-laptop-kde ~ $ inxi -Ax
Audio:     Card Intel 6 Series/C200 Series Chipset Family High Definition Audio Controller driver snd_hda_intel BusID: 00:1b.0
           Sound: Advanced Linux Sound Architecture Version 1.0.24
17xeros's card here: http://forums.solydxk.nl/viewtopic.php? ... 2146#p2146:

Code: Select all

Audio: Card Intel 82801I (ICH9 Family) HD Audio Controller driver snd_hda_intel
Sound: Advanced Linux Sound Architecture Version 1.0.24
Otrod's card, here: http://forums.solydxk.nl/viewtopic.php? ... 2232#p2303:

Code: Select all

Audio:     Card Intel 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller driver snd_hda_intel BusID: 00:1b.0
           Sound: Advanced Linux Sound Architecture Version 1.0.24
Mr. B's two cards, here: http://forums.solydxk.nl/viewtopic.php? ... 3792#p3784:

Code: Select all

Audio:     Card Intel 82801H (ICH8 Family) HD Audio Controller driver snd_hda_intel BusID: 00:1b.0
           Sound: Advanced Linux Sound Architecture Version 1.0.24

Code: Select all

Audio:     Card Intel NM10/ICH7 Family High Definition Audio Controller driver snd_hda_intel BusID: 00:1b.0
           Sound: Advanced Linux Sound Architecture Version 1.0.24
BostonPeng's card here: http://forums.solydxk.nl/viewtopic.php? ... 5156#p5136

Code: Select all

$ inxi -Ax
Audio:     Card Intel 82801I (ICH9 Family) HD Audio Controller driver snd_hda_intel BusID: 00:1b.0
           Sound: Advanced Linux Sound Architecture Version 1.0.24
$ 
crizzly's card:

Code: Select all

crizzly@baer ~ $ inxi -Axx
Audio:     Card-1: NVIDIA GF119 HDMI Audio Controller bus-ID: 02:00.1 chip-ID: 10de:0e08 Sound: ALSA ver: 1.0.25
           Card-2: C-Media CM8738 driver: snd_cmipci port: d800 bus-ID: 01:08.0 chip-ID: 13f6:0111
crizzly@baer ~ $ 
Change the following at the bottom of /etc/modprobe.d/alsa-base.conf
There is a line that looks like this:

Code: Select all

options snd-hda-intel model=generic
Change it so that it looks like this:

Code: Select all

options snd-hda-intel model=auto
Other Fixes

If this didn't work for you, other options that have worked include adding the following to /etc/modprobe.d/alsa-base.conf:
Erro's card, here: http://forums.solydxk.nl/viewtopic.php?f=6&t=92

Code: Select all

    inxi -Ax                       
    Audio:     Card-1 Advanced Micro Devices [AMD] nee ATI RV620 HDMI Audio [Radeon HD 3400 Series] driver snd_hda_intel BusID: 01:00.1
               Card-2 Intel 82801I (ICH9 Family) HD Audio Controller driver snd_hda_intel BusID: 00:1b.0
               Sound: Advanced Linux Sound Architecture Version 1.0.24
His fix was to change:

Code: Select all

options snd-hda-intel model=auto
to:

Code: Select all

options snd-hda-intel model=asus-laptop 
For gkgazza27 here: http://forums.solydxk.nl/viewtopic.php?f=6&t=195#p1698 with this sound card:

Code: Select all

gkgazza27@gkgazza27-desktop:~$ inxi -Ax
Audio:     Card Intel NM10/ICH7 Family High Definition Audio Controller driver snd_hda_intel BusID: 00:1b.0
           Sound: Advanced Linux Sound Architecture Version 1.0.24
And josk here: http://forums.solydxk.nl/viewtopic.php? ... 1991#p1983 With these two sound cards:

Code: Select all

Audio:     Card NVIDIA MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio driver snd_hda_intel BusID: 00:07.0
           Sound: Advanced Linux Sound Architecture Version 1.0.24
And:

Code: Select all

Audio:  Card-1 NVIDIA MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio driver snd_hda_intel BusID: 00:07.0
           Card-2 NVIDIA High Definition Audio Controller driver snd_hda_intel BusID: 03:00.1
           Sound: Advanced Linux Sound Architecture Version 1.0.24
The solution was to remove pulseaudio:

Code: Select all

apt purge pulseaudio*

Code: Select all

apt remove pavucontrol
And to change (note that model=auto is now the defualt):

Code: Select all

options snd-hda-intel model=generic
to

Code: Select all

options snd-hda-intel model=auto
Stelios' solutions for ALC8xx and ALC9xx cards that are on some ASUS Motherboards are here: http://forums.solydxk.nl/viewtopic.php? ... 2078#p2078
He changed

Code: Select all

options snd-hda-intel model=auto
to the following if you have a SPDIF output (which worked for orestes1986 here: http://forums.solydxk.nl/viewtopic.php? ... 3198#p3198 ):

Code: Select all

options snd-hda-intel model=5stack-digout position_fix=0
Or the following if you do not:

Code: Select all

options snd-hda-intel model=5stack position_fix=0
If neither work, then try the following:

Code: Select all

options snd-hda-intel model=auto position_fix=0
Further Reading

Slackware has a document here: http://docs.slackware.com/howtos:hardwa ... -hda-intel

Ubuntu has a help page here: https://help.ubuntu.com/community/HdaIntelSoundHowto

Ubuntu has a french document here: http://doc.ubuntu-fr.org/audio_intel_hda

Ubuntu has a large list here: http://ubuntuforums.org/showthread.php?t=1043568

Alsa also has a list here: http://git.alsa-project.org/?p=alsa-ker ... xt;hb=HEAD

solydxk-system 1.0.4 Update

solydxk-system update 1.0.4 adds the following to your /etc/modprobe.d/alsa-base.conf file. If you've changed it, you must remove the following line:

Code: Select all

options snd-hda-intel model=generic
Subsequent versions (1.0.5 and beyond) don't cause this.
Dell XPS 15:
SolydX Debian Testing
SolydK Testing
SolydX Testing
Debian Sid Xfce
Debian Wheezy KDE
Arch Gnome Shell

Gateway:
SolydX Sid
Debian Sid OpenBox
Arch Linux OpenBox
CrunchBang Testing

User avatar
Arjen Balfoort
Site Admin
Posts: 9219
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Sound Card Database

Postby Arjen Balfoort » 05 Mar 2013 09:04

Very good initiative!
If we can get a complete database, I might be able to implement this in DDM.

The first thing I can do is to set the "options snd-hda-intel model=auto" option as default in the iso's.
That seems to cover quiet a number of cards, or am I mistaken?


SolydXK needs you!
Development | Testing | Translations

User avatar
CjTX2
Posts: 170
Joined: 23 Feb 2013 15:42
Location: Texas

Re: Sound Card Database

Postby CjTX2 » 05 Mar 2013 17:26

Do you need/want the inxi outputs for systems worked or only for the ones with problems?

Building new machine named Garfield II & still using an old T42 Thinkpad that's old and slow, but just keeps on going and going . . . sorta like me! :lol:

User avatar
Arjen Balfoort
Site Admin
Posts: 9219
Joined: 26 Jan 2013 19:36
Location: Netherlands
Contact:

Re: Sound Card Database

Postby Arjen Balfoort » 05 Mar 2013 18:23

CjTX2 wrote:Do you need/want the inxi outputs for systems worked or only for the ones with problems?
Only the problematic ones, or else it'll become too complicated.
It's my intention to keep DDM as simple and flexible as possible.


SolydXK needs you!
Development | Testing | Translations

User avatar
CjTX2
Posts: 170
Joined: 23 Feb 2013 15:42
Location: Texas

Re: Sound Card Database

Postby CjTX2 » 05 Mar 2013 19:58

Here in the United States, that's what we call KISSing a project. (Keep It Simple Stupid) :lol: Good idea.

Building new machine named Garfield II & still using an old T42 Thinkpad that's old and slow, but just keeps on going and going . . . sorta like me! :lol:

User avatar
zerozero
Posts: 5373
Joined: 10 Feb 2013 23:37
Location: West Midlands, England
Contact:

Re: Sound Card Database

Postby zerozero » 05 Mar 2013 22:27

i have to update this:

Code: Select all

options snd-hda-intel model=auto
doesn't give me sound through the headphones

Code: Select all

zerozero@solydk ~ $ inxi -Axx
Audio:     Card: Intel 7 Series/C210 Series Chipset Family High Definition Audio Controller 
           driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:1e20 
           Sound: Advanced Linux Sound Architecture ver: k3.7.0-9.dmz.2-liquorix-amd64
zerozero@solydk ~ $ 
i had this issue in the beginning but

Code: Select all

options snd-hda-intel model=generic
solved it;
changing to auto keeps sound on the speakers but mutes the headphones
bliss of ignorance

cwwgateway
Posts: 1215
Joined: 23 Feb 2013 19:14

Re: Sound Card Database

Postby cwwgateway » 05 Mar 2013 23:24

Thanks zerozero, I'll update the post.

Edit: If it works with the default configuration, I'll remove it for right now. If the default changes to auto in some release down the road, I'll start including cards that work with model=generic.
Dell XPS 15:
SolydX Debian Testing
SolydK Testing
SolydX Testing
Debian Sid Xfce
Debian Wheezy KDE
Arch Gnome Shell

Gateway:
SolydX Sid
Debian Sid OpenBox
Arch Linux OpenBox
CrunchBang Testing

User avatar
gkgazza27
Posts: 22
Joined: 05 Mar 2013 13:27

Re: Sound Card Database

Postby gkgazza27 » 12 Mar 2013 15:20

hi to all, this is great work cwwgateway, in my alsa-base.conf. file I have both (generic and auto) options, my query is would the system use both options, choosing which it will use depending on the device we are using, I have read a lot of the stuff that are written in the links you provide, and it seems that a lot of this options 'generic' 'auto' do good on the use of a lot of different devices like 'mic' 'headphone' 'laptop', so I got to think what would happen if I have a couple of this options in the file
System: Host gkgazza27-desktop Kernel 3.2.0-4-686-pae i686 (32 bit) Distro SolydXK 1 debian
CPU:Dual core Intel Atom N570/Graphics: Card Intel Atom Processor /Audio:Card Intel NM10/ICH7/Network:Card-1 Atheros AR9285 Wireless/Card-2 Atheros AR8152 v1.1

cwwgateway
Posts: 1215
Joined: 23 Feb 2013 19:14

Re: Sound Card Database

Postby cwwgateway » 12 Mar 2013 18:56

gkgazza27 wrote:hi to all, this is great work cwwgateway, in my alsa-base.conf. file I have both (generic and auto) options, my query is would the system use both options, choosing which it will use depending on the device we are using, I have read a lot of the stuff that are written in the links you provide, and it seems that a lot of this options 'generic' 'auto' do good on the use of a lot of different devices like 'mic' 'headphone' 'laptop', so I got to think what would happen if I have a couple of this options in the file
TBH I don't know. If you think of it like a command, the last one in the file, but I don't know if that's correct. I'm more of a messenger :) , I don't have that much experience with alsa-base.conf settings.
Dell XPS 15:
SolydX Debian Testing
SolydK Testing
SolydX Testing
Debian Sid Xfce
Debian Wheezy KDE
Arch Gnome Shell

Gateway:
SolydX Sid
Debian Sid OpenBox
Arch Linux OpenBox
CrunchBang Testing

User avatar
gkgazza27
Posts: 22
Joined: 05 Mar 2013 13:27

Re: Sound Card Database

Postby gkgazza27 » 12 Mar 2013 22:57

@cwwgateway
got it mate :)
System: Host gkgazza27-desktop Kernel 3.2.0-4-686-pae i686 (32 bit) Distro SolydXK 1 debian
CPU:Dual core Intel Atom N570/Graphics: Card Intel Atom Processor /Audio:Card Intel NM10/ICH7/Network:Card-1 Atheros AR9285 Wireless/Card-2 Atheros AR8152 v1.1

josk
Posts: 33
Joined: 09 Mar 2013 19:16

Re: Sound Card Database

Postby josk » 13 Mar 2013 23:10

I fixed it by removing pulseaudio and changing the generic text to be auto in following config line:
options snd-hda-intel model=auto

cwwgateway
Posts: 1215
Joined: 23 Feb 2013 19:14

Re: Sound Card Database

Postby cwwgateway » 13 Mar 2013 23:18

josk wrote:I fixed it by removing pulseaudio and changing the generic text to be auto in following config line:
options snd-hda-intel model=auto
could you post the output of running the following in the terminal?:

Code: Select all

inxi -Ax
It will show us your sound card info so we know which card this is necessary with.
Dell XPS 15:
SolydX Debian Testing
SolydK Testing
SolydX Testing
Debian Sid Xfce
Debian Wheezy KDE
Arch Gnome Shell

Gateway:
SolydX Sid
Debian Sid OpenBox
Arch Linux OpenBox
CrunchBang Testing

josk
Posts: 33
Joined: 09 Mar 2013 19:16

Re: Sound Card Database

Postby josk » 14 Mar 2013 06:27

cwwgateway wrote:
josk wrote:I fixed it by removing pulseaudio and changing the generic text to be auto in following config line:
options snd-hda-intel model=auto
could you post the output of running the following in the terminal?:

Code: Select all

inxi -Ax
It will show us your sound card info so we know which card this is necessary with.
Ok, I converted two of my pc's to SolydK and both of them got the same "no sound" issue.

HTPC - I use HDMI OUT for outputting the sound.

Code: Select all

Audio:     Card NVIDIA MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio driver snd_hda_intel BusID: 00:07.0
           Sound: Advanced Linux Sound Architecture Version 1.0.24
My other PC - I use SPDIF OUT (CARD1) for outputting the sound.

Code: Select all

Audio:  Card-1 NVIDIA MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio driver snd_hda_intel BusID: 00:07.0
           Card-2 NVIDIA High Definition Audio Controller driver snd_hda_intel BusID: 03:00.1
           Sound: Advanced Linux Sound Architecture Version 1.0.24
With this option: "options snd-hda-intel model=generic". I wasn't able even the see the spdif output in phonon. Both pc got fixed by removing pulseaudio (I just hate it. Package of extra latency and serious problems if you are using digital outputs.) and changing that GENERIC text to AUTO.

cwwgateway
Posts: 1215
Joined: 23 Feb 2013 19:14

Re: Sound Card Database

Postby cwwgateway » 14 Mar 2013 10:29

Ok, great :D . I'll edit the original post now.
Dell XPS 15:
SolydX Debian Testing
SolydK Testing
SolydX Testing
Debian Sid Xfce
Debian Wheezy KDE
Arch Gnome Shell

Gateway:
SolydX Sid
Debian Sid OpenBox
Arch Linux OpenBox
CrunchBang Testing

17xeros
Posts: 42
Joined: 23 Feb 2013 16:20

Re: Sound Card Database

Postby 17xeros » 15 Mar 2013 23:58

Audio: Card Intel 82801I (ICH9 Family) HD Audio Controller driver snd_hda_intel
Sound: Advanced Linux Sound Architecture Version 1.0.24
Internal microphone was not working.
changing the last lines of /etc/modprobe.d/alsa.conf
options snd-hda-intel model=auto
#options snd-hda-intel model=generic
#options snd-hda-intel model=generic
fixed the problem for this card as well.
It's all geek to me
Zetor 25A. Zetor 2.1L 25hp, 12V 150Amp-hours, 4x2 2WD

wayne
Posts: 178
Joined: 25 Feb 2013 14:58

Re: Sound Card Database

Postby wayne » 16 Mar 2013 03:04

my cards

Code: Select all


wayne@solydx32:~$ inxi -Ax
Audio:     Card-1 Intel 5 Series/3400 Series Chipset High Definition Audio driver snd_hda_intel BusID: 00:1b.0
           Card-2 Advanced Micro Devices [AMD] nee ATI Cedar HDMI Audio [Radeon HD 5400/6300 Series] driver snd_hda_intel BusID: 01:00.1
           Sound: Advanced Linux Sound Architecture Version 1.0.24
no issue on sound.

cwwgateway
Posts: 1215
Joined: 23 Feb 2013 19:14

Re: Sound Card Database

Postby cwwgateway » 16 Mar 2013 15:14

Thanks wayne and 17xeros for the card details.

wayne, do you mind checking if model=auto works (basically what 17xeros did)? It seems model=auto and model=generic are the two most common options, but model=auto *seems* to at least attempt to support more cards. I'm curious if it would break the cards that work with model=generic (like it did for zerozero).
Dell XPS 15:
SolydX Debian Testing
SolydK Testing
SolydX Testing
Debian Sid Xfce
Debian Wheezy KDE
Arch Gnome Shell

Gateway:
SolydX Sid
Debian Sid OpenBox
Arch Linux OpenBox
CrunchBang Testing

User avatar
stelios
Posts: 128
Joined: 28 Feb 2013 21:31
Location: Athens

Re: Sound Card Database

Postby stelios » 16 Mar 2013 19:37

cwwgateway wrote:Thanks wayne and 17xeros for the card details.

wayne, do you mind checking if model=auto works (basically what 17xeros did)? It seems model=auto and model=generic are the two most common options, but model=auto *seems* to at least attempt to support more cards. I'm curious if it would break the cards that work with model=generic (like it did for zerozero).
model=auto for on-board sound chips does not work, when the motherboard BIOS is either broken or non-standard. After all, that's what this setting does: it reads the BIOS information regarding the on-board sound chip and attempts to configure the hda-intel driver accordingly. The setting "generic" is normally used for debugging. So it is perfectly normal that a card that fails to be configured correctly using the "auto" setting might work using the "generic" one.

What i am trying to say, is that the "auto" setting, does not break the "generic" one. It simply fails because of a broken or non-standrad BIOS, in which case "generic" can be used.

User avatar
Otrod
Posts: 35
Joined: 16 Mar 2013 15:31
Location: Barcelona

Re: Sound Card Database

Postby Otrod » 17 Mar 2013 12:24

My card:

Code: Select all

Audio:     Card Intel 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller driver snd_hda_intel BusID: 00:1b.0
           Sound: Advanced Linux Sound Architecture Version 1.0.24
My speakers were completely muted (not so the headphones), and changing my etc/modprobe.d/alsa-base.conf file from

Code: Select all

options snd-hda-intel model=generic
to

Code: Select all

options snd-hda-intel model=auto
solved it. Besides that, muting the system from the sound applet was irreversible (even for the headphones). Removing PulseAudio

Code: Select all

apt purge pulseaudio*
fixed that too. I hope it helps.
scared of my computer

wayne
Posts: 178
Joined: 25 Feb 2013 14:58

Re: Sound Card Database

Postby wayne » 17 Mar 2013 13:04

cwwgateway wrote:
wayne, do you mind checking if model=auto works (basically what 17xeros did)? It seems model=auto and model=generic are the two most common options, but model=auto *seems* to at least attempt to support more cards. I'm curious if it would break the cards that work with model=generic (like it did for zerozero).

Hi cww,

just tried for your database :mrgreen:

and on this file /etc/modprobe.d/alsa-base.conf


A: this is solydX32, there is no line that read
options snd-hda-intel model=generic
or
options snd-hda-intel model=auto

Code: Select all

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7
# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd$
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modp$
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modp$
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2

anyway just to complete the test, I added the line, then reboot to check..
1. original no line
2. added model=auto
3. added model=generic

in ALL cases, sound works.. perhaps that line does not apply to my sound chip :!: :?:

for curiosity,
check a few other distros.
ubuntu variant had a lot more stuff in that file...no sound issue for all of them.

randomly check a few debian distros
2 had the line with model=generic, no sound issue
1 does not even have the file... i guess it is somewhere else. no sound issue too

old case, LMDE, lost sound after d-u.. I remove pulse-audio completely and install alsa to get sound working :mrgreen:


Return to “Hardware”

Who is online

Users browsing this forum: No registered users and 1 guest